This discussion is archived
5 Replies Latest reply: Jun 18, 2009 7:26 AM by 543302 RSS

Post install v 1.3 errors

619509 Newbie
Currently Being Moderated
Hello

I was trying to intall ILM Assistant v 1.3 on XE 10.2.0.1.0. First problems came up when I started installation script (error in part which determine major and mintor instance version) but I managed to overcome this modyfing ilma_installation.sql script and installation went without errors.
After succesfull installation I tried execute ilma_post_install.sql script but recived errors show below:

ILM Assistant - building required cache - this could take several hours

Error starting at line 32 in command:
begin
ilm_toolkit.ilm_toolkit.refresh_cache_job('ILM_TOOLKIT');
end;
Error report:
ORA-06502: PL/SQL: numeric or value error: character to number conversion error
ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 15283
ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 875
ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 913
ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 1000
ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 15826
ORA-06512: at line 2
+06502. 00000 - "PL/SQL: numeric or value error%s"+
*Cause:+

*Action:+

Do you know solution how to overcome this?

Thank you
  • 1. Re: Post install v 1.3 errors
    543302 Newbie
    Currently Being Moderated
    Hi,

    The ILM Assistant is failing due to the XE version number. From the SQL*Plus command line, enter the following:

    select value from v$parameter
    where name = 'compatible'

    Let me know what prints.

    Also, you said you fixed up the installation script to handle the version. Can you post your fix-up? I suspect the two problems are related.

    Thanks,

    Greg
  • 2. Re: Post install v 1.3 errors
    619509 Newbie
    Currently Being Moderated
    Thank you for answer Greg.

    SQL statement
    select value from v$parameter where name = 'compatible'
    returns +10.2.0.1.0+

    My modyfication are marked in bold below (this is part of ilma_install.sql file). I simply set major and minor variables.

    DECLARE
    l_buf VARCHAR2(30);
    l_major BINARY_INTEGER;
    l_minor BINARY_INTEGER;
    l_loc BINARY_INTEGER;
    proc VARCHAR2(30);
    BEGIN
    SELECT version INTO l_buf
    FROM v$instance
    WHERE ROWNUM = 1;

    l_loc := instr(l_buf,'.');

    --l_major := substr(l_buf,1,l_loc - 1);*
    l_buf := substr(l_buf,l_loc + 1);
    --l_minor := substr(l_buf,1,instr(l_buf,'.'));*
    l_major := 10;
    l_minor := 2;

    IF l_major < 9 then
    :prvtilmb_file := 'Unsupported';
    :prvtilms_file := 'Unsupported';
    ELSIF l_major = 9 THEN
    :prvtilmb_file := 'prvtilmb09.plb';
    :prvtilms_file := 'prvtilms09.plb';
    ELSIF l_major = 10 AND l_minor = 2 THEN
    :prvtilmb_file := 'prvtilmb10.plb';
    :prvtilms_file := 'prvtilms10.plb';
    ELSIF l_major = 10 AND l_minor < 2 THEN
    :prvtilmb_file := 'prvtilmb09.plb';
    :prvtilms_file := 'prvtilms09.plb';
    ELSE
    :prvtilmb_file := 'prvtilmb11.plb';
    :prvtilms_file := 'prvtilms11.plb';
    END IF;
    END;
    /
  • 3. Re: Post install v 1.3 errors
    705003 Newbie
    Currently Being Moderated
    Hi Greg,

    I am trying to install oracle ILM version 1.4

    Environment details
    OS : Solaris 5.10
    Oracle : 11.1.0.7.0
    APEX : 3.2

    Installation finishes without errors

    but post_installation script run give me errors

    SQL> @ilma_post_install.sql

    Session altered.


    Session altered.

    ILM Assistant - building required cache - this could take several hours
    begin
    *
    ERROR at line 1:
    ORA-06502: PL/SQL: numeric or value error: character string buffer too small
    ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 14890
    ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 14970
    ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 15645
    ORA-06512: at "ILM_TOOLKIT.ILM_TOOLKIT", line 15834
    ORA-06512: at line 2


    I re-ran install using all options given in your oracle forum comments, but can't resolve the issue. Can you please help.

    Regards,

    Al
  • 4. Re: Post install v 1.3 errors
    543302 Newbie
    Currently Being Moderated
    Sorry for the slow reply. I will investigate and get back to you.

    Thanks,

    Greg
  • 5. Re: Post install v 1.3 errors
    543302 Newbie
    Currently Being Moderated
    Hi,

    I have uploaded an updated library that hopefully resolves your installation problem. The current version of the Assistant is 1.4a, dated 6/18/2009. Please download and install the kit from the ILM Assistant web page.

    Thanks,

    Greg

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points