3 Replies Latest reply on Oct 22, 2008 6:06 PM by 619485

    No BI Publisher contents displayed in Content Viewer

    Kan Nishida-Oracle
      I could connect to BI Publisher from Smart Space client. However, when I access to the BI Publisher from the Content Viewer or Windows Explorer, I could only see 'My Folder' and 'Shared Folder' level but no any folder/reports are displayed. I don't have any problem with BI EE service with Smart Space client.

      Any idea ?
        • 1. Re: No BI Publisher contents displayed in Content Viewer
          662016
          Hi Kan,

          The Smart Space team was at Oracle OpenWorld this week. We'll be back in the office on Monday and then we'll contact you to diagnose the issue. Can you please e-mail me your contact information (e-mail and phone) so we can work with you directly?

          Thanks and have a nice weekend,

          Hackey Weinberger
          Smart Space Product Manager
          hackey.weinberger@oracle.com
          • 2. Re: No BI Publisher contents displayed in Content Viewer
            Kan Nishida-Oracle
            This has been resolved by changing the Java command line to start a J2EE server where BI Publisher is running on. This is documented in the release note. Here is the note.

            --------------------------------------------------------------------------------------------------------------------------------------------------------------------
            3.1.64 Integration With Smart Space, Fusion Edition Requires Update to JVM Parameter

            This issue applies to Version 10.1.3.4.

            To enable BI Publisher to work with Oracle Smart Space, Fusion Edition, you must force the BI Publisher Web service to appear as RPC-encoded. The solution for this issue is to set the JVM parameter described below.



            Important:

            Setting this parameter causes the BI Office component of the Oracle Business Intelligence Enterprise Edition to fail. You therefore cannot integrate BI Publisher with Smart Space if you also wish to use BI Office.



            To enable BI Publisher to integrate with Smart Space, modify the Java command that starts your J2EE application server that runs BI Publisher to include the following parameter:

            -Daxis.ServerConfigFile=server-rpc-config.wsdd

            For example, if you are using the default oc4j.cmd, then change this line:

            set JVMARGS=-Djava.library.path=C:\oracle\bise1\bi\server\Bin;C:\oracle\bise1\bi\web\bin -DSAROOTDIR=C:\oracle\bise1\bi -DSADATADIR=C:\oracle\bise1\bidata -XX:MaxPermSize=128m -Xmx512m %OC4J_JVM_ARGS%

            to this:

            set JVMARGS=-Djava.library.path=C:\oracle\bise1\bi\server\Bin;C:\oracle\bise1\bi\web\bin -DSAROOTDIR=C:\oracle\bise1\bi -DSADATADIR=C:\oracle\bise1\bidata -Daxis.ServerConfigFile=server-rpc-config.wsdd -XX:MaxPermSize=128m -Xmx512m %OC4J_JVM_ARGS%

            If you are not integrating BI Publisher with Oracle Smart Space, then this command is unnecessary
            --------------------------------------------------------------------------------------------------------------------------------------------------------------------

            And the release note is,
            http://download.oracle.com/docs/cd/E10415_01/doc/bi.1013/e10404/bi_pub_rns.htm#CHDGEIIA
            • 3. Re: No BI Publisher contents displayed in Content Viewer
              619485
              This sounds like you have not set the BI Publisher JVM argument in your application server used by BI Publisher to change their web services mode to work with the 11.1.1.0 release of Smart Space.

              To enable BI Publisher to integrate with Smart Space, modify the Java command that starts your J2EE application server that runs BI Publisher to include the following parameter:

              -Daxis.ServerConfigFile=server-rpc-config.wsdd

              For example, if you are using the default oc4j.cmd, then change this line:

              set JVMARGS=-Djava.library.path=C:\oracle\bise1\bi\server\Bin;C:\oracle\bise1\bi\web\bin -DSAROOTDIR=C:\oracle\bise1\bi -DSADATADIR=C:\oracle\bise1\bidata -XX:MaxPermSize=128m -Xmx512m %OC4J_JVM_ARGS%

              to this:

              set JVMARGS=-Djava.library.path=C:\oracle\bise1\bi\server\Bin;C:\oracle\bise1\bi\web\bin -DSAROOTDIR=C:\oracle\bise1\bi -DSADATADIR=C:\oracle\bise1\bidata -Daxis.ServerConfigFile=server-rpc-config.wsdd -XX:MaxPermSize=128m -Xmx512m %OC4J_JVM_ARGS%

              If you are not integrating BI Publisher with Oracle Smart Space, then this command is unnecessary

              In the next release of Smart Space (11.1.1.1), which is expected to be released prior to the end of this calendar year, will not require the BI Publisher JVM argument to be set anymore.