9 Replies Latest reply: Dec 18, 2010 2:01 PM by 765382 RSS

    Invalid Login Credentials


      I have just finished installing oracle-xe using the deb package (oracle-xe-universal_10.2.0.1-1.0_i386). I have configured and now when I try to log in I get "Invalid Login Credentials". I haven't been able to log in once.

      Is there a way to change this password, or is it going to be easier to just install it again? Which ever is the case, could I please have a step-by-step as I am just starting out with oracle.
        • 1. Re: Invalid Login Credentials
          You have provided none of the required information to help you.

          1. What user-id and password are you using to log in?
          2. What is the actual and complete error message you are receiving?
          3. In what tool or at what interface are you entering the login?
          4. What operating system (be very specific)
          5. As what operating system user?
          • 2. Re: Invalid Login Credentials
            I am using system as the user ID and the password that I set during the configuration. When I try to log into the web interface; localhost:8080 I get returned to the login prompt with just the simple error above it saying "Invalid Login Credentials"

            I installed and configured as root, i.e. su and I am logged into the system as my standard user.

            OE is Ubuntu 7.04 32bit

            Edited by: user10381165 on 8/10/2008 14:35
            • 3. Re: Invalid Login Credentials
              I have just had a look through the logs and came across this...

              I hope this helps

              [  OCRUTL][3067926736]u_set_comp_error: Parameter was NULL
              [  OCRUTL][3067926736]u_set_ocr_error: Parameter was NULL
              2008-10-07 19:46:04.057: [  OCROSD][3067926736]utgdv:2:ocr loc file cannot be opened
              2008-10-07 19:46:04.057: [  OCROSD][3067926736]utopen:1: Couldnt find ocr,[ocrmirror] location in config file
              [  OCRUTL][3067926736]u_set_gbl_comp_error: Parameter was NULL
              2008-10-07 19:46:04.057: [  OCRRAW][3067926736]proprinit: Could not open raw device
              2008-10-07 19:46:04.057: [ default][3067926736]a_init:7!: Backend init unsuccessful : [33]
              [  OCRUTL][3067926736]u_set_ocr_error: Parameter was NULL
              2008-10-07 19:46:04.057: [ CSSCLNT][3067926736]clsssinit: error(33 ) in OCR initialization
              • 4. Re: Invalid Login Credentials
                You are using an unsupported operating system and Oracle should never been installed as root or used as root.

                Get a supported o/s and install according to the documentation.
                • 5. Re: Invalid Login Credentials
                  Is there a supported operating system that you could suggest? We run a mix of Ubuntu 7.04 and PC LinuxOS 2007 and run Fedora Core 7 on our server. I don't want to install oracle on the server just yet, until I have finished testing the app.
                  • 6. Re: Invalid Login Credentials
                    You are using an unsupported operating system and Oracle should never been installed as root or used as root.
                    OP is installing XE which has to be installed as root user on any of Linux flavor as it is only provided as rpm or deb package. Even though 'Ubuntu' is not written in installation requirements document, if you try to download XE, you will find message below download link as '- Available for Debian, Mandriva, Novell, Red Hat and Ubuntu'

                    OP: Try to check if you have installed all required libraries like make, glibc, libaio, gcc, gcc++ and so on. Also give a try installation using rpm package installing in verbose mode.
                    • 7. Re: Invalid Login Credentials
                      I ran into the same problem, Invalid Login Credentials, with Ubuntu 10.04. I was sure that I typed in the password that I entered when running the oracle-xe configure script. I wasn't able to change the password by running sqlplus, as suggested here and on other forums. With sqlplus, I received the insufficient privileges message. I also tried reinstallations of oracle-xe but with no result. All these steps were executed as root.
                      Then I decided to copy the oracle environment variables (oracle_home, oracle_sid, path etc.) to the .bashrc file of the user that was logged in. That user belongs to the group dba in /etc/group. After starting a new terminal, I was able to start sqlplus / nolog, then issued the connect /as sysdba command and finally issued the alter user sys identified by <password>; command. That went OK, and finally I was able to login on the database home page with the sys account. I've not yet figured out how oracle checks the credentials, but it seems that only users who belong to the dba group have access to the database and can change the password of sys and system. What the configure script is doing with the entered password is unclear.

                      • 8. Re: Invalid Login Credentials
                        Hi, '
                        I also have the same problem. I login with 'system' and the password which I am sure is the one I gave when intstalling.
                        I would appreciate any help!
                        • 9. Re: Invalid Login Credentials

                          While installing at the last it will ask for users, check the users if they are uncheck
                          cause I got the same problem when i first installed oracle 10g on Winxp
                          I re-installed that and at the last i checked the users accounts that i will use (i.e.system)

                          Hope this will help