3 Replies Latest reply on Oct 31, 2008 11:15 AM by rolfsyd

    Downstream capture 'paused for flow control'

    rolfsyd
      Hi all,



      I run a <strong>real-time downstream capture and apply</strong> process(es) on a downstram (target) host. Because of a critical Windows security patch, I had to reboot the downstream server.

      I first stopped the capture and apply processes before the reboot. After the reboot I started the apply and capture process. The capture process now sits in a <strong>'PAUSED FOR FLOW CONTROL'</strong> state, and no changes are applied to the downstream target.

      I would expect the capture process to catch up where it left off when I stopped it. Can anybody tell me how to get the capture process back on track ?

      Environment is Real-Time downstreaming in 10.2.0.4 on Windows 2003 Server. Any help will be appreciated.



      Regards

      Rolf
        • 1. Re: Downstream capture 'paused for flow control'
          JustinCave
          OK. First off, I'm assuming that you're talking about Streams, rather than any of the other Oracle replication technologies.

          If so, what are the propagation and apply processes doing?

          Justin
          • 2. Re: Downstream capture 'paused for flow control'
            rijesh chandran - oracle
            Hello

            I have explained this in the following thread:

            Apply process is active, idle and just stopped applying changes

            Please check and let me know if you have issues still.

            Thanks,
            Rijesh
            • 3. Re: Downstream capture 'paused for flow control'
              rolfsyd
              Hi again,

              Sorry for the late reponse, I've been busy doing other things...
              Yes Justin, I'm talking about Oracle Streams; real-time downstreaming where both
              capture and apply processes are running on the downstream/target site. The logs
              are distributed to the target over WAN (10 Mbit/s).

              Rijesh; I followed your advice on 'aq_tm_processes', and noticed on my systems that
              this parameter was set to '0' in both source and target. I changed it to '1' in both
              sites, and the 'Paused for flow-control' disappeared ! Changes started to flow downstream
              as the online logs gets archivwed at the source:)

              However; I'm trying to run real-time capturing, having set the DOWNSTREAM_REAL_TIME_MINE=Y.
              This used to work at one point, but now changes are only replicated downstream when the archive
              logs are shipped to the target. The downstream host has experienced downtime due to SAN failure
              which made it unavaileble to the source. The downstream db has also been restarted a couple of times.
              At one time the space of stanfby archive area on the target was exhausted (where the logs from source were shipped to)


              Right now I find in the alert log on the source db:

              LGWR: Error 4030 creating archivelog file 'PA2.GARD.LOCAL'
              Fri Oct 31 09:00:11 2008
              Errors in file c:\oracle\product\10.2.0\admin\padata\bdump\padata_lns1_5088.trc:

              The trace file shows:

              *** SERVICE NAME:(SYS$BACKGROUND) 2008-10-31 09:00:11.039
              *** SESSION ID:(455.5383) 2008-10-31 09:00:11.039
              *** 2008-10-31 09:00:11.039 58902 kcrr.c
              LNS1: initializing for LGWR communication
              LNS1: connecting to KSR channel
              Success
              LNS1: subscribing to KSR channel
              Success
              *** 2008-10-31 09:00:11.039 58955 kcrr.c
              LNS1: initialized successfully ASYNC=1
              Destination is specified with ASYNC=61440
              *** 2008-10-31 09:00:11.070 73045 kcrr.c
              Sending online log thread 1 seq 4049 [logfile 1] to standby
              Redo shipping client performing standby login
              *** 2008-10-31 09:00:11.336 66535 kcrr.c
              Logged on to standby successfully
              Client logon and security negotiation successful!
              Error 4030 attaching RFS server to standby instance at host 'PA2.GARD.LOCAL'
              Error 4030 attaching to destination LOG_ARCHIVE_DEST_2 standby host 'PA2.GARD.LOCAL'
              *** 2008-10-31 09:00:11.414 62692 kcrr.c
              LGWR: Error 4030 creating archivelog file 'PA2.GARD.LOCAL'
              .
              .
              .

              In the alert log on the downstream/target db I have seen this (but not since yesterday, the above from source is from today...):

              Streams CAPTURE C001 with pid=28, OS id=4460 stopped
              Thu Oct 30 11:57:16 2008
              Errors in file c:\oracle\admin\pa2\bdump\pa2_c001_4460.trc:
              ORA-04030: out of process memory when trying to allocate 8389132 bytes (krvxiphd: priv,redo read buffer)


              I have tried to tune/adjust SGA/PGA on the target but does this mean I still have a memory issue on the target ?

              KR
              Rolf