1 Reply Latest reply on Jun 24, 2003 5:03 PM by 3004

    Application working fine on Weblogic 6.1 SP2 but not working on Weblogic 6.1 SP4

    3004

                I have a web application deployed as a war file in WebLogic 6.1 SP2.It works fine.But
                same application does not work in WebLogic 6.1 SP4.It is built using struts framework.
                
                The error I get when I try to run it on WL 6.1 SP4 is as follows:
                
                Error 500--Internal Server Error
                From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
                10.5.1 500 Internal Server Error
                The server encountered an unexpected condition which prevented it from fulfilling
                the request.
                -----------------------------------------------------------------------------------------------------------
                
                When I see the log file...I can see the following:
                (csas is my appln name)
                
                
                0 [Thread-2] INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.util.LocalStrings',
                returnNull=true
                5 [Thread-2] INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.action.ActionResources',
                returnNull=true
                855 [Thread-2] ERROR action.ActionServlet - Parsing error processing resource
                path
                java.lang.NullPointerException
                     at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:941)
                     at org.apache.struts.action.ActionServlet.init(ActionServlet.java:468)
                     at javax.servlet.GenericServlet.init(GenericServlet.java:258)
                     at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:731)
                     at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:658)
                     at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:603)
                     at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:2360)
                     at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:2301)
                     at weblogic.servlet.internal.HttpServer.preloadServlets(HttpServer.java:558)
                     at weblogic.servlet.internal.WebService.preloadServlets(WebService.java:450)
                     at weblogic.t3.srvr.ServletInitRunner.run(ServletInitRunner.java:49)
                     at java.lang.Thread.run(Thread.java:479)
                
                javax.servlet.UnavailableException: Parsing error processing resource path
                     at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:952)
                     at org.apache.struts.action.ActionServlet.init(ActionServlet.java:468)
                     at javax.servlet.GenericServlet.init(GenericServlet.java:258)
                     at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:731)
                     at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:658)
                     at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:603)
                     at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:2360)
                     at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:2301)
                     at weblogic.servlet.internal.HttpServer.preloadServlets(HttpServer.java:558)
                     at weblogic.servlet.internal.WebService.preloadServlets(WebService.java:450)
                     at weblogic.t3.srvr.ServletInitRunner.run(ServletInitRunner.java:49)
                
                <May 21, 2003 9:49:40 AM EDT> <Error> <HTTP> <[WebAppServletContext(789954,csas,/csas)]
                Servlet failed with Exception
                java.lang.NullPointerException
                     at weblogic.servlet.JSPServlet.service(JSPServlet.java:132)
                     at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
                     at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:262)
                     at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:198)
                     at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:2637)
                     at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2359)
                     at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
                     at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
                >
                <May 21, 2003 9:56:10 AM EDT> <Error> <HTTP> <[WebAppServletContext(5626240,portal,/portal)]
                Servlet failed with Exception
                java.lang.NullPointerException
                     at com.epicentric.common.website.SiteNavUtils.storeRootMenuID(SiteNavUtils.java:316)
                     at com.epicentric.common.website.SiteNavUtils.getMenuIterator(SiteNavUtils.java:217)
                     at com.epicentric.common.website.SiteNavUtils.getRebuiltMenuIterator(SiteNavUtils.java:166)
                     at jsp_servlet._templates._template0006._t0006style0001.__site_nav._jspService(__site_nav.java:2701)
                     at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
                     at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:262)
                     at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:321)
                     at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:198)
                     at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:2637)
                     at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2359)
                     at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
                     at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
                
                Kindly help
                
        • 1. Re: Application working fine on Weblogic 6.1 SP2 but not working on Weblogic 6.1 SP4
          3004
          Try the weblogic.developer.interest.servlet newsgroup.
                    
                    "Rajesh Behari Mishra" <rajesh_behari@yahoo.com> wrote in message news:3ecb9c13$1@newsgroups.bea.com...
                    >
                    > I have a web application deployed as a war file in WebLogic 6.1 SP2.It works fine.But
                    > same application does not work in WebLogic 6.1 SP4.It is built using struts framework.
                    >
                    > The error I get when I try to run it on WL 6.1 SP4 is as follows:
                    >
                    > Error 500--Internal Server Error
                    > From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
                    > 10.5.1 500 Internal Server Error
                    > The server encountered an unexpected condition which prevented it from fulfilling
                    > the request.
                    > -----------------------------------------------------------------------------------------------------------
                    >
                    > When I see the log file...I can see the following:
                    > (csas is my appln name)
                    >
                    >
                    > 0 [Thread-2] INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.util.LocalStrings',
                    > returnNull=true
                    > 5 [Thread-2] INFO util.PropertyMessageResources - Initializing, config='org.apache.struts.action.ActionResources',
                    > returnNull=true
                    > 855 [Thread-2] ERROR action.ActionServlet - Parsing error processing resource
                    > path
                    > java.lang.NullPointerException
                    > at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:941)
                    > at org.apache.struts.action.ActionServlet.init(ActionServlet.java:468)
                    > at javax.servlet.GenericServlet.init(GenericServlet.java:258)
                    > at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:731)
                    > at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:658)
                    > at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:603)
                    > at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:2360)
                    > at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:2301)
                    > at weblogic.servlet.internal.HttpServer.preloadServlets(HttpServer.java:558)
                    > at weblogic.servlet.internal.WebService.preloadServlets(WebService.java:450)
                    > at weblogic.t3.srvr.ServletInitRunner.run(ServletInitRunner.java:49)
                    > at java.lang.Thread.run(Thread.java:479)
                    >
                    > javax.servlet.UnavailableException: Parsing error processing resource path
                    > at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:952)
                    > at org.apache.struts.action.ActionServlet.init(ActionServlet.java:468)
                    > at javax.servlet.GenericServlet.init(GenericServlet.java:258)
                    > at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:731)
                    > at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:658)
                    > at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:603)
                    > at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:2360)
                    > at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:2301)
                    > at weblogic.servlet.internal.HttpServer.preloadServlets(HttpServer.java:558)
                    > at weblogic.servlet.internal.WebService.preloadServlets(WebService.java:450)
                    > at weblogic.t3.srvr.ServletInitRunner.run(ServletInitRunner.java:49)
                    >
                    > <May 21, 2003 9:49:40 AM EDT> <Error> <HTTP> <[WebAppServletContext(789954,csas,/csas)]
                    > Servlet failed with Exception
                    > java.lang.NullPointerException
                    > at weblogic.servlet.JSPServlet.service(JSPServlet.java:132)
                    > at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
                    > at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:262)
                    > at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:198)
                    > at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:2637)
                    > at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2359)
                    > at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
                    > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
                    > >
                    > <May 21, 2003 9:56:10 AM EDT> <Error> <HTTP> <[WebAppServletContext(5626240,portal,/portal)]
                    > Servlet failed with Exception
                    > java.lang.NullPointerException
                    > at com.epicentric.common.website.SiteNavUtils.storeRootMenuID(SiteNavUtils.java:316)
                    > at com.epicentric.common.website.SiteNavUtils.getMenuIterator(SiteNavUtils.java:217)
                    > at com.epicentric.common.website.SiteNavUtils.getRebuiltMenuIterator(SiteNavUtils.java:166)
                    > at jsp_servlet._templates._template0006._t0006style0001.__site_nav._jspService(__site_nav.java:2701)
                    > at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
                    > at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:262)
                    > at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:321)
                    > at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:198)
                    > at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:2637)
                    > at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2359)
                    > at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
                    > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
                    >
                    > Kindly help