2 Replies Latest reply on Jul 9, 2002 3:41 PM by 259532

    Communication Link Failure

    214194
      Hi,

      I have been challenged with taking a sql server7 database and converting it over to oracle8i for one of our clients. I work from home so I connect to the sql server database through VPN.

      When I try to capture the source database, I keep getting this error:

      [Microsoft][ODBC SQL Server Driver]Communication link failure.

      I'm at a loss right now of what I need to do get this migrated. I have included in this message information about my odbc dsn and some info from the error log. One other thing is that I'm using the Oracle8i Lite as my repository.

      Any ideas would be greatly appreciated.




      Here's some info about what I have:

      I have downloaded OMWB 2.0.2.0.0
      I have SQL 2000 on my machine at home and the database that I'm trying to convert is SQL7, so I have downloaded plugins for each.

      I have set up my ODBC DSN and these are the configurations for it and the test results which were good.

      Microsoft SQL Server ODBC Driver Version 03.80.0194

      Data Source Name: NPIN_Test
      Data Source Description: NPIN_Test
      Server: Mimosa
      Database: NPIN_TEST
      Language: (Default)
      Translate Character Data: Yes
      Log Long Running Queries: No
      Log Driver Statistics: No
      Use Integrated Security: No
      Use Regional Settings: No
      Prepared Statements Option: Drop temporary procedures on disconnect
      Use Failover Server: No
      Use ANSI Quoted Identifiers: Yes
      Use ANSI Null, Paddings and Warnings: Yes
      Data Encryption: No

      Microsoft SQL Server ODBC Driver Version 03.80.0194

      Running connectivity tests...

      Attempting connection
      Connection established
      Verifying option settings
      Disconnecting from server

      TESTS COMPLETED SUCCESSFULLY!
      *************************************

      When I try to capture the source database, I keep getting this error:

      [Microsoft][ODBC SQL Server Driver]Communication link failure

      When I check the Log file here's some of the stuff in it:

      ** Oracle Migration Workbench
      ** Release 2.0.2.0.0 Production
      ** ( Build 20011121 )

      ** ORACLE_HOME: C:\oracle\ORA9i

      ** user language: en
      ** user region: US
      ** user timezone: EST
      ** file encoding: Cp1252
      ** java version: 1.1.8.10
      ** java vendor: Oracle Corporation
      ** o.s. arch: x86
      ** o.s. name: Windows NT
      ** o.s. version: 5.0

      ** Classpath:

      C:\oracle\ORA9i\Omwb\olite\Oljdk11.jar;C:\oracle\ORA9i\Omwb\olite\Olite40.jar;C:\Program Files\Oracle\jre\1.1.8\lib\rt.jar;C:\Program Files\Oracle\jre\1.1.8\lib\i18n.jar;C:\oracle\ORA9i\Omwb\jlib;C:\oracle\ORA9i\Omwb\jlib\Omwb.jar;C:\oracle\ORA9i\jlib\oembase-9_0_1.jar;C:\oracle\ORA9i\jlib\netcfg.jar;C:\oracle\ORA9i\Omwb\plugins\SQLServer6.jar;C:\oracle\ORA9i\Omwb\plugins\SQLServer7.jar;C:\oracle\ORA9i\Omwb\plugins\SQLServer2K.jar;C:\oracle\ORA9i\Omwb\plugins\Sybase11.jar;C:\oracle\ORA9i\Omwb\plugins\Sybase12.jar;C:\oracle\ORA9i\Omwb\plugins\MSAccess.jar;C:\oracle\ORA9i\Omwb\plugins\MySQL.jar;C:\oracle\ORA9i\Omwb\drivers\mm.mysql.jdbc-1.2a;C:\oracle\ORA9i\Omwb\plugins\Informix7.jar;C:\oracle\ORA9i\Omwb\drivers\ifxjdbc.jar;C:\oracle\ORA9i\lib\xmlparserv2.jar;C:\oracle\ORA9i\rdbms\jlib\xsu111.jar;C:\oracle\ORA9i\jdbc\lib\classes111.zip;C:\oracle\ORA9i\lib\vbjorb.jar;C:\oracle\ORA9i\jlib\ewt-swingaccess-3_3_18.jar;C:\oracle\ORA9i\jlib\ewt-3_3_18.jar;C:\oracle\ORA9i\jlib\ewtcompat-3_3_15.jar;C:\oracle\ORA9i\jlib\share-1_1_9.jar;C:\oracle\ORA9i\jlib\help-3_2_9.jar;C:\oracle\ORA9i\jlib\ice-5_06_3.jar;C:\oracle\ORA9i\jlib\kodiak-1_2_1.jar


      ** Started : Thu Feb 21 11:15:52 EST 2002


      ** The following plugins are installed:
      ** Microsoft SQLServer 7.0 Release 2.0.2.0.0 Production
      ** Microsoft SQLServer 2000 Release 2.0.2.0.0 Production

      java.sql.SQLException: [POL-5167] index does not exist

      EXCEPTION : LoadTableData.run() : SS7_SYSPROTECTS [Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]ConnectionRead (recv()).
      EXCEPTION : LoadTableData.run() : SS7_SYSFILES [Microsoft][ODBC SQL Server Driver]Communication link failure
      EXCEPTION : LoadTableData.run() : SS7_SYSTYPES [Microsoft][ODBC SQL Server Driver]Communication link failure
      EXCEPTION : LoadTableData.run() : SS7_SYSINDEXES [Microsoft][ODBC SQL Server Driver]Communication link failure
      EXCEPTION : LoadTableData.run() : SS7_SYSINDEXKEYS [Microsoft][ODBC SQL Server Driver]Communication link failure
      EXCEPTION : LoadTableData.run() : SS7_SYSREFERENCES [Microsoft][ODBC SQL Server Driver]Communication link failure
      EXCEPTION : LoadTableData.run() : SS7_SYSCONSTRAINTS [Microsoft][ODBC SQL Server Driver]Communication link failure
      EXCEPTION : LoadTableData.run() : SS7_SYSCOMMENTS [Microsoft][ODBC SQL Server Driver]Communication link failure
      EXCEPTION : LoadTableData.run() : SS7_SYSCOLUMNS [Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]ConnectionRead (recv()).




        • 1. re:Communication Link Failure
          3783
          Does the problem repeatably reproduce?

          There is an alternative:
          We have included a disconnected source model load feature to aid loading and maping the source model when connection to the source database is initially poor. bcp and sqlloader are used to take the data out of the source database and load the data into the repository. This will only work with an 8i/9i repository.

          Turloch
          Oracle Migration Workbench Team
          • 2. Disconnected Source Model Load not successful"
            259532
            Migration workbench Team,

            I am working on converting the databases from Informix 7.3 to Oracle 9i. I am following the "Disconnected Source Model Load". Basing on the script provided by Oracle corporation, it seems it is not fully functional, I did modified the script to include the remaining SQL statements to capture the remaining the sysmaster information. I have been successfully through the process, but the final outcome is nothing other than the user creation , only Informix and root from Informix server. I did not found much data about this anywhere. Can you please reply me with the required information to move forward. It is an urgent thing for me.

            Thanks in advance for your kind reply.

            Ramesh

            ramesh_egroup@yahoo.com