5 Replies Latest reply on Feb 9, 2001 12:51 AM by 3004

    Is proxy server running ?

    3004

                Hi !
                how can i be sure of the following ....
                
                1. Has the weblogic.servlet.internal.HttpClusterServlet servlet been loaded when I start proxy server?
                
                2. How can I know that it is servicing the *.jsp requests i.e forwarding these requests to clustered servers behind the proxy?
                
                I have the following settings for my proxy server...
                -----------------------------------------------------------
                weblogic.allow.execute.weblogic.servlet=everyone
                weblogic.httpd.register.cluster=weblogic.servlet.internal.HttpClusterServlet
                weblogic.httpd.initArgs.cluster=\
                     defaultServers=192.168.1.207:7001:7002|192.168.1.204:7001:7002,\ secureProxy=ON
                weblogic.httpd.defaultServlet=cluster
                
                weblogic.system.listenPort=80
                weblogic.system.SSLListenPort=7003
                weblogic.security.ssl.enable=true
                
                weblogic.httpd.register.*.html=\
                weblogic.servlet.FileServlet
                weblogic.httpd.register.*.jpg=\
                weblogic.servlet.FileServlet
                weblogic.httpd.register.*.gif=\
                weblogic.servlet.FileServlet
                -----------------------------------------------------------
                
                
                This is what is displayed on my proxy server when i make a call to simple.jsp which is present in one of the clustered servers.
                
                -----------------------------------------------------------
                
                Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: init
                Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param ver
                bose initialized to: true
                Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param pac
                kagePrefix initialized to: jsp_servlet
                Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param com
                pileCommand initialized to: c:/jdk1.3/bin/javac.exe
                Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param src
                Compiler initialized to weblogic.jspc
                Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param sup
                erclass initialized to null
                Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param wor
                kingDir initialized to: C:\weblogic\myserver\jsp_classes
                Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param pag
                eCheckSeconds initialized to: 1
                Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: initializ
                ation complete
                Tue Dec 05 16:05:41 GMT+01:00 2000:<E> <ServletContext-General> Servlet failed w
                ith Exception
                java.io.FileNotFoundException: no resource '/simple.jsp' in servlet context root
                'C:\weblogic\proxyserver\public_html'
                at weblogic.servlet.JSPServlet.service(JSPServlet.java:105)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:865)
                at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                pl.java:106)
                at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                textImpl.java:907)
                at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                textImpl.java:851)
                at weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                ContextManager.java:252)
                at weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                a:364)
                at weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                
                at weblogic.kernel.ExecuteThread.run(ExecuteThread.java, Compiled Code)
                
                -----------------------------------------------------------
                
                
                3. Does any of the clustered servers throw any output indicating that it serviced a request forwarded by the proxy?
                
                I'm dying to see THAT more than my forthcoming holiday trip to Paris. :o)
                
                
                
                
                
                
        • 1. Re: Is proxy server running ?
          3004

                    Now I have removed all "weblogic.httpd.register..." properties from my Global weblogic.properties file.
                    
                    When I make a request for 'simple.jsp', i think it is then that HttpClusterServlet is loaded and it's init() is fired as indicated by this line .....
                    Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster: init
                    
                    Now I am sure that HttpClusterServlet (The HERO) is in action and not weblogic.servlet.JSPServlet (The VILLAIN).
                    
                    
                    Now, init() must be looking for some parameters, not finding it and throwing a NullPointerException ...
                    
                    Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster: init
                    Tue Dec 05 16:40:07 GMT+01:00 2000:<E> <ServletContext-General> Servlet failed w
                    ith Exception
                    java.lang.NullPointerException
                    at weblogic.servlet.internal.HttpClusterServlet.init(HttpClusterServlet.
                    java:98)
                    at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
                    pl.java:457)
                    at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
                    Impl.java, Compiled Code)
                    at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
                    mpl.java:404)
                    at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
                    java:164)
                    at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                    pl.java:101)
                    at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                    textImpl.java:907)
                    at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                    textImpl.java:851)
                    at weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                    ContextManager.java:252)
                    at weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                    a:364)
                    at weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                    
                    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java, Compiled Code)
                    
                    -----------------------------------------------------------------
                    
                    Phew ! I must have missed something again.
                    Any clues ??????
                    
                    thanks.
                    vikram
                    
                    "Vikram Kulkarni" <kulkis@rediffmail.com> wrote:
                    >
                    >Hi !
                    >how can i be sure of the following ....
                    >
                    >1. Has the weblogic.servlet.internal.HttpClusterServlet servlet been loaded when I start proxy server?
                    >
                    >2. How can I know that it is servicing the *.jsp requests i.e forwarding these requests to clustered servers behind the proxy?
                    >
                    >I have the following settings for my proxy server...
                    >-----------------------------------------------------------
                    >weblogic.allow.execute.weblogic.servlet=everyone
                    >weblogic.httpd.register.cluster=weblogic.servlet.internal.HttpClusterServlet
                    >weblogic.httpd.initArgs.cluster=\
                    >     defaultServers=192.168.1.207:7001:7002|192.168.1.204:7001:7002,\ secureProxy=ON
                    >weblogic.httpd.defaultServlet=cluster
                    >
                    >weblogic.system.listenPort=80
                    >weblogic.system.SSLListenPort=7003
                    >weblogic.security.ssl.enable=true
                    >
                    >weblogic.httpd.register.*.html=\
                    >weblogic.servlet.FileServlet
                    >weblogic.httpd.register.*.jpg=\
                    >weblogic.servlet.FileServlet
                    >weblogic.httpd.register.*.gif=\
                    >weblogic.servlet.FileServlet
                    >-----------------------------------------------------------
                    >
                    >
                    >This is what is displayed on my proxy server when i make a call to simple.jsp which is present in one of the clustered servers.
                    >
                    >-----------------------------------------------------------
                    >
                    >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: init
                    >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param ver
                    >bose initialized to: true
                    >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param pac
                    >kagePrefix initialized to: jsp_servlet
                    >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param com
                    >pileCommand initialized to: c:/jdk1.3/bin/javac.exe
                    >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param src
                    >Compiler initialized to weblogic.jspc
                    >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param sup
                    >erclass initialized to null
                    >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param wor
                    >kingDir initialized to: C:\weblogic\myserver\jsp_classes
                    >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: param pag
                    >eCheckSeconds initialized to: 1
                    >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp: initializ
                    >ation complete
                    >Tue Dec 05 16:05:41 GMT+01:00 2000:<E> <ServletContext-General> Servlet failed w
                    >ith Exception
                    >java.io.FileNotFoundException: no resource '/simple.jsp' in servlet context root
                    > 'C:\weblogic\proxyserver\public_html'
                    > at weblogic.servlet.JSPServlet.service(JSPServlet.java:105)
                    > at javax.servlet.http.HttpServlet.service(HttpServlet.java:865)
                    > at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                    >pl.java:106)
                    > at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                    >textImpl.java:907)
                    > at weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                    >textImpl.java:851)
                    > at weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                    >ContextManager.java:252)
                    > at weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                    >a:364)
                    > at weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                    >
                    > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java, Compiled Code)
                    >
                    >-----------------------------------------------------------
                    >
                    >
                    >3. Does any of the clustered servers throw any output indicating that it serviced a request forwarded by the proxy?
                    >
                    >I'm dying to see THAT more than my forthcoming holiday trip to Paris. :o)
                    >
                    >
                    >
                    >
                    >
                    
                    
          • 2. Re: Is proxy server running ?
            3004
            The weblogic proxy server can't share the same global property file with the
                      cluster servers.
                      All the properties you specified in the above can only be applied to the
                      proxy server, this property file can't be read as the global property file
                      by cluster servers.
                      
                      
                      
                      Vikram Kulkarni <kulkis@rediffmail.com> wrote in message
                      news:3a5dd6ef$1@newsgroups.bea.com...
                      >
                      > Now I have removed all "weblogic.httpd.register..." properties from my
                      Global weblogic.properties file.
                      >
                      > When I make a request for 'simple.jsp', i think it is then that
                      HttpClusterServlet is loaded and it's init() is fired as indicated by this
                      line .....
                      > Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                      init
                      >
                      > Now I am sure that HttpClusterServlet (The HERO) is in action and not
                      weblogic.servlet.JSPServlet (The VILLAIN).
                      >
                      >
                      > Now, init() must be looking for some parameters, not finding it and
                      throwing a NullPointerException ...
                      >
                      > Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                      init
                      > Tue Dec 05 16:40:07 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                      failed w
                      > ith Exception
                      > java.lang.NullPointerException
                      > at
                      weblogic.servlet.internal.HttpClusterServlet.init(HttpClusterServlet.
                      > java:98)
                      > at
                      weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
                      > pl.java:457)
                      > at
                      weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
                      > Impl.java, Compiled Code)
                      > at
                      weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
                      > mpl.java:404)
                      > at
                      weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
                      > java:164)
                      > at
                      weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                      > pl.java:101)
                      > at
                      weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                      > textImpl.java:907)
                      > at
                      weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                      > textImpl.java:851)
                      > at
                      weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                      > ContextManager.java:252)
                      > at
                      weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                      > a:364)
                      > at
                      weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                      >
                      > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java, Compiled
                      Code)
                      >
                      > -----------------------------------------------------------------
                      >
                      > Phew ! I must have missed something again.
                      > Any clues ??????
                      >
                      > thanks.
                      > vikram
                      >
                      > "Vikram Kulkarni" <kulkis@rediffmail.com> wrote:
                      > >
                      > >Hi !
                      > >how can i be sure of the following ....
                      > >
                      > >1. Has the weblogic.servlet.internal.HttpClusterServlet servlet been
                      loaded when I start proxy server?
                      > >
                      > >2. How can I know that it is servicing the *.jsp requests i.e forwarding
                      these requests to clustered servers behind the proxy?
                      > >
                      > >I have the following settings for my proxy server...
                      > >-----------------------------------------------------------
                      > >weblogic.allow.execute.weblogic.servlet=everyone
                      >
                      >weblogic.httpd.register.cluster=weblogic.servlet.internal.HttpClusterServle
                      t
                      > >weblogic.httpd.initArgs.cluster=\
                      > > defaultServers=192.168.1.207:7001:7002|192.168.1.204:7001:7002,\
                      secureProxy=ON
                      > >weblogic.httpd.defaultServlet=cluster
                      > >
                      > >weblogic.system.listenPort=80
                      > >weblogic.system.SSLListenPort=7003
                      > >weblogic.security.ssl.enable=true
                      > >
                      > >weblogic.httpd.register.*.html=\
                      > >weblogic.servlet.FileServlet
                      > >weblogic.httpd.register.*.jpg=\
                      > >weblogic.servlet.FileServlet
                      > >weblogic.httpd.register.*.gif=\
                      > >weblogic.servlet.FileServlet
                      > >-----------------------------------------------------------
                      > >
                      > >
                      > >This is what is displayed on my proxy server when i make a call to
                      simple.jsp which is present in one of the clustered servers.
                      > >
                      > >-----------------------------------------------------------
                      > >
                      > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      init
                      > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      param ver
                      > >bose initialized to: true
                      > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      param pac
                      > >kagePrefix initialized to: jsp_servlet
                      > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      param com
                      > >pileCommand initialized to: c:/jdk1.3/bin/javac.exe
                      > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      param src
                      > >Compiler initialized to weblogic.jspc
                      > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      param sup
                      > >erclass initialized to null
                      > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      param wor
                      > >kingDir initialized to: C:\weblogic\myserver\jsp_classes
                      > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      param pag
                      > >eCheckSeconds initialized to: 1
                      > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                      initializ
                      > >ation complete
                      > >Tue Dec 05 16:05:41 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                      failed w
                      > >ith Exception
                      > >java.io.FileNotFoundException: no resource '/simple.jsp' in servlet
                      context root
                      > > 'C:\weblogic\proxyserver\public_html'
                      > > at weblogic.servlet.JSPServlet.service(JSPServlet.java:105)
                      > > at javax.servlet.http.HttpServlet.service(HttpServlet.java:865)
                      > > at
                      weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                      > >pl.java:106)
                      > > at
                      weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                      > >textImpl.java:907)
                      > > at
                      weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                      > >textImpl.java:851)
                      > > at
                      weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                      > >ContextManager.java:252)
                      > > at
                      weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                      > >a:364)
                      > > at
                      weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                      > >
                      > > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java, Compiled
                      Code)
                      > >
                      > >-----------------------------------------------------------
                      > >
                      > >
                      > >3. Does any of the clustered servers throw any output indicating that it
                      serviced a request forwarded by the proxy?
                      > >
                      > >I'm dying to see THAT more than my forthcoming holiday trip to Paris. :o)
                      > >
                      > >
                      > >
                      > >
                      > >
                      >
                      
                      
                      
            • 3. Re: Is proxy server running ?
              3004

                        No. I have another directory called proxyserver at the same level as myserver and am starting this proxy server using the parameters ... -Dweblogic.system.name=proxyserver weblogic.Server
                        
                        Therefore, I commented out all weblogic.httpd.register statements in my global weblogic.properties file.
                        
                        and my proxyserver property file redirects any JSP requests to the clustered server because of the statements....
                        
                        -----------------------------------------------------
                        weblogic.allow.execute.weblogic.servlet=everyone
                        weblogic.httpd.register.cluster=weblogic.servlet.internal.HttpClusterServlet
                        weblogic.httpd.initArgs.cluster=\
                             defaultServers=192.168.1.207:7001:7002|192.168.1.204:7001:7002,\ secureProxy=ON
                        weblogic.httpd.defaultServlet=cluster
                        
                        weblogic.system.listenPort=80
                        weblogic.system.SSLListenPort=7003
                        weblogic.security.ssl.enable=true
                        
                        weblogic.httpd.register.*.html=\
                        weblogic.servlet.FileServlet
                        weblogic.httpd.register.*.jpg=\
                        weblogic.servlet.FileServlet
                        weblogic.httpd.register.*.gif=\
                        weblogic.servlet.FileServlet
                        
                        -----------------------------------------------------
                        
                        THE PROBLEM WAS HERE ....
                        In my clustered server weblogic.properties file I had the following...
                        
                        -----------------------------------------------------
                        
                        weblogic.httpd.register.*.jsp=\ weblogic.servlet.internal.HttpClusterServlet weblogic.httpd.initArgs.*.jsp=\ defaultServers=server1:9001|server2:9001 weblogic.httpd.register.*.servlet=\ weblogic.servlet.internal.HttpClusterServlet weblogic.httpd.initArgs.*.servlet=\ defaultServers=server1:9001|server2:9001 weblogic.httpd.register.myfavoriteservlet=\ weblogic.servlet.internal.HttpClusterServlet weblogic.httpd.initArgs.myfavoriteservlet=\ defaultServers=server1:9001|server2:9001
                        
                        -----------------------------------------------------
                        
                        Now, this would have again caused another redirection to the HttpClusterServlet. On the contrary, it is here that the JSPServlet should come in and handle the requests.
                        
                        I removed the above lines and instead added this in each of the clustered server's weblogic.properties file ....
                        
                        -----------------------------------------------------
                        
                        weblogic.httpd.register.*.jsp=\
                        weblogic.servlet.JSPServlet
                        weblogic.httpd.initArgs.*.jsp=\
                        pageCheckSeconds=1,\
                        compileCommand=c:/jdk1.3/bin/javac.exe,\
                        workingDir=C:/weblogic/myserver/jsp_classes,\
                        verbose=true
                        
                        -----------------------------------------------------
                        
                        and BINGO ....
                        IT WORKS !!!
                        
                        THANKS A LOT FOR THE DISCUSSIONS ...
                        
                        warm regards,
                        
                        vikram
                        
                        "Tao Zhang" <sdzhangtao@yahoo.com> wrote:
                        >The weblogic proxy server can't share the same global property file with the
                        >cluster servers.
                        >All the properties you specified in the above can only be applied to the
                        >proxy server, this property file can't be read as the global property file
                        >by cluster servers.
                        >
                        
                        It can be done. But of course, since I commented out all weblogic.httpd.register statements, many of the admin servlets are not accessible right now.
                        
                        
                        
                        >
                        >
                        >Vikram Kulkarni <kulkis@rediffmail.com> wrote in message
                        >news:3a5dd6ef$1@newsgroups.bea.com...
                        >>
                        >> Now I have removed all "weblogic.httpd.register..." properties from my
                        >Global weblogic.properties file.
                        >>
                        >> When I make a request for 'simple.jsp', i think it is then that
                        >HttpClusterServlet is loaded and it's init() is fired as indicated by this
                        >line .....
                        >> Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                        >init
                        >>
                        >> Now I am sure that HttpClusterServlet (The HERO) is in action and not
                        >weblogic.servlet.JSPServlet (The VILLAIN).
                        >>
                        >>
                        >> Now, init() must be looking for some parameters, not finding it and
                        >throwing a NullPointerException ...
                        >>
                        >> Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                        >init
                        >> Tue Dec 05 16:40:07 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                        >failed w
                        >> ith Exception
                        >> java.lang.NullPointerException
                        >> at
                        >weblogic.servlet.internal.HttpClusterServlet.init(HttpClusterServlet.
                        >> java:98)
                        >> at
                        >weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
                        >> pl.java:457)
                        >> at
                        >weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
                        >> Impl.java, Compiled Code)
                        >> at
                        >weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
                        >> mpl.java:404)
                        >> at
                        >weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
                        >> java:164)
                        >> at
                        >weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                        >> pl.java:101)
                        >> at
                        >weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                        >> textImpl.java:907)
                        >> at
                        >weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                        >> textImpl.java:851)
                        >> at
                        >weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                        >> ContextManager.java:252)
                        >> at
                        >weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                        >> a:364)
                        >> at
                        >weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                        >>
                        >> at weblogic.kernel.ExecuteThread.run(ExecuteThread.java, Compiled
                        >Code)
                        >>
                        >> -----------------------------------------------------------------
                        >>
                        >> Phew ! I must have missed something again.
                        >> Any clues ??????
                        >>
                        >> thanks.
                        >> vikram
                        >>
                        >> "Vikram Kulkarni" <kulkis@rediffmail.com> wrote:
                        >> >
                        >> >Hi !
                        >> >how can i be sure of the following ....
                        >> >
                        >> >1. Has the weblogic.servlet.internal.HttpClusterServlet servlet been
                        >loaded when I start proxy server?
                        >> >
                        >> >2. How can I know that it is servicing the *.jsp requests i.e forwarding
                        >these requests to clustered servers behind the proxy?
                        >> >
                        >> >I have the following settings for my proxy server...
                        >> >-----------------------------------------------------------
                        >> >weblogic.allow.execute.weblogic.servlet=everyone
                        >>
                        >>weblogic.httpd.register.cluster=weblogic.servlet.internal.HttpClusterServle
                        >t
                        >> >weblogic.httpd.initArgs.cluster=\
                        >> > defaultServers=192.168.1.207:7001:7002|192.168.1.204:7001:7002,\
                        >secureProxy=ON
                        >> >weblogic.httpd.defaultServlet=cluster
                        >> >
                        >> >weblogic.system.listenPort=80
                        >> >weblogic.system.SSLListenPort=7003
                        >> >weblogic.security.ssl.enable=true
                        >> >
                        >> >weblogic.httpd.register.*.html=\
                        >> >weblogic.servlet.FileServlet
                        >> >weblogic.httpd.register.*.jpg=\
                        >> >weblogic.servlet.FileServlet
                        >> >weblogic.httpd.register.*.gif=\
                        >> >weblogic.servlet.FileServlet
                        >> >-----------------------------------------------------------
                        >> >
                        >> >
                        >> >This is what is displayed on my proxy server when i make a call to
                        >simple.jsp which is present in one of the clustered servers.
                        >> >
                        >> >-----------------------------------------------------------
                        >> >
                        >> >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >init
                        >> >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >param ver
                        >> >bose initialized to: true
                        >> >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >param pac
                        >> >kagePrefix initialized to: jsp_servlet
                        >> >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >param com
                        >> >pileCommand initialized to: c:/jdk1.3/bin/javac.exe
                        >> >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >param src
                        >> >Compiler initialized to weblogic.jspc
                        >> >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >param sup
                        >> >erclass initialized to null
                        >> >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >param wor
                        >> >kingDir initialized to: C:\weblogic\myserver\jsp_classes
                        >> >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >param pag
                        >> >eCheckSeconds initialized to: 1
                        >> >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                        >initializ
                        >> >ation complete
                        >> >Tue Dec 05 16:05:41 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                        >failed w
                        >> >ith Exception
                        >> >java.io.FileNotFoundException: no resource '/simple.jsp' in servlet
                        >context root
                        >> > 'C:\weblogic\proxyserver\public_html'
                        >> > at weblogic.servlet.JSPServlet.service(JSPServlet.java:105)
                        >> > at javax.servlet.http.HttpServlet.service(HttpServlet.java:865)
                        >> > at
                        >weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                        >> >pl.java:106)
                        >> > at
                        >weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                        >> >textImpl.java:907)
                        >> > at
                        >weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                        >> >textImpl.java:851)
                        >> > at
                        >weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                        >> >ContextManager.java:252)
                        >> > at
                        >weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                        >> >a:364)
                        >> > at
                        >weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                        >> >
                        >> > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java, Compiled
                        >Code)
                        >> >
                        >> >-----------------------------------------------------------
                        >> >
                        >> >
                        >> >3. Does any of the clustered servers throw any output indicating that it
                        >serviced a request forwarded by the proxy?
                        >> >
                        >> >I'm dying to see THAT more than my forthcoming holiday trip to Paris. :o)
                        >> >
                        >> >
                        >> >
                        >> >
                        >> >
                        >>
                        >
                        >
                        
                        
              • 4. Re: Is proxy server running ?
                3004
                Why weblogic proxy makes that exception? per-server properties overwrites
                          per-cluster properties overwrites global properties, isn't it? if I made a
                          sub-directory as "myproxy" and save the proxy-related settings as a
                          weblogic.properties under "myproxy" directory, it should work. Comments?
                          
                          "Tao Zhang" <sdzhangtao@yahoo.com> wrote in message
                          news:3a5e7cec@newsgroups.bea.com...
                          | The weblogic proxy server can't share the same global property file with
                          the
                          | cluster servers.
                          | All the properties you specified in the above can only be applied to the
                          | proxy server, this property file can't be read as the global property file
                          | by cluster servers.
                          |
                          |
                          |
                          | Vikram Kulkarni <kulkis@rediffmail.com> wrote in message
                          | news:3a5dd6ef$1@newsgroups.bea.com...
                          | >
                          | > Now I have removed all "weblogic.httpd.register..." properties from my
                          | Global weblogic.properties file.
                          | >
                          | > When I make a request for 'simple.jsp', i think it is then that
                          | HttpClusterServlet is loaded and it's init() is fired as indicated by this
                          | line .....
                          | > Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                          | init
                          | >
                          | > Now I am sure that HttpClusterServlet (The HERO) is in action and not
                          | weblogic.servlet.JSPServlet (The VILLAIN).
                          | >
                          | >
                          | > Now, init() must be looking for some parameters, not finding it and
                          | throwing a NullPointerException ...
                          | >
                          | > Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                          | init
                          | > Tue Dec 05 16:40:07 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                          | failed w
                          | > ith Exception
                          | > java.lang.NullPointerException
                          | > at
                          | weblogic.servlet.internal.HttpClusterServlet.init(HttpClusterServlet.
                          | > java:98)
                          | > at
                          | weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
                          | > pl.java:457)
                          | > at
                          | weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
                          | > Impl.java, Compiled Code)
                          | > at
                          | weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
                          | > mpl.java:404)
                          | > at
                          | weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
                          | > java:164)
                          | > at
                          | weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                          | > pl.java:101)
                          | > at
                          | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                          | > textImpl.java:907)
                          | > at
                          | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                          | > textImpl.java:851)
                          | > at
                          | weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                          | > ContextManager.java:252)
                          | > at
                          | weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                          | > a:364)
                          | > at
                          | weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                          | >
                          | > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java,
                          Compiled
                          | Code)
                          | >
                          | > -----------------------------------------------------------------
                          | >
                          | > Phew ! I must have missed something again.
                          | > Any clues ??????
                          | >
                          | > thanks.
                          | > vikram
                          | >
                          | > "Vikram Kulkarni" <kulkis@rediffmail.com> wrote:
                          | > >
                          | > >Hi !
                          | > >how can i be sure of the following ....
                          | > >
                          | > >1. Has the weblogic.servlet.internal.HttpClusterServlet servlet been
                          | loaded when I start proxy server?
                          | > >
                          | > >2. How can I know that it is servicing the *.jsp requests i.e
                          forwarding
                          | these requests to clustered servers behind the proxy?
                          | > >
                          | > >I have the following settings for my proxy server...
                          | > >-----------------------------------------------------------
                          | > >weblogic.allow.execute.weblogic.servlet=everyone
                          | >
                          |
                          >weblogic.httpd.register.cluster=weblogic.servlet.internal.HttpClusterServle
                          | t
                          | > >weblogic.httpd.initArgs.cluster=\
                          | > > defaultServers=192.168.1.207:7001:7002|192.168.1.204:7001:7002,\
                          | secureProxy=ON
                          | > >weblogic.httpd.defaultServlet=cluster
                          | > >
                          | > >weblogic.system.listenPort=80
                          | > >weblogic.system.SSLListenPort=7003
                          | > >weblogic.security.ssl.enable=true
                          | > >
                          | > >weblogic.httpd.register.*.html=\
                          | > >weblogic.servlet.FileServlet
                          | > >weblogic.httpd.register.*.jpg=\
                          | > >weblogic.servlet.FileServlet
                          | > >weblogic.httpd.register.*.gif=\
                          | > >weblogic.servlet.FileServlet
                          | > >-----------------------------------------------------------
                          | > >
                          | > >
                          | > >This is what is displayed on my proxy server when i make a call to
                          | simple.jsp which is present in one of the clustered servers.
                          | > >
                          | > >-----------------------------------------------------------
                          | > >
                          | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | init
                          | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | param ver
                          | > >bose initialized to: true
                          | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | param pac
                          | > >kagePrefix initialized to: jsp_servlet
                          | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | param com
                          | > >pileCommand initialized to: c:/jdk1.3/bin/javac.exe
                          | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | param src
                          | > >Compiler initialized to weblogic.jspc
                          | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | param sup
                          | > >erclass initialized to null
                          | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | param wor
                          | > >kingDir initialized to: C:\weblogic\myserver\jsp_classes
                          | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | param pag
                          | > >eCheckSeconds initialized to: 1
                          | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                          | initializ
                          | > >ation complete
                          | > >Tue Dec 05 16:05:41 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                          | failed w
                          | > >ith Exception
                          | > >java.io.FileNotFoundException: no resource '/simple.jsp' in servlet
                          | context root
                          | > > 'C:\weblogic\proxyserver\public_html'
                          | > > at weblogic.servlet.JSPServlet.service(JSPServlet.java:105)
                          | > > at javax.servlet.http.HttpServlet.service(HttpServlet.java:865)
                          | > > at
                          | weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                          | > >pl.java:106)
                          | > > at
                          | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                          | > >textImpl.java:907)
                          | > > at
                          | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                          | > >textImpl.java:851)
                          | > > at
                          | weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                          | > >ContextManager.java:252)
                          | > > at
                          | weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                          | > >a:364)
                          | > > at
                          | weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                          | > >
                          | > > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java,
                          Compiled
                          | Code)
                          | > >
                          | > >-----------------------------------------------------------
                          | > >
                          | > >
                          | > >3. Does any of the clustered servers throw any output indicating that
                          it
                          | serviced a request forwarded by the proxy?
                          | > >
                          | > >I'm dying to see THAT more than my forthcoming holiday trip to Paris.
                          :o)
                          | > >
                          | > >
                          | > >
                          | > >
                          | > >
                          | >
                          |
                          |
                          
                          
                          
                • 5. Re: Is proxy server running ?
                  3004
                  Actually, the weblogic proxy server can share the global properties with the
                            cluster servers but ONLY IF you strip out the properties that cannot be set for
                            the proxy server (which means pushing those properties into the cluster-specific
                            properties file)...
                            
                            Tracy Zhang wrote:
                            
                            > Why weblogic proxy makes that exception? per-server properties overwrites
                            > per-cluster properties overwrites global properties, isn't it? if I made a
                            > sub-directory as "myproxy" and save the proxy-related settings as a
                            > weblogic.properties under "myproxy" directory, it should work. Comments?
                            >
                            > "Tao Zhang" <sdzhangtao@yahoo.com> wrote in message
                            > news:3a5e7cec@newsgroups.bea.com...
                            > | The weblogic proxy server can't share the same global property file with
                            > the
                            > | cluster servers.
                            > | All the properties you specified in the above can only be applied to the
                            > | proxy server, this property file can't be read as the global property file
                            > | by cluster servers.
                            > |
                            > |
                            > |
                            > | Vikram Kulkarni <kulkis@rediffmail.com> wrote in message
                            > | news:3a5dd6ef$1@newsgroups.bea.com...
                            > | >
                            > | > Now I have removed all "weblogic.httpd.register..." properties from my
                            > | Global weblogic.properties file.
                            > | >
                            > | > When I make a request for 'simple.jsp', i think it is then that
                            > | HttpClusterServlet is loaded and it's init() is fired as indicated by this
                            > | line .....
                            > | > Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                            > | init
                            > | >
                            > | > Now I am sure that HttpClusterServlet (The HERO) is in action and not
                            > | weblogic.servlet.JSPServlet (The VILLAIN).
                            > | >
                            > | >
                            > | > Now, init() must be looking for some parameters, not finding it and
                            > | throwing a NullPointerException ...
                            > | >
                            > | > Tue Dec 05 16:40:07 GMT+01:00 2000:<I> <ServletContext-General> cluster:
                            > | init
                            > | > Tue Dec 05 16:40:07 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                            > | failed w
                            > | > ith Exception
                            > | > java.lang.NullPointerException
                            > | > at
                            > | weblogic.servlet.internal.HttpClusterServlet.init(HttpClusterServlet.
                            > | > java:98)
                            > | > at
                            > | weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
                            > | > pl.java:457)
                            > | > at
                            > | weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
                            > | > Impl.java, Compiled Code)
                            > | > at
                            > | weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
                            > | > mpl.java:404)
                            > | > at
                            > | weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
                            > | > java:164)
                            > | > at
                            > | weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                            > | > pl.java:101)
                            > | > at
                            > | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                            > | > textImpl.java:907)
                            > | > at
                            > | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                            > | > textImpl.java:851)
                            > | > at
                            > | weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                            > | > ContextManager.java:252)
                            > | > at
                            > | weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                            > | > a:364)
                            > | > at
                            > | weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                            > | >
                            > | > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java,
                            > Compiled
                            > | Code)
                            > | >
                            > | > -----------------------------------------------------------------
                            > | >
                            > | > Phew ! I must have missed something again.
                            > | > Any clues ??????
                            > | >
                            > | > thanks.
                            > | > vikram
                            > | >
                            > | > "Vikram Kulkarni" <kulkis@rediffmail.com> wrote:
                            > | > >
                            > | > >Hi !
                            > | > >how can i be sure of the following ....
                            > | > >
                            > | > >1. Has the weblogic.servlet.internal.HttpClusterServlet servlet been
                            > | loaded when I start proxy server?
                            > | > >
                            > | > >2. How can I know that it is servicing the *.jsp requests i.e
                            > forwarding
                            > | these requests to clustered servers behind the proxy?
                            > | > >
                            > | > >I have the following settings for my proxy server...
                            > | > >-----------------------------------------------------------
                            > | > >weblogic.allow.execute.weblogic.servlet=everyone
                            > | >
                            > |
                            > >weblogic.httpd.register.cluster=weblogic.servlet.internal.HttpClusterServle
                            > | t
                            > | > >weblogic.httpd.initArgs.cluster=\
                            > | > > defaultServers=192.168.1.207:7001:7002|192.168.1.204:7001:7002,\
                            > | secureProxy=ON
                            > | > >weblogic.httpd.defaultServlet=cluster
                            > | > >
                            > | > >weblogic.system.listenPort=80
                            > | > >weblogic.system.SSLListenPort=7003
                            > | > >weblogic.security.ssl.enable=true
                            > | > >
                            > | > >weblogic.httpd.register.*.html=\
                            > | > >weblogic.servlet.FileServlet
                            > | > >weblogic.httpd.register.*.jpg=\
                            > | > >weblogic.servlet.FileServlet
                            > | > >weblogic.httpd.register.*.gif=\
                            > | > >weblogic.servlet.FileServlet
                            > | > >-----------------------------------------------------------
                            > | > >
                            > | > >
                            > | > >This is what is displayed on my proxy server when i make a call to
                            > | simple.jsp which is present in one of the clustered servers.
                            > | > >
                            > | > >-----------------------------------------------------------
                            > | > >
                            > | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | init
                            > | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | param ver
                            > | > >bose initialized to: true
                            > | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | param pac
                            > | > >kagePrefix initialized to: jsp_servlet
                            > | > >Tue Dec 05 16:02:04 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | param com
                            > | > >pileCommand initialized to: c:/jdk1.3/bin/javac.exe
                            > | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | param src
                            > | > >Compiler initialized to weblogic.jspc
                            > | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | param sup
                            > | > >erclass initialized to null
                            > | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | param wor
                            > | > >kingDir initialized to: C:\weblogic\myserver\jsp_classes
                            > | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | param pag
                            > | > >eCheckSeconds initialized to: 1
                            > | > >Tue Dec 05 16:02:05 GMT+01:00 2000:<I> <ServletContext-General> *.jsp:
                            > | initializ
                            > | > >ation complete
                            > | > >Tue Dec 05 16:05:41 GMT+01:00 2000:<E> <ServletContext-General> Servlet
                            > | failed w
                            > | > >ith Exception
                            > | > >java.io.FileNotFoundException: no resource '/simple.jsp' in servlet
                            > | context root
                            > | > > 'C:\weblogic\proxyserver\public_html'
                            > | > > at weblogic.servlet.JSPServlet.service(JSPServlet.java:105)
                            > | > > at javax.servlet.http.HttpServlet.service(HttpServlet.java:865)
                            > | > > at
                            > | weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
                            > | > >pl.java:106)
                            > | > > at
                            > | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                            > | > >textImpl.java:907)
                            > | > > at
                            > | weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
                            > | > >textImpl.java:851)
                            > | > > at
                            > | weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
                            > | > >ContextManager.java:252)
                            > | > > at
                            > | weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
                            > | > >a:364)
                            > | > > at
                            > | weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:252)
                            > | > >
                            > | > > at weblogic.kernel.ExecuteThread.run(ExecuteThread.java,
                            > Compiled
                            > | Code)
                            > | > >
                            > | > >-----------------------------------------------------------
                            > | > >
                            > | > >
                            > | > >3. Does any of the clustered servers throw any output indicating that
                            > it
                            > | serviced a request forwarded by the proxy?
                            > | > >
                            > | > >I'm dying to see THAT more than my forthcoming holiday trip to Paris.
                            > :o)
                            > | > >
                            > | > >
                            > | > >
                            > | > >
                            > | > >
                            > | >
                            > |
                            > |