1 Reply Latest reply on Feb 28, 2003 6:14 PM by 3004

    Problem loading mod_wl.so in Apache on HP-UX

    3004
      After installing mod_wl.so on apache
      I got this error when i try to run the apache


      /usr/lib/dld.sl: Can't shl_load() a library containing Thread Local Storage:
      /usr/lib/libcl.2

      /usr/lib/dld.sl: Exec format error

      Syntax error on line 236 of /opt/apache/etc/httpd.conf:

      Cannot load /opt/apache/lib/modules/mod_wl.so into server: Exec format error

      /opt/apache/bin/apachectl start: httpd could not be started



      I have the WLS 7, the apache version is 1.3.23, HP-UX 11.0.

      Any ideas ?
      Thanks

      PAwel Kowalewski


        • 1. Re: Problem loading mod_wl.so in Apache on HP-UX
          3004
          When you build your apache 1.3.x server, you should be using these CFLAGS:

          CFLAGS="-lstd -lstream -lCsup -lm -lcl -ldld"

          You can also try to do the following before starting Apache:

          export LD_PRELOAD="/usr/lib/libcl.2"

          Regards,

          Eric



          "bea" <kowal3003@interia.pl> wrote in message
          news:3e5f2898@newsgroups.bea.com...
          After installing mod_wl.so on apache
          I got this error when i try to run the apache


          /usr/lib/dld.sl: Can't shl_load() a library containing Thread Local
          Storage:
          /usr/lib/libcl.2

          /usr/lib/dld.sl: Exec format error

          Syntax error on line 236 of /opt/apache/etc/httpd.conf:

          Cannot load /opt/apache/lib/modules/mod_wl.so into server: Exec format
          error
          >
          /opt/apache/bin/apachectl start: httpd could not be started



          I have the WLS 7, the apache version is 1.3.23, HP-UX 11.0.

          Any ideas ?
          Thanks

          PAwel Kowalewski