1 Reply Latest reply on Sep 16, 2002 7:40 PM by 3004

    WLS 6.0 sp2 fatal initialization error

    3004

      Hi all.

      I am starting wlcs 3.5 sp1 after installing wls 6.0 sp2 on a win 2k server with
      sqlserver7.0. The database configuration is just fine in both the config.xml and
      the realm settings are just fine in weblogiccommerce.properties.

      I get the following error on start up. <br>
      This is a wls 6.0 sp2 initialization issue.<br>

      any help is greatly appreciated.
      [error.text.txt]
        • 1. Re: WLS 6.0 sp2 fatal initialization error
          3004
          You should report this problem to support@bea.com

          --
          Kumar


          Arjun wrote:
          Hi all.

          I am starting wlcs 3.5 sp1 after installing wls 6.0 sp2 on a win 2k server with
          sqlserver7.0. The database configuration is just fine in both the config.xml and
          the realm settings are just fine in weblogiccommerce.properties.

          I get the following error on start up. <br>
          This is a wls 6.0 sp2 initialization issue.<br>

          any help is greatly appreciated.


          ------------------------------------------------------------------------

          Starting WebLogic Server ....
          <Sep 5, 2002 8:54:05 AM CDT> <Notice> <Management> <Loading configuration file .
          \config\wlcsDomain\config.xml ...>
          log file: d:\bea\WebLogicCommerce3.5\.\config\wlcsDomain\logs\weblogic.log
          <Sep 5, 2002 8:54:08 AM CDT> <Info> <Logging> <Only log messages of severity "Er
          ror" or worse will be displayed in this window. This can be changed at Admin Con
          sole> wlcsDomain> Servers> wlcsServer> Logging> General> Stdout severity thresho
          ld>
          =============== Initializing Logger ======================
          <Sep 5, 2002 8:54:19 AM CDT> <Emergency> <Server> <Unable to initialize the serv
          er: 'Fatal initialization exception
          Throwable: java.lang.IllegalAccessError: java.lang.NullPointerException:
          java.lang.IllegalAccessError: java.lang.NullPointerException:
          at weblogic.security.acl.Realm.getRealm(Realm.java:91)
          at weblogic.security.acl.Realm.getRealm(Realm.java:62)
          at weblogic.security.SecurityService.initializeRealm(SecurityService.jav
          a:265)
          at weblogic.security.SecurityService.initialize(SecurityService.java:123
          )
          at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
          at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
          at weblogic.Server.main(Server.java:35)
          '>
          ***************************************************************************
          The WebLogic Server did not start up properly.
          Exception raised: java.lang.IllegalAccessError: java.lang.NullPointerException:

          java.lang.IllegalAccessError: java.lang.NullPointerException:
          at weblogic.security.acl.Realm.getRealm(Realm.java:91)
          at weblogic.security.acl.Realm.getRealm(Realm.java:62)
          at weblogic.security.SecurityService.initializeRealm(SecurityService.jav
          a:265)
          at weblogic.security.SecurityService.initialize(SecurityService.java:123
          )
          at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
          at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
          at weblogic.Server.main(Server.java:35)
          Reason: Fatal initialization exception
          ***************************************************************************
          Press any key to continue . . .