2 Replies Latest reply on Jun 24, 2002 9:46 PM by 3004

    Error auto-deploying a Web App (.WAR file)

    3004

      Hello,

      Weblogic 6.1 throws a FileNotFoundException about 10% of the time for me when
      auto-deploying a Web app. Has anyone else run into this? I searched the newsgroups
      but didn't come up with anything, so I thought I'd start here.

      My build/deploy cycle is managed by an Ant build file that creates a WAR file
      of my web application and then drops it into $WL_HOME/config/mydomain/applications.
      Occasionally when I do this, I get the error shown below. Originally I was building
      the WAR file right in the ../applications directory, so I thought that might be
      an issue. So, I started building the WAR file in a staging directory and copying
      it into ../applications. No luck. Next, I tried deleting the original WAR file
      from ../applications, and THEN copying the new one over from the staging directory.
      Still fails occasionally.

      Let's see. This is Weblogic 6.1 on Win2K. The only other thing is that my dev/build/staging
      environment is on a network share, and it's from there that I'm copying the WAR
      file to my local machine (where WL is running).

      If someone has seen and/or knows what is up with this, great. If not, it's not
      a show-stopper.

      Thanks!
      Cheers,
      David

      ========================================================

      <Apr 8, 2002 9:05:00 AM PDT> <Error> <Management> <IOException opening application
      mydomain:Name=private-banking,Type=Application, loading from path .\config\mydomain\applications\private-banking.war
      java.io.FileNotFoundException: error in opening zip file
           at weblogic.management.mbeans.custom.Application.findType(Application.java:1833)
           at weblogic.management.mbeans.custom.Application.adminLoad(Application.java:444)
           at weblogic.management.mbeans.custom.Application.load(Application.java:387)
           at java.lang.reflect.Method.invoke(Native Method)
           at weblogic.management.internal.DynamicMBeanImpl.invokeLocally(DynamicMBeanImpl.java:636)
           at weblogic.management.internal.DynamicMBeanImpl.invoke(DynamicMBeanImpl.java:621)
           at weblogic.management.internal.ConfigurationMBeanImpl.invoke(ConfigurationMBeanImpl.java:359)
           at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1555)
           at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1523)
           at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:468)
           at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:209)
           at $Proxy8.load(Unknown Source)
           at weblogic.management.mbeans.custom.ApplicationManager.poll(ApplicationManager.java:840)
           at weblogic.management.mbeans.custom.ApplicationManager.poll(ApplicationManager.java:733)
           at weblogic.management.mbeans.custom.ApplicationManager.update(ApplicationManager.java:206)
           at weblogic.management.mbeans.custom.ApplicationManager$ApplicationPoller.run(ApplicationManager.java:1050)

        • 1. Re: Error auto-deploying a Web App (.WAR file)
          3004
          Hi.

          This may be a known issue that was addressed in sp2. If you are not already at that sp level I suggest you upgrade.

          Regards,
          Michael

          David Ventimiglia wrote:
          Hello,

          Weblogic 6.1 throws a FileNotFoundException about 10% of the time for me when
          auto-deploying a Web app. Has anyone else run into this? I searched the newsgroups
          but didn't come up with anything, so I thought I'd start here.

          My build/deploy cycle is managed by an Ant build file that creates a WAR file
          of my web application and then drops it into $WL_HOME/config/mydomain/applications.
          Occasionally when I do this, I get the error shown below. Originally I was building
          the WAR file right in the ../applications directory, so I thought that might be
          an issue. So, I started building the WAR file in a staging directory and copying
          it into ../applications. No luck. Next, I tried deleting the original WAR file
          from ../applications, and THEN copying the new one over from the staging directory.
          Still fails occasionally.

          Let's see. This is Weblogic 6.1 on Win2K. The only other thing is that my dev/build/staging
          environment is on a network share, and it's from there that I'm copying the WAR
          file to my local machine (where WL is running).

          If someone has seen and/or knows what is up with this, great. If not, it's not
          a show-stopper.

          Thanks!
          Cheers,
          David

          ========================================================

          <Apr 8, 2002 9:05:00 AM PDT> <Error> <Management> <IOException opening application
          mydomain:Name=private-banking,Type=Application, loading from path .\config\mydomain\applications\private-banking.war
          java.io.FileNotFoundException: error in opening zip file
          at weblogic.management.mbeans.custom.Application.findType(Application.java:1833)
          at weblogic.management.mbeans.custom.Application.adminLoad(Application.java:444)
          at weblogic.management.mbeans.custom.Application.load(Application.java:387)
          at java.lang.reflect.Method.invoke(Native Method)
          at weblogic.management.internal.DynamicMBeanImpl.invokeLocally(DynamicMBeanImpl.java:636)
          at weblogic.management.internal.DynamicMBeanImpl.invoke(DynamicMBeanImpl.java:621)
          at weblogic.management.internal.ConfigurationMBeanImpl.invoke(ConfigurationMBeanImpl.java:359)
          at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1555)
          at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1523)
          at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:468)
          at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:209)
          at $Proxy8.load(Unknown Source)
          at weblogic.management.mbeans.custom.ApplicationManager.poll(ApplicationManager.java:840)
          at weblogic.management.mbeans.custom.ApplicationManager.poll(ApplicationManager.java:733)
          at weblogic.management.mbeans.custom.ApplicationManager.update(ApplicationManager.java:206)
          at weblogic.management.mbeans.custom.ApplicationManager$ApplicationPoller.run(ApplicationManager.java:1050)
          --
          Michael Young
          Developer Relations Engineer
          BEA Support


          • 2. Re: Error auto-deploying a Web App (.WAR file)
            3004

            Michael,

            This is a problem with 6.1 SP2 also -- a very annoying error. Without auto deploy
            working properly, developers are spending alot of time waiting for WebLogic to restart.
            HELP!!! we need this fixed.
            I see the EXACT same stack trace (ERROR).

            Tom Markel
            Sr. Java Engineer

            Michael Young <Reply@ToNewsgroup.Only> wrote:
            Hi.

            This may be a known issue that was addressed in sp2. If you are not already
            at that sp level I suggest you upgrade.

            Regards,
            Michael

            David Ventimiglia wrote:
            Hello,

            Weblogic 6.1 throws a FileNotFoundException about 10% of the time for
            me when
            auto-deploying a Web app. Has anyone else run into this? I searched
            the newsgroups
            but didn't come up with anything, so I thought I'd start here.

            My build/deploy cycle is managed by an Ant build file that creates a WAR
            file
            of my web application and then drops it into $WL_HOME/config/mydomain/applications.
            Occasionally when I do this, I get the error shown below. Originally
            I was building
            the WAR file right in the ../applications directory, so I thought that
            might be
            an issue. So, I started building the WAR file in a staging directory
            and copying
            it into ../applications. No luck. Next, I tried deleting the original
            WAR file
            from ../applications, and THEN copying the new one over from the staging
            directory.
            Still fails occasionally.

            Let's see. This is Weblogic 6.1 on Win2K. The only other thing is that
            my dev/build/staging
            environment is on a network share, and it's from there that I'm copying
            the WAR
            file to my local machine (where WL is running).

            If someone has seen and/or knows what is up with this, great. If not,
            it's not
            a show-stopper.

            Thanks!
            Cheers,
            David

            ========================================================

            <Apr 8, 2002 9:05:00 AM PDT> <Error> <Management> <IOException opening
            application
            mydomain:Name=private-banking,Type=Application, loading from path .\config\mydomain\applications\private-banking.war
            java.io.FileNotFoundException: error in opening zip file
            at weblogic.management.mbeans.custom.Application.findType(Application.java:1833)
            at weblogic.management.mbeans.custom.Application.adminLoad(Application.java:444)
            at weblogic.management.mbeans.custom.Application.load(Application.java:387)
            at java.lang.reflect.Method.invoke(Native Method)
            at weblogic.management.internal.DynamicMBeanImpl.invokeLocally(DynamicMBeanImpl.java:636)
            at weblogic.management.internal.DynamicMBeanImpl.invoke(DynamicMBeanImpl.java:621)
            at weblogic.management.internal.ConfigurationMBeanImpl.invoke(ConfigurationMBeanImpl.java:359)
            at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1555)
            at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1523)
            at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:468)
            at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:209)
            at $Proxy8.load(Unknown Source)
            at weblogic.management.mbeans.custom.ApplicationManager.poll(ApplicationManager.java:840)
            at weblogic.management.mbeans.custom.ApplicationManager.poll(ApplicationManager.java:733)
            at weblogic.management.mbeans.custom.ApplicationManager.update(ApplicationManager.java:206)
            at weblogic.management.mbeans.custom.ApplicationManager$ApplicationPoller.run(ApplicationManager.java:1050)
            --
            Michael Young
            Developer Relations Engineer
            BEA Support