5 Replies Latest reply on Nov 8, 2001 8:15 AM by 3004

    WLS 6.1 and weblogic-web-jar.dtd problems

    3004
      Hi,

      We have problems with our finer.war application.
      The problem is a BIG PROBLEM when my laptop doesent have any
      network connectivity. The problem are: When i start the WLS the server
      trys to redeploy my web-app, an inside my web-inf directory i have a file
      named weblogic.xml. This file refers to an DTD
      www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd

      Is there anybody who knows how to prevent WLS to go external for
      DTD's like theese? At BEA's support site i found information (wls51) whitch
      sed
      that if an external source doesen't existed it tried to load the DTD form
      weblogic.jar

      I'm developing my apps using JBuilder 5

      Any idea ?

      --
      TIA,
      Borre Nordbakken


        • 1. Re: WLS 6.1 and weblogic-web-jar.dtd problems
          3004
          Strange - I thought that it always resolves these to dtd's in
          weblogic.jar. It always starts fine when my DSL is down.

          Borre Nordbakken <bno@brreg.no> wrote:
          Hi,
          We have problems with our finer.war application.
          The problem is a BIG PROBLEM when my laptop doesent have any
          network connectivity. The problem are: When i start the WLS the server
          trys to redeploy my web-app, an inside my web-inf directory i have a file
          named weblogic.xml. This file refers to an DTD
          www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd
          Is there anybody who knows how to prevent WLS to go external for
          DTD's like theese? At BEA's support site i found information (wls51) whitch
          sed
          that if an external source doesen't existed it tried to load the DTD form
          weblogic.jar
          I'm developing my apps using JBuilder 5
          Any idea ?
          --
          TIA,
          Borre Nordbakken
          --
          Dimitri
          • 2. Re: WLS 6.1 and weblogic-web-jar.dtd problems
            3004
            And you are using WLS 6.1 SP1 ?

            --
            Borre

            "Dimitri Rakitine" <dr@dima.dhs.org> wrote in message
            news:3be86111@newsgroups.bea.com...
            Strange - I thought that it always resolves these to dtd's in
            weblogic.jar. It always starts fine when my DSL is down.

            Borre Nordbakken <bno@brreg.no> wrote:
            Hi,
            We have problems with our finer.war application.
            The problem is a BIG PROBLEM when my laptop doesent have any
            network connectivity. The problem are: When i start the WLS the server
            trys to redeploy my web-app, an inside my web-inf directory i have a
            file
            named weblogic.xml. This file refers to an DTD
            www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd
            Is there anybody who knows how to prevent WLS to go external for
            DTD's like theese? At BEA's support site i found information (wls51)
            whitch
            sed
            that if an external source doesen't existed it tried to load the DTD
            form
            weblogic.jar
            I'm developing my apps using JBuilder 5
            Any idea ?
            --
            TIA,
            Borre Nordbakken
            --
            Dimitri
            • 3. Re: WLS 6.1 and weblogic-web-jar.dtd problems
              3004
              Yes. To make sure I just unplugged my box and WebLogic started and
              deployed my apps without any problems.

              Borre Nordbakken <bno@brreg.no> wrote:
              And you are using WLS 6.1 SP1 ?
              --
              Borre
              "Dimitri Rakitine" <dr@dima.dhs.org> wrote in message
              news:3be86111@newsgroups.bea.com...
              Strange - I thought that it always resolves these to dtd's in
              weblogic.jar. It always starts fine when my DSL is down.

              Borre Nordbakken <bno@brreg.no> wrote:
              Hi,
              We have problems with our finer.war application.
              The problem is a BIG PROBLEM when my laptop doesent have any
              network connectivity. The problem are: When i start the WLS the server
              trys to redeploy my web-app, an inside my web-inf directory i have a
              file
              named weblogic.xml. This file refers to an DTD
              www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd
              Is there anybody who knows how to prevent WLS to go external for
              DTD's like theese? At BEA's support site i found information (wls51)
              whitch
              sed
              that if an external source doesen't existed it tried to load the DTD
              form
              weblogic.jar
              I'm developing my apps using JBuilder 5
              Any idea ?
              --
              TIA,
              Borre Nordbakken
              --
              Dimitri
              --
              Dimitri
              • 4. Re: WLS 6.1 and weblogic-web-jar.dtd problems
                3004
                Strange.
                I have created a case at BEA Support, and they called me this
                morning to tell me that they have some simular cases reported earlyer and
                the are going to investiage this problem.

                --
                Borre

                "Dimitri Rakitine" <dr@dima.dhs.org> wrote in message
                news:3be8e8b3@newsgroups.bea.com...
                Yes. To make sure I just unplugged my box and WebLogic started and
                deployed my apps without any problems.

                Borre Nordbakken <bno@brreg.no> wrote:
                And you are using WLS 6.1 SP1 ?
                --
                Borre
                "Dimitri Rakitine" <dr@dima.dhs.org> wrote in message
                news:3be86111@newsgroups.bea.com...
                Strange - I thought that it always resolves these to dtd's in
                weblogic.jar. It always starts fine when my DSL is down.

                Borre Nordbakken <bno@brreg.no> wrote:
                Hi,
                We have problems with our finer.war application.
                The problem is a BIG PROBLEM when my laptop doesent have any
                network connectivity. The problem are: When i start the WLS the
                server
                trys to redeploy my web-app, an inside my web-inf directory i have a
                file
                named weblogic.xml. This file refers to an DTD
                www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd
                Is there anybody who knows how to prevent WLS to go external for
                DTD's like theese? At BEA's support site i found information (wls51)
                whitch
                sed
                that if an external source doesen't existed it tried to load the DTD
                form
                weblogic.jar
                I'm developing my apps using JBuilder 5
                Any idea ?
                --
                TIA,
                Borre Nordbakken
                --
                Dimitri
                --
                Dimitri
                • 5. Re: WLS 6.1 and weblogic-web-jar.dtd problems
                  3004
                  Aha - I guess I know what it is. It happens when it cannot resolve entity locally.
                  For example, if I change my weblogic.xml doctype from

                  <!DOCTYPE weblogic-web-app PUBLIC "-//BEA Systems, Inc.//DTD Web Application 6.0//EN" "http://www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd">

                  to

                  <!DOCTYPE weblogic-web-app PUBLIC "-//BEA Systems, Inc.//DTD Web Application 6.1//EN" "http://www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd">

                  and unplug network cable, application fails to deploy:

                  <Nov 8, 2001 12:07:32 AM PST> <Debug> <HTTP> <Could not resolve entity "-//BEA Systems, Inc.//DTD Web Application 6.1//EN". Check your dtd reference.>
                  <Nov 8, 2001 12:07:32 AM PST> <Error> <HTTP> <[examplesWebApp] Error reading Web application "C:\bea
                  \wlserver\config\examples\applications\myTestWebApp"
                  java.net.UnknownHostException: www.bea.com
                  at java.net.InetAddress.getAllByName0(InetAddress.java:571)
                  at java.net.InetAddress.getAllByName0(InetAddress.java:540)
                  at java.net.InetAddress.getAllByName(InetAddress.java:533)
                  at weblogic.net.http.HttpClient.openServer(HttpClient.java:191)
                  at weblogic.net.http.HttpClient.openServer(HttpClient.java:254)
                  at weblogic.net.http.HttpClient.<init>(HttpClient.java:117)
                  at weblogic.net.http.HttpURLConnection.getHttpClient(HttpURLConnection.java:119)
                  at weblogic.net.http.HttpURLConnection.getInputStream(HttpURLConnection.java:311)
                  at java.net.URL.openStream(URL.java:798)

                  (with the correct doctype

                  <!DOCTYPE weblogic-web-app PUBLIC "-//BEA Systems, Inc.//DTD Web Application 6.0//EN" "http://www.bea.com/servers/wls600/dtd/weblogi
                  c-web-jar.dtd">

                  it deploys just fine with network cable unplugged).

                  Borre Nordbakken <bno@brreg.no> wrote:
                  Strange.
                  I have created a case at BEA Support, and they called me this
                  morning to tell me that they have some simular cases reported earlyer and
                  the are going to investiage this problem.
                  --
                  Borre
                  "Dimitri Rakitine" <dr@dima.dhs.org> wrote in message
                  news:3be8e8b3@newsgroups.bea.com...
                  Yes. To make sure I just unplugged my box and WebLogic started and
                  deployed my apps without any problems.

                  Borre Nordbakken <bno@brreg.no> wrote:
                  And you are using WLS 6.1 SP1 ?
                  --
                  Borre
                  "Dimitri Rakitine" <dr@dima.dhs.org> wrote in message
                  news:3be86111@newsgroups.bea.com...
                  Strange - I thought that it always resolves these to dtd's in
                  weblogic.jar. It always starts fine when my DSL is down.

                  Borre Nordbakken <bno@brreg.no> wrote:
                  Hi,
                  We have problems with our finer.war application.
                  The problem is a BIG PROBLEM when my laptop doesent have any
                  network connectivity. The problem are: When i start the WLS the
                  server
                  trys to redeploy my web-app, an inside my web-inf directory i have a
                  file
                  named weblogic.xml. This file refers to an DTD
                  www.bea.com/servers/wls600/dtd/weblogic-web-jar.dtd
                  Is there anybody who knows how to prevent WLS to go external for
                  DTD's like theese? At BEA's support site i found information (wls51)
                  whitch
                  sed
                  that if an external source doesen't existed it tried to load the DTD
                  form
                  weblogic.jar
                  I'm developing my apps using JBuilder 5
                  Any idea ?
                  --
                  TIA,
                  Borre Nordbakken
                  --
                  Dimitri
                  --
                  Dimitri
                  --
                  Dimitri