7 Replies Latest reply on Aug 6, 2001 9:02 AM by 3004

    Placeholder problem

    3004
      Hi,

      I am using WLCS 3.5/WLS 6.0 service pack 2/Oracle 8.1.6 with WebLogic
      jdrivers (816_7)(weblogicoci37.dll) and am trying to display the sample
      application. When the placeholders are loading I get the following
      exceptions:

      ####<02-Aug-01 11:53:27 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:27 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:35 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:35 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:41 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:41 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:46 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:46 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:50 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>
      ####<02-Aug-01 11:53:50 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
      <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
      <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
      unsupported network datatype or representation>

      Can anybody help?

      Laura :-)


        • 1. Re: Placeholder problem
          3004

          Laura,

          Yuck. :(

          What OS are you running on?
          Are these exceptions are coming from running loadSamplePlaceholders.bat/sh?

          PJL

          "Laura Allen" <mumbles_uk@hotmail.com> wrote:
          Hi,

          I am using WLCS 3.5/WLS 6.0 service pack 2/Oracle 8.1.6 with WebLogic
          jdrivers (816_7)(weblogicoci37.dll) and am trying to display the sample
          application. When the placeholders are loading I get the following
          exceptions:

          ####<02-Aug-01 11:53:27 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:27 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:35 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:35 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '11' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:41 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:41 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:46 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:46 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:50 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_top_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>
          ####<02-Aug-01 11:53:50 BST> <Warning> <ph:placeholder> <ecsoft-lo-twks1>
          <wlcsServer> <ExecuteThread: '13' for queue: 'default'> <> <> <000000>
          <Content Error (Placeholder:cs_side_generic) SQL Exception:ORA-03115:
          unsupported network datatype or representation>

          Can anybody help?

          Laura :-)

          • 2. Re: Placeholder problem
            3004
            Hi Peter,

            Fun this isn't it! I'm running on Windows 2000 Professional with WLServer
            6.0 service pack 2 and Oracle 8.1.6. I'm beginning to think that my
            database configuration is not fully supported - the version of Oracle I'm
            using is 8.1.6.0.0, and I've got the WL_HOME\bin\oci816_7 (weblogicoci37.dll
            and weblogicoxa37.dll) on my classpath etc. Connection to the commercePool
            does not seem to be the problem - I have proved that the drivers work using
            dbping. But then when I try and load the sample data it wants none of it!
            I've tried altering things in EBCC, and I cannot open any placeholders for
            editing or create new ones. Ironically the loadads.bat and
            loadSamplePlaceholders.bat files run OK but the discounts and rules don't.

            Weird huh?

            Laura :-|


            • 3. Re: Placeholder problem
              3004

              Can you upgrade your Oracle database from 8.1.6.0.0 to
              8.1.7 or the latest 8.1.6.3 patchset (I believe that would be 8.1.6.3.5) and see
              if this resolves the problem with loadsampledata? I suspect that it will due
              to our usage of CLOB datatypes.

              Also, any chance that your Oracle Client and Oracle Database are of different
              release levels, or are they both running on the same box?


              • 4. Re: Placeholder problem
                3004
                I'll try upgrading to 8.1.7 or the 8.1.6.3 and see if this makes any
                difference - thanks for your suggestions! The client and database are
                running on the same box.

                Laura :-)

                "Shari" <sturney@bea.com> wrote in message
                news:3b698498$1@newsgroups.bea.com...
                >
                Can you upgrade your Oracle database from 8.1.6.0.0 to
                8.1.7 or the latest 8.1.6.3 patchset (I believe that would be 8.1.6.3.5)
                and see
                if this resolves the problem with loadsampledata? I suspect that it will
                due
                to our usage of CLOB datatypes.

                Also, any chance that your Oracle Client and Oracle Database are of
                different
                release levels, or are they both running on the same box?

                • 5. Re: Placeholder problem
                  3004
                  I have upgraded to 8.1.7.0.0 - but now I get the following error and WLCS
                  will not start - any ideas?

                  =============== Initializing Logger ======================
                  Starting Loading jDriver/Oracle .....
                  <03-Aug-01 17:01:21 BST> <Emergency> <Server> <Unable to initialize the
                  server:
                  'Fatal initialization exception
                  Throwable: java.lang.IllegalAccessError:
                  com.beasys.commerce.axiom.contact.secur
                  ity.RDBMSException: realm initialization failed,
                  Connection.prepareStatement() f
                  ailed on statement "", - with nested exception:
                  [java.sql.SQLException: ORA-00942: table or view does not exist]
                  java.lang.IllegalAccessError:
                  com.beasys.commerce.axiom.contact.security.RDBMSEx
                  ception: realm initialization failed, Connection.prepareStatement() failed
                  on st
                  atement "", - with nested exception:
                  [java.sql.SQLException: ORA-00942: table or view does not exist]
                  at weblogic.security.acl.Realm.getRealm(Realm.java:91)
                  at weblogic.security.acl.Realm.getRealm(Realm.java:62)
                  at
                  weblogic.security.SecurityService.initializeRealm(SecurityService.jav
                  a:265)
                  at
                  weblogic.security.SecurityService.initialize(SecurityService.java:123
                  )
                  at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
                  at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
                  at weblogic.Server.main(Server.java:35)
                  '>
                  ***************************************************************************
                  The WebLogic Server did not start up properly.
                  Exception raised: java.lang.IllegalAccessError:
                  com.beasys.commerce.axiom.contac
                  t.security.RDBMSException: realm initialization failed,
                  Connection.prepareStatem
                  ent() failed on statement "", - with nested exception:
                  [java.sql.SQLException: ORA-00942: table or view does not exist]
                  java.lang.IllegalAccessError:
                  com.beasys.commerce.axiom.contact.security.RDBMSEx
                  ception: realm initialization failed, Connection.prepareStatement() failed
                  on st
                  atement "", - with nested exception:
                  [java.sql.SQLException: ORA-00942: table or view does not exist]
                  at weblogic.security.acl.Realm.getRealm(Realm.java:91)
                  at weblogic.security.acl.Realm.getRealm(Realm.java:62)
                  at
                  weblogic.security.SecurityService.initializeRealm(SecurityService.jav
                  a:265)
                  at
                  weblogic.security.SecurityService.initialize(SecurityService.java:123
                  )
                  at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
                  at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
                  at weblogic.Server.main(Server.java:35)
                  Reason: Fatal initialization exception
                  ***************************************************************************
                  Press any key to continue . . .



                  "Shari" <sturney@bea.com> wrote in message
                  news:3b698498$1@newsgroups.bea.com...
                  >
                  Can you upgrade your Oracle database from 8.1.6.0.0 to
                  8.1.7 or the latest 8.1.6.3 patchset (I believe that would be 8.1.6.3.5)
                  and see
                  if this resolves the problem with loadsampledata? I suspect that it will
                  due
                  to our usage of CLOB datatypes.

                  Also, any chance that your Oracle Client and Oracle Database are of
                  different
                  release levels, or are they both running on the same box?

                  • 6. Re: Placeholder problem
                    3004
                    Laura,

                    Did you re-apply the DDL scripts after you switched to the new DB? It looks
                    like the User tables (used by the security realm) are missing.

                    Sincerely,

                    Daniel Selman



                    "Laura Allen" <mumbles_uk@hotmail.com> wrote in message
                    news:3b6acc38$1@newsgroups.bea.com...
                    I have upgraded to 8.1.7.0.0 - but now I get the following error and WLCS
                    will not start - any ideas?

                    =============== Initializing Logger ======================
                    Starting Loading jDriver/Oracle .....
                    <03-Aug-01 17:01:21 BST> <Emergency> <Server> <Unable to initialize the
                    server:
                    'Fatal initialization exception
                    Throwable: java.lang.IllegalAccessError:
                    com.beasys.commerce.axiom.contact.secur
                    ity.RDBMSException: realm initialization failed,
                    Connection.prepareStatement() f
                    ailed on statement "", - with nested exception:
                    [java.sql.SQLException: ORA-00942: table or view does not exist]
                    java.lang.IllegalAccessError:
                    com.beasys.commerce.axiom.contact.security.RDBMSEx
                    ception: realm initialization failed, Connection.prepareStatement() failed
                    on st
                    atement "", - with nested exception:
                    [java.sql.SQLException: ORA-00942: table or view does not exist]
                    at weblogic.security.acl.Realm.getRealm(Realm.java:91)
                    at weblogic.security.acl.Realm.getRealm(Realm.java:62)
                    at
                    weblogic.security.SecurityService.initializeRealm(SecurityService.jav
                    a:265)
                    at
                    weblogic.security.SecurityService.initialize(SecurityService.java:123
                    )
                    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
                    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
                    at weblogic.Server.main(Server.java:35)
                    '>
                    ***************************************************************************
                    The WebLogic Server did not start up properly.
                    Exception raised: java.lang.IllegalAccessError:
                    com.beasys.commerce.axiom.contac
                    t.security.RDBMSException: realm initialization failed,
                    Connection.prepareStatem
                    ent() failed on statement "", - with nested exception:
                    [java.sql.SQLException: ORA-00942: table or view does not exist]
                    java.lang.IllegalAccessError:
                    com.beasys.commerce.axiom.contact.security.RDBMSEx
                    ception: realm initialization failed, Connection.prepareStatement() failed
                    on st
                    atement "", - with nested exception:
                    [java.sql.SQLException: ORA-00942: table or view does not exist]
                    at weblogic.security.acl.Realm.getRealm(Realm.java:91)
                    at weblogic.security.acl.Realm.getRealm(Realm.java:62)
                    at
                    weblogic.security.SecurityService.initializeRealm(SecurityService.jav
                    a:265)
                    at
                    weblogic.security.SecurityService.initialize(SecurityService.java:123
                    )
                    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
                    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
                    at weblogic.Server.main(Server.java:35)
                    Reason: Fatal initialization exception
                    ***************************************************************************
                    Press any key to continue . . .



                    "Shari" <sturney@bea.com> wrote in message
                    news:3b698498$1@newsgroups.bea.com...
                    Can you upgrade your Oracle database from 8.1.6.0.0 to
                    8.1.7 or the latest 8.1.6.3 patchset (I believe that would be 8.1.6.3.5)
                    and see
                    if this resolves the problem with loadsampledata? I suspect that it
                    will
                    due
                    to our usage of CLOB datatypes.

                    Also, any chance that your Oracle Client and Oracle Database are of
                    different
                    release levels, or are they both running on the same box?

                    • 7. Re: Placeholder problem
                      3004
                      Thanks for your help - everything fine with Oracle 8.1.7 - I had indeed not
                      loaded the data under the correct user. Now feel really quite positive -
                      what a success for first thing on a Monday morning! Placeholders etc all
                      loaded and displaying fine. Thanks again, Laura

                      "Daniel Selman" <please@noreply.com> wrote in message
                      news:3b6ad38e@newsgroups.bea.com...
                      Laura,

                      Did you re-apply the DDL scripts after you switched to the new DB? It
                      looks
                      like the User tables (used by the security realm) are missing.

                      Sincerely,

                      Daniel Selman



                      "Laura Allen" <mumbles_uk@hotmail.com> wrote in message
                      news:3b6acc38$1@newsgroups.bea.com...
                      I have upgraded to 8.1.7.0.0 - but now I get the following error and
                      WLCS
                      will not start - any ideas?

                      =============== Initializing Logger ======================
                      Starting Loading jDriver/Oracle .....
                      <03-Aug-01 17:01:21 BST> <Emergency> <Server> <Unable to initialize the
                      server:
                      'Fatal initialization exception
                      Throwable: java.lang.IllegalAccessError:
                      com.beasys.commerce.axiom.contact.secur
                      ity.RDBMSException: realm initialization failed,
                      Connection.prepareStatement() f
                      ailed on statement "", - with nested exception:
                      [java.sql.SQLException: ORA-00942: table or view does not exist]
                      java.lang.IllegalAccessError:
                      com.beasys.commerce.axiom.contact.security.RDBMSEx
                      ception: realm initialization failed, Connection.prepareStatement()
                      failed
                      on st
                      atement "", - with nested exception:
                      [java.sql.SQLException: ORA-00942: table or view does not exist]
                      at weblogic.security.acl.Realm.getRealm(Realm.java:91)
                      at weblogic.security.acl.Realm.getRealm(Realm.java:62)
                      at
                      weblogic.security.SecurityService.initializeRealm(SecurityService.jav
                      a:265)
                      at
                      weblogic.security.SecurityService.initialize(SecurityService.java:123
                      )
                      at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
                      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
                      at weblogic.Server.main(Server.java:35)
                      '>
                      ***************************************************************************
                      The WebLogic Server did not start up properly.
                      Exception raised: java.lang.IllegalAccessError:
                      com.beasys.commerce.axiom.contac
                      t.security.RDBMSException: realm initialization failed,
                      Connection.prepareStatem
                      ent() failed on statement "", - with nested exception:
                      [java.sql.SQLException: ORA-00942: table or view does not exist]
                      java.lang.IllegalAccessError:
                      com.beasys.commerce.axiom.contact.security.RDBMSEx
                      ception: realm initialization failed, Connection.prepareStatement()
                      failed
                      on st
                      atement "", - with nested exception:
                      [java.sql.SQLException: ORA-00942: table or view does not exist]
                      at weblogic.security.acl.Realm.getRealm(Realm.java:91)
                      at weblogic.security.acl.Realm.getRealm(Realm.java:62)
                      at
                      weblogic.security.SecurityService.initializeRealm(SecurityService.jav
                      a:265)
                      at
                      weblogic.security.SecurityService.initialize(SecurityService.java:123
                      )
                      at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:343)
                      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:169)
                      at weblogic.Server.main(Server.java:35)
                      Reason: Fatal initialization exception
                      ***************************************************************************
                      Press any key to continue . . .



                      "Shari" <sturney@bea.com> wrote in message
                      news:3b698498$1@newsgroups.bea.com...
                      Can you upgrade your Oracle database from 8.1.6.0.0 to
                      8.1.7 or the latest 8.1.6.3 patchset (I believe that would be
                      8.1.6.3.5)
                      and see
                      if this resolves the problem with loadsampledata? I suspect that it
                      will
                      due
                      to our usage of CLOB datatypes.

                      Also, any chance that your Oracle Client and Oracle Database are of
                      different
                      release levels, or are they both running on the same box?