4 Replies Latest reply on Mar 22, 2001 3:32 PM by 3004

    weblogic.deploy update -- and that null message

    3004

      So, does anyone else receive an inexplicable error message when running "weblogic.deploy update" in version 6.0, stating that a "java.lang.NullPointerException" has been thrown?

      The update occurs anyway, but seeing a message like this is always disconcerting. Anyone have an idea why this is happening?

      (The exact trace that I receive is cut-n-pasted below.)

      T Fenstermaker
      Online Resources
      McLean VA

      java.lang.NullPointerException
      at weblogic.deploy.deployApplication(deploy.java:383)
      at weblogic.deploy.deploy(deploy.java:340)
      at weblogic.deploy.runBody(deploy.java:219)
      at weblogic.utils.compiler.Tool.run(Tool.java:81)
      at weblogic.deploy.main(deploy.java:954)

        • 1. Re: weblogic.deploy update -- and that null message
          3004
          So, does anyone else receive an inexplicable
          error message when running "weblogic.deploy
          update" in version 6.0, stating that a
          "java.lang.NullPointerException" has been thrown?
          I take it from the lack of response that the answer to this question must be either:

          a) No, no one else receives this inexplicable error, or,
          b) Yes, everyone else receives this inexplicable error and it's so well known how dare I ask.

          Anyone want to give me a clue which of these two is correct?

          T Fenstermaker
          Online Resources
          McLean VA


          • 2. Re: weblogic.deploy update -- and that null message
            3004

            "T Fenstermaker" <tcfml@yahoo.com> wrote:
            >
            So, does anyone else receive an inexplicable error message when running
            "weblogic.deploy update" in version 6.0, stating that a "java.lang.NullPointerException"
            has been thrown?

            The update occurs anyway, but seeing a message like this is always disconcerting.
            Anyone have an idea why this is happening?

            (The exact trace that I receive is cut-n-pasted below.)

            T Fenstermaker
            Online Resources
            McLean VA

            java.lang.NullPointerException
            at weblogic.deploy.deployApplication(deploy.java:383)
            at weblogic.deploy.deploy(deploy.java:340)
            at weblogic.deploy.runBody(deploy.java:219)
            at weblogic.utils.compiler.Tool.run(Tool.java:81)
            at weblogic.deploy.main(deploy.java:954)
            I get the same error. I only have weblogic.jar in my classpath. Does anyone have
            an answer to this?
            • 3. Re: weblogic.deploy update -- and that null message
              3004

              I to am getting this message. If anyone figures this out drop me
              an email fred.grafe@compoze.com

              "T Fenstermaker" <tcfml@yahoo.com> wrote:
              >
              So, does anyone else receive an inexplicable error message
              when running "weblogic.deploy update" in version 6.0,
              stating that a "java.lang.NullPointerException" has been
              thrown?

              The update occurs anyway, but seeing a message like this
              is always disconcerting. Anyone have an idea why this
              is happening?

              (The exact trace that I receive is cut-n-pasted below.)

              T Fenstermaker
              Online Resources
              McLean VA

              java.lang.NullPointerException
              at weblogic.deploy.deployApplication(deploy.java:383)
              at weblogic.deploy.deploy(deploy.java:340)
              at weblogic.deploy.runBody(deploy.java:219)
              at weblogic.utils.compiler.Tool.run(Tool.java:81)
              at weblogic.deploy.main(deploy.java:954)
              • 4. Re: weblogic.deploy update -- and that null message
                3004

                If you use the -debug setting with weblogic.deploy you get more
                info. I'm deploying an .ear file, deployment works if I use the
                console, and if I just copy the ear file to the domain and WLS
                autodeploys.

                I getting the following error.
                [java] java.net.MalformedURLException: unknown protocol: d
                [java] at java.net.URL.<init>(URL.java:480)
                [java] at java.net.URL.<init>(URL.java:376)
                [java] at java.net.URL.<init>(URL.java:330)
                [java] at weblogic.deploy.parseSource(deploy.java:539)
                [java] at weblogic.deploy.init(deploy.java:299)
                [java] at weblogic.deploy.runBody(deploy.java:214)
                [java] at weblogic.utils.compiler.Tool.run(Tool.java:81)
                [java] at weblogic.deploy.main(deploy.java:1036)
                [java] javax.management.InstanceNotFoundException: harmony
                [java] at weblogic.rmi.internal.AbstractOutboundRequest.sendRecei
                OutboundRequest.java:90)
                [java] at weblogic.management.internal.AdminMBeanHomeImpl_WLStub.
                minMBeanHomeImpl_WLStub.java:1147)
                [java] at weblogic.deploy.findMBean(deploy.java:815)
                [java] at weblogic.deploy.findApplicationMBean(deploy.java:804)
                [java] at weblogic.deploy.deploy(deploy.java:312)
                [java] at weblogic.deploy.runBody(deploy.java:222)
                [java] at weblogic.utils.compiler.Tool.run(Tool.java:81)
                [java] at weblogic.deploy.main(deploy.java:1036)
                [java] java.lang.NullPointerException
                [java] at weblogic.deploy.deployApplication(deploy.java:420)
                [java] at weblogic.deploy.deploy(deploy.java:367)
                [java] at weblogic.deploy.runBody(deploy.java:222)
                [java] at weblogic.utils.compiler.Tool.run(Tool.java:81)
                [java] at weblogic.deploy.main(deploy.java:1036)
                [java] Java Result: 1


                "T Fenstermaker" <tcfml@yahoo.com> wrote:
                >
                So, does anyone else receive an inexplicable
                error message when running "weblogic.deploy
                update" in version 6.0, stating that a
                "java.lang.NullPointerException" has been thrown?
                I take it from the lack of response that the answer to
                this question must be either:

                a) No, no one else receives this inexplicable error, or,
                b) Yes, everyone else receives this inexplicable error
                and it's so well known how dare I ask.

                Anyone want to give me a clue which of these two is correct?

                T Fenstermaker
                Online Resources
                McLean VA