1 Reply Latest reply on May 22, 2008 9:51 PM by 666705

    DDBeanCreateException Deploying to WLS 10.0

    666705
      Hi All,

      I would very much appreciate any help on the following problem.

      I used WorkSpace 1.1 to develop my app and tested in on WLS 10.0 within it. In WorkSpace the server runs on port 7021 and it has ALSB as well on the same port.

      I created EARs and tryed deploying them to another WLS 10.0 that was used by ALSB, outside of Work Space. All module deployed fine.

      Then I created a standalone WLS 10.0 server and tried deploying my modules on it. The server by default is on port 7001. Deployment failed with this error:

      javax.enterprise.deploy.model.exceptions.DDBeanCreateException: [J2EE Deployment SPI:260142]The descriptor at 'META-INF/annotation-manifest.xml' in module 'XXX.war' is not recognized, and could not be parsed.

      I found this article in Chris Hogue's blog (http://dev2dev.bea.com/blog/hogue/archive/2006/09/changing_annota.html_)
      He recommends adding weblogic J2EE weblogic-controls-1.0 library to the EAR. I already have weblogic-controls-10.0 library attached. The only thing that jumps at me is the difference in ports. I manually changed references in annotation.xml from port 7021 to port 7001, but it did not help.

      Thoughts?? Thanks in advance!
        • 1. Re: DDBeanCreateException Deploying to WLS 10.0
          666705
          Try deploying weblogic-controls-1.0.ear as a library directly in WLS console instead of adding it to your project ear file.

          If you still get error try deploying beehive-controls-1. 0.ear and beehive-netui-1.0.war also. This is how I resolved this error in WLS 9.2 and I hope this works for WLS 10 too. No changes in annotation-manifest.xml were needed for my app.