1 Reply Latest reply on Mar 25, 2007 12:37 AM by 666705

    apache axis 1.4 & WLS 9.1 compatible?

    666705
      Hi,
      I am trying to expose some business logic as a webservice using apache axis 1.4 and weblogic 9.1

      I have installed apache axis on WLS and the sanity check of the installation is saying all is fine!

      However when I try to publish my wsdl via my service url, I get the following error in the logs.

      ==============================================
      22 Mar 2007 17:03:35,748 DEBUG: [org.apache.axis.server.AxisServer ()] AxisServer.generateWSDL: Transport = 'http'
      22 Mar 2007 17:03:35,748 DEBUG: [org.apache.axis.i18n.ProjectResourceBundle ()] org.apache.axis.i18n.resource::handleGetObject(noServ
      ice05)
      22 Mar 2007 17:03:35,751 DEBUG: [org.apache.axis.utils.XMLUtils ()] Failed to set EntityResolver to null on DocumentBuilder
      java.lang.NullPointerException
      at weblogic.xml.jaxp.ChainingEntityResolver.popEntityResolver(ChainingEntityResolver.java:61)
      at weblogic.xml.jaxp.RegistryDocumentBuilder.setEntityResolver(RegistryDocumentBuilder.java:169)
      at org.apache.axis.utils.XMLUtils.releaseDocumentBuilder(XMLUtils.java:252)


      ====================================================

      Anyone managed to host a webservice on Weblogic Server 9.1 using apache axis 1.4 successfully?

      Or any indication of whats causing the exception?

      TIA