1 Reply Latest reply on Jul 23, 2004 5:18 PM by 666705

    Having problems starting Weblogic Managed Server

    666705
      Hi,
      I am new to WebLogic and I was looking at the webservices examples in samples dir and I took the example and just moved it to one of my currently deployed Web Application folder and changed the dir strutcure instead of the samples dir strutcure, compiled and deployed as standalone Application(not as part of my currently deployed Web App). It worked fine.
      Then since there would be a need for reuse of lot of the current Web App. in the web services we are trying to implement, I tried to put the ear that got created in the WEB-INF/lib of the currently deployed exploded dir. It was pretty dumb to put the ear there, just thought, worst case it wont work, I thought I could pull the ear out of there. But seems like this changed the entire config.xml and ever since that my admin server got changed to myserver, I corrected all the problems with the admin server and admin server and node server they come up just fine. When trying to bring up Managed server, I get the following excpetion
      Jul 16, 2004 4:00:37 PM EDT> <Debug> <HTTP> <BEA-101158> <Exception thrown while loading epic_dev: java.lang.NullPointerException
      java.lang.NullPointerException
           at weblogic.utils.enumerations.FileEnumeration.getNextFile(FileEnumeration.java:155)
           at weblogic.utils.enumerations.FileEnumeration.hasMoreFiles(FileEnumeration.java:102)
           at weblogic.utils.enumerations.FileEnumeration.hasMoreElements(FileEnumeration.java:134)
           at weblogic.utils.jars.ExplodedJarFile$1.hasNext(ExplodedJarFile.java:112)
           at weblogic.utils.classloaders.ExtractionHelper.extractClassFiles(ExtractionHelper.java:117)
           at weblogic.servlet.internal.WebAppServletContext.extractClassFiles(WebAppServletContext.java:5119)
           at weblogic.servlet.internal.WebAppServletContext.setDocroot(WebAppServletContext.java:4991)
           at weblogic.servlet.internal.WebAppServletContext.init(WebAppServletContext.java:560)
           at weblogic.servlet.internal.WebAppServletContext.<init>(WebAppServletContext.java:511)
           at weblogic.servlet.internal.HttpServer.loadWebApp(HttpServer.java:594)
           at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:623)
           at weblogic.j2ee.J2EEApplicationContainer.prepareWebModule(J2EEApplicationContainer.java:2896)
           at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1532)
           at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1188)
           at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1031)
           at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:822)
           at weblogic.management.deploy.slave.SlaveDeployer$Application.prepare(SlaveDeployer.java:3085)
           at weblogic.management.deploy.slave.SlaveDeployer.prepareAllApplications(SlaveDeployer.java:930)
           at weblogic.management.deploy.slave.SlaveDeployer.resume(SlaveDeployer.java:398)
           at weblogic.management.deploy.DeploymentManagerServerLifeCycleImpl.resume(DeploymentManagerServerLifeCycleImpl.java:230)
           at weblogic.t3.srvr.SubsystemManager.resume(SubsystemManager.java:131)
           at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:964)
           at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:359)
           at weblogic.Server.main(Server.java:32)
      >
      <Jul 16, 2004 4:00:37 PM EDT> <Info> <Deployer> <BEA-149061> <Module epic_dev of application appsdirepic_dev_dir failed to transition from unprepared to prepared on server betsy_dev.>
      <Jul 16, 2004 4:00:37 PM EDT> <Error> <Deployer> <BEA-149205> <Failed to initialize the application appsdirepic_dev_dir due to error weblogic.management.ApplicationException: prepare failed for epic_dev
      {
      Module Name: epic_dev, Error: Could not load epic_dev: java.lang.NullPointerException
      }.
      weblogic.management.ApplicationException: prepare failed for epic_dev
      {
      Module Name: epic_dev, Error: Could not load epic_dev: java.lang.NullPointerException
      }
           at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1555)
           at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1188)
           at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1031)
           at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:822)
           at weblogic.management.deploy.slave.SlaveDeployer$Application.prepare(SlaveDeployer.java:3085)
           at weblogic.management.deploy.slave.SlaveDeployer.prepareAllApplications(SlaveDeployer.java:930)
           at weblogic.management.deploy.slave.SlaveDeployer.resume(SlaveDeployer.java:398)
           at weblogic.management.deploy.DeploymentManagerServerLifeCycleImpl.resume(DeploymentManagerServerLifeCycleImpl.java:230)
           at weblogic.t3.srvr.SubsystemManager.resume(SubsystemManager.java:131)
           at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:964)
           at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:359)
           at weblogic.Server.main(Server.java:32)
      >


      Could someone help me with resolving this.(This is only the dev machine, I played thannkfully!).
      And also would like to get suggestions on setting up the new webserverces that we are trying to do. If I need to reuse lot of class files from current appl., how do i go about implementing this webservice? Should this be part of the existing application? or Web service could be a separate application and somehow we could look at the web app which is in the same domain.
      Any help is appreciated.

      Thanks
      Anna