3 Replies Latest reply on Dec 7, 2001 10:54 AM by 3004

    Re: Managed server->admin connection problem

    3004
      Do you get any error on the Admin server, when you attempt to start the
      managed server ?

      Timothy Fry <tim@imoney.com> wrote in message
      news:39f7230a$1@newsgroups.bea.com...
      Hi, I'm trying to get a managed server running (see my previous post re:
      the
      admin.host property problem). My latest attempts result in the managed
      server apparently failing to contact my running admin server. The managed
      server waits for 1 minute before producing the following traceback: (note
      that I can successfully ping the admin server at the attempted URL with
      "java weblogic.Admin -url T3://10.0.0.3:7001 PING"), and that I've tried
      various combinations of URL (http://, t3:// and T3://) and with all
      variations on hostname and IP address for this machine -- PING always
      works,
      and the managed server always fails).

      Any ideas?

      Thanks in advance,

      Tim


      Starting WebLogic Server ....
      <Wed Oct 25 12:57:38 GMT-05:00 2000> <Warning> <Management> <Unrecognized
      property: admin.host>
      <Wed Oct 25 12:58:39 GMT-05:00 2000> <Error> <Configuration Management>
      <Error connecting to admin server and initializing admin home: admin URL:
      t3://10.0.0.3:7001
      javax.naming.CommunicationException. Root exception is
      java.net.ConnectException: No server found at T3://10.0.0.3:7001
      at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:170)
      at weblogic.rjvm.ServerURL.findOrCreateRJVM(ServerURL.java:215)
      at
      weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialCon
      textFactoryDelegate.java:219)
      at weblogic.jndi.Environment.getContext(Environment.java:129)
      at
      weblogic.jndi.Environment.getInitialContext(Environment.java:112)
      at
      weblogic.management.Admin.initializeRemoteAdminHome(Admin.java:712)
      at weblogic.management.Admin.start(Admin.java:295)
      at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:357)
      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:160)
      at weblogic.Server.main(Server.java:32)
      >
      <Wed Oct 25 12:58:39 GMT-05:00 2000> <Emergency> <Server> <Unable to
      initialize the server: Fatal initialization exception
      Throwable: weblogic.management.configuration.ConfigurationException: admin
      URL: t3://10.0.0.3:7001 - with nested exception:
      [javax.naming.CommunicationException [Root exception is
      java.net.ConnectException: No server found at T3://10.0.0.3:7001]]
      weblogic.management.configuration.ConfigurationException: admin URL:
      t3://10.0.0.3:7001 - with nested exception:
      [javax.naming.CommunicationException [Root exception is
      java.net.ConnectException: No server found at T3://10.0.0.3:7001]]
      at
      weblogic.management.Admin.initializeRemoteAdminHome(Admin.java:719)
      at weblogic.management.Admin.start(Admin.java:295)
      at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:357)
      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:160)
      at weblogic.Server.main(Server.java:32)
      .
      .
      .


        • 1. Re: Managed server->admin connection problem
          3004
          Do you get the following error on Admin Server ..... (This is a known
          problem and will be fixed in the next beta refresh.)

          <Wed Oct 04 18:16:14 PDT 2000> <Warning> <HTTP> <Unable to resolve "GET
          /Bootstrap
          HTTP/1.1" on HttpServer(5316402,null default ctx,wl_default_web_server,[])>
          java.lang.Exception: Unable to resolve 'GET /Bootstrap HTTP/1.1' on
          HttpServer(5316402,null default ctx,wl_default_web_server,[])
          at
          weblogic.servlet.internal.MuxableSocketHTTP.dispatch(MuxableSocketHTTP.java:
          336)
          at
          weblogic.socket.NTSocketMuxer.processSockets(NTSocketMuxer.java:461)
          at
          weblogic.socket.SocketReaderRequest.execute(SocketReaderRequest.java:23)
          at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:133)
          at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:116)



          • 2. RE: Re: Managed server->admin connection problem
            3004
            i am starting the managed server and it is giving an error unable to instantiate admin home
            • 3. RE: Re: Managed server->admin connection problem
              3004
              i am starting the managed server and it is giving an error unable to instantiate admin home