1 Reply Latest reply on Aug 29, 2001 8:34 PM by 3004

    How to deal the user "system" problem in Custom Realm when migrating from weblogic5.1 to 6.1?

    3004
      I don't know whether my problem related to this news group.
      Hope someone help me!!
      Thanks.

      As you know, when start the managed server of weblogic 6, the password
      of the user system is required.
      but our application on welogic 5.1 use the database tables to control the
      security(that's,the custom realm access the account EJB). Before we needn't
      to input password when start the application. But when migrating from
      weblogic5.1 to 6.1,
      the password of the user system is required, after input password,the error
      rised as follow:

      <2001-8-29 pm 03:42:38> <Emergency> <Server> <Unable to initialize the
      server: 'Fatal initialization exception
      Throwable: java.lang.SecurityException: Authentication for user system
      denied
      java.lang.SecurityException: Authentication for user system denied
      at
      weblogic.security.SecurityService.initializeSuid(SecurityService.java:264)
      at
      weblogic.security.SecurityService.initialize(SecurityService.java:102)
      at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:385)
      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:197)
      at weblogic.Server.main(Server.java:35)
      '>
      ***************************************************************************
      The WebLogic Server did not start up properly.
      Exception raised: java.lang.SecurityException: Authentication for user
      system denied
      java.lang.SecurityException: Authentication for user system denied
      at
      weblogic.security.SecurityService.initializeSuid(SecurityService.java:264)
      at
      weblogic.security.SecurityService.initialize(SecurityService.java:102)
      at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:385)
      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:197)
      at weblogic.Server.main(Server.java:35)
      Reason: Fatal initialization exception
      ***************************************************************************

      How can I fix this problem??

      Thank you in advance.

      Raphael Quan


        • 1. Re: How to deal the user "system" problem in Custom Realm when migrating from weblogic5.1 to 6.1?
          3004
          WLS 61 requires the system password to startup.
          If you would not like to enter it each time your applicaiton (built on top of
          61) starts up you can:
          1) set this in the startWebLogic.cmd script as follows:
          java ..... -Dweblogic.management.password=yourPwd weblogic.Server
          2) set this in the password.ini file present in the root dir of your domain (by
          default -config\mydomain)

          cheers,
          Mihir


          raphael wrote:
          I don't know whether my problem related to this news group.
          Hope someone help me!!
          Thanks.

          As you know, when start the managed server of weblogic 6, the password
          of the user system is required.
          but our application on welogic 5.1 use the database tables to control the
          security(that's,the custom realm access the account EJB). Before we needn't
          to input password when start the application. But when migrating from
          weblogic5.1 to 6.1,
          the password of the user system is required, after input password,the error
          rised as follow:

          <2001-8-29 pm 03:42:38> <Emergency> <Server> <Unable to initialize the
          server: 'Fatal initialization exception
          Throwable: java.lang.SecurityException: Authentication for user system
          denied
          java.lang.SecurityException: Authentication for user system denied
          at
          weblogic.security.SecurityService.initializeSuid(SecurityService.java:264)
          at
          weblogic.security.SecurityService.initialize(SecurityService.java:102)
          at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:385)
          at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:197)
          at weblogic.Server.main(Server.java:35)
          '>
          ***************************************************************************
          The WebLogic Server did not start up properly.
          Exception raised: java.lang.SecurityException: Authentication for user
          system denied
          java.lang.SecurityException: Authentication for user system denied
          at
          weblogic.security.SecurityService.initializeSuid(SecurityService.java:264)
          at
          weblogic.security.SecurityService.initialize(SecurityService.java:102)
          at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:385)
          at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:197)
          at weblogic.Server.main(Server.java:35)
          Reason: Fatal initialization exception
          ***************************************************************************

          How can I fix this problem??

          Thank you in advance.

          Raphael Quan