2 Replies Latest reply on Dec 28, 2000 3:48 PM by 3004

    SIGBUS 10 bus error

    3004
      I'm having problem with weblogic server core dumping with 'SIGBUS 10 bus error' irregularly. I'm unable to reproduce this bug as there doesn't seem to be any pattern. It would work for a few customers and then dies even though we've only had no more than 5 requests (The traffic on our website is fairly slow). Once I bounce the server, it would work again for a few more customers then core dumps again with same error. I noticed from previous discussion boards that this might be a JVM issue (Solaris_JDK_1.2.2_05a)?? Can anyone tell me if rolling back my jdk version would fix this problem? Any help would be greatly appreciated, thanks!WeblogicServer 5.10 sp6Platform (OS Version)=================Sun Sparc Solaris 7JDK Version (if applicable)=====================Solaris_JDK_1.2.2_05aERROR MESSAGE===============SIGBUS 10 bus error si_signo [10]: BUS si_errno [0]: si_code [1]: BUS_ADRALN [addr: 0xedc1fdfd]stackpointer=EADC0D70Inconsistent thread : best efforts attempt (may fail)"SeedGenerator Thread" (TID:0x17637a8, sys_thread_t:0x17636e0, state:CW, thread_t: t@31, threadID:0xe9701dc8, stack_bottom:0xe9702000, stack_size:0x20000) prio=1
        • 1. Re: SIGBUS 10 bus error
          3004
          See http://www.weblogic.com/platforms/index.html#solaris for
          suggested workarounds.

          Thomas <thomas.tsai@rmkr.com> wrote:
          I'm having problem with weblogic server core dumping with 'SIGBUS 10 bus error' irregularly. I'm unable to reproduce this bug as there doesn't seem to be any pattern. It would work for a few customers and then dies even though we've only had no more than 5 requests (The traffic on our website is fairly slow). Once I bounce the server, it would work again for a few more customers then core dumps again with same error. I noticed from previous discussion boards that this might be a JVM issue (Solaris_JDK_1
          .2.2_05a)?? Can anyone tell me if rolling back my jdk version would fix this problem? Any help would be greatly appreciated, thanks!WeblogicServer 5.10 sp6Platform (OS Version)=================Sun Sparc Solaris 7JDK Version (if applicable)=====================Solaris_JDK_1.2.2_05aERROR MESSAGE===============SIGBUS 10 bus error si_signo [10]: BUS si_errno [0]: si_code [1]: BUS_ADRALN [addr: 0xedc1fdfd]stackpointer=EADC0D70Inconsistent thread : best efforts attempt (may fail)"SeedGenerator Thread
          " (TID:0x17637a8, sys_thread_t:0x17636e0, state:CW, thread_t: t@31, threadID:0xe9701dc8, stack_bottom:0xe9702000, stack_size:0x20000) prio=1

          Dimitri

          • 2. Re: SIGBUS 10 bus error
            3004
            take a look at http://www.weblogic.com/platforms/sun/index.html
            it recommends using:
            export JVMARGS="inline_instrs_jit=0"
            with 1.2.2_05a

            "Thomas" <thomas.tsai@rmkr.com> wrote in message
            news:3a2e8d4c$1@newsgroups.bea.com...
            I'm having problem with weblogic server core dumping with 'SIGBUS 10 bus
            error' irregularly. I'm unable to reproduce this bug as there doesn't seem
            to be any pattern. It would work for a few customers and then dies even
            though we've only had no more than 5 requests (The traffic on our website is
            fairly slow). Once I bounce the server, it would work again for a few more
            customers then core dumps again with same error. I noticed from previous
            discussion boards that this might be a JVM issue (Solaris_JDK_1.2.2_05a)??
            Can anyone tell me if rolling back my jdk version would fix this problem?
            Any help would be greatly appreciated, thanks!WeblogicServer 5.10
            sp6Platform (OS Version)=================Sun Sparc Solaris 7JDK Version (if
            applicable)=====================Solaris_JDK_1.2.2_05aERROR
            MESSAGE===============SIGBUS 10 bus error si_signo [10]: BUS si_errno
            [0]: si_code [1]: BUS_ADRALN [addr:
            0xedc1fdfd]stackpointer=EADC0D70Inconsistent thread : best efforts attempt
            (may fail)"SeedGenerator Thread" (TID:0x17637a8, sys_thread_t:0x17636e0,
            state:CW, thread_t: t@31, threadID:0xe9701dc8, stack_bottom:0xe9702000,
            stack_size:0x20000) prio=1