0 Replies Latest reply on Mar 15, 2007 2:32 PM by 666705

    WLST nmStart doesn't work

    666705
      Hi i am trying to start the admin server using nmStart() command but resulted throwing below error. It looks like a user authentication problem.

      Well its a long story...
      i Couldn't able to connect to the node manager through WLST for the first time, so i had to change the NM user credentials from the console. Later i tried to connect to nodemanager using nmConnect() with the updated credentials this time it worked. But unfortunately i am not able to start the admin server. Help would be appreciated on this..

      One more point...i am getting user authentication errors when i tried to connect using the connect() command with the running admin server (whcih has started by weblogic.Serve). In this case i can able to logon to the console with the user 'system'. But user system is not getting authenticated when i tried to conenct or start the admin server using WLST.


      wls:/nm/SMOReports> nmStart("AdminServer","D:/bea/weblogic92/domains/SMOReports"
      ,props=makePropertiesObject("weblogic.ListenPort=7001"))
      Starting server AdminServer ...
      Error Starting server AdminServer: weblogic.nodemanager.NMException: Exception w
      hile starting server 'AdminServer': java.io.IOException: Server failed to start
      up. See server output log for more details.


      In the logs the error shown as ...
      ####<Mar 15, 2007 9:37:58 AM EDT> <Critical> <Security> <RCHZ3033> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1173965878760> <BEA-090403> <Authentication for user denied>
      ####<Mar 15, 2007 9:37:58 AM EDT> <Critical> <WebLogicServer> <RCHZ3033> <AdminServer> <Main Thread> <<WLS Kernel>> <> <> <1173965878760> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user denied
      weblogic.security.SecurityInitializationException: Authentication for user denied
           at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(CommonSecurityServiceManagerDelegateImpl.java:947)
           at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(CommonSecurityServiceManagerDelegateImpl.java:1029)
           at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager.java:854)
           at weblogic.security.SecurityService.start(SecurityService.java:141)
           at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
           at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)