1 Reply Latest reply on Feb 12, 2004 1:44 PM by 3004

    WLS 6.1 + JDK 1.4.1

    3004

      Hello,

      I am trying to run WLS 6.1 using JDK 1.4.1 on HP UX 11i and I am getting the following
      error. Can somebody please tell me what could be the issue here ? Though BEA ships
      JDK 1.3.1, one of the ear files that I have written requires JDK 1.4.1.

      java.lang.SecurityException: Unable to locate a login configuration at com.sun.security.auth.login.ConfigFile.<init>(ConfigFile.java:97)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)


      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)


      at java.lang.reflect.Constructor.newInstance(Constructor.java:274) at java.lang.Class.newInstance0(Class.java:306)
      at java.lang.Class.newInstance(Class.java:259) at javax.security.auth.login.Configuration$3.run(Configuration.java:221)
      at java.security.AccessController.doPrivileged(Native Method) at javax.security.auth.login.Configuration.getConfiguration(Configuration.java:215)


      at javax.security.auth.login.LoginContext$1.run(LoginContext.java:170) at java.security.AccessController.doPrivileged(Native
      Method) at javax.security.auth.login.LoginContext.init(LoginContext.java:167)
      at javax.security.auth.login.LoginContext.<init>(LoginContext.java:404) at weblogic.security.internal.ServerAuthenticate.main(ServerAuthenticate.java:78)


      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:210) at weblogic.Server.main(Server.java:35)
      Caused by: java.io.IOException: Unable to locate a login configuration at com.sun.security.auth.login.ConfigFile.init(ConfigFile.java:206)
      at com.sun.security.auth.login.ConfigFile.<init>(ConfigFile.java:95) ... 16 more


        • 1. Re: WLS 6.1 + JDK 1.4.1
          3004
          On 12 Feb 2004 03:47:23 -0800, Giridhar S <giridhar.s@hp.com> wrote:

          >
          Hello,

          I am trying to run WLS 6.1 using JDK 1.4.1 on HP UX 11i and I am getting
          the following
          error. Can somebody please tell me what could be the issue here ? Though
          BEA ships
          JDK 1.3.1, one of the ear files that I have written requires JDK 1.4.1.

          java.lang.SecurityException: Unable to locate a login configuration at
          com.sun.security.auth.login.ConfigFile.<init>(ConfigFile.java:97)
          at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
          at
          sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)


          at
          sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)


          at java.lang.reflect.Constructor.newInstance(Constructor.java:274) at
          java.lang.Class.newInstance0(Class.java:306)
          at java.lang.Class.newInstance(Class.java:259) at
          javax.security.auth.login.Configuration$3.run(Configuration.java:221)
          at java.security.AccessController.doPrivileged(Native Method) at
          javax.security.auth.login.Configuration.getConfiguration(Configuration.java:215)


          at javax.security.auth.login.LoginContext$1.run(LoginContext.java:170)
          at java.security.AccessController.doPrivileged(Native
          Method) at
          javax.security.auth.login.LoginContext.init(LoginContext.java:167)
          at javax.security.auth.login.LoginContext.<init>(LoginContext.java:404)
          at
          weblogic.security.internal.ServerAuthenticate.main(ServerAuthenticate.java:78)


          at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:210) at
          weblogic.Server.main(Server.java:35)
          Caused by: java.io.IOException: Unable to locate a login configuration
          at com.sun.security.auth.login.ConfigFile.init(ConfigFile.java:206)
          at com.sun.security.auth.login.ConfigFile.<init>(ConfigFile.java:95) ...
          16 more

          I believe that your configuration is an unsupported one:
          See http://e-docs.bea.com/wls/certifications/certs_610/hp9000.html#sp3

          6.1 had a private copy of JAAS, JAAS was included in 1.4 so my guess is
          that there is some incompatibility there.
          --
          Using M2, Opera's revolutionary e-mail client: http://www.opera.com/m2/