1 Reply Latest reply on Jun 22, 2001 11:03 PM by 3004

    Problems Connecting to LDAP (NDS) from WLS 5.1

    3004
      Hi,

      I am WLS 5.1 with sp8 and trying to connect to NDS LDAP Server 4.12. I
      checked the LDAP log file which says :

      conn=28 fd=704 slot=704 connection from 127.0.0.1 to 127.0.0.1
      conn=28 op=0 BIND
      dn="uid=admin,ou=Administrators,ou=TopologyManagement,o=NetscapeRoot"
      method=128 version=3
      conn=28 op=0 RESULT err=0 tag=97 nentries=0 etime=0
      conn=28 op=1 SRCH base="o=bozpivot.com" scope=0 filter="(objectclass=*)"
      conn=28 op=1 RESULT err=0 tag=101 nentries=1 etime=0
      conn=28 op=3 SRCH base="ou=Groups,o=bozpivot.com" scope=0
      filter="(objectclass=*)"
      conn=28 op=3 RESULT err=0 tag=101 nentries=1 etime=0
      conn=28 op=5 SRCH base="cn=system,ou=Groups,o=bozpivot.com" scope=0
      filter="(objectclass=*)"
      conn=28 op=5 RESULT err=0 tag=101 nentries=1 etime=0
      conn=28 op=-1 fd=704 closed - A1

      I am assuming that is correct. But the weblogic server does not like this
      reply. WLS says

      Unable to initialize server: java.lang.NullPointerException fatal
      initialization exception java.lang.NullPointerException at
      weblogic.security.ldaprealm.LDAPDelegate.magicBunny(LDAPDelegate.java:292)

      My ldaprealm.properties is as follows :
      weblogic.security.ldaprealm.url=ldap://127.0.0.1:389
      weblogic.security.ldaprealm.principal=uid=admin, ou=Administrators,
      ou=TopologyManagement, o=NetscapeRoot
      weblogic.security.ldaprealm.credential=mypassword
      weblogic.security.ldaprealm.ssl=false
      weblogic.security.ldaprealm.authentication=simple
      weblogic.security.ldaprealm.userAuthentication=local
      #
      # User Schema
      weblogic.security.ldaprealm.userDN=o=bizpivot.com,ou=People
      weblogic.security.ldaprealm.userNameAttribute=uid
      weblogic.security.ldaprealm.userPasswordAttribute=userpassword

      # Group Schema
      weblogic.security.ldaprealm.groupDN=o=bizpivot.com,ou=Groups
      weblogic.security.ldaprealm.groupNameAttribute=cn
      weblogic.security.ldaprealm.groupUsernameAttribute=uniquemember

      Can some one help me ?

      Thank you in advance.

      Ramesh




        • 1. Re: Problems Connecting to LDAP (NDS) from WLS 5.1
          3004
          Hi Ramesh,

          Check the LDAPConfiguration at
          http://www.weblogic.com/docs51/admindocs/ldap2.html#properties for
          WLS51SP7 & higher. (Should solve your problem).

          -- Sunny


          "ramesh" <brameshraju@hotmail.com> wrote in message
          news:3b3344a0@newsgroups.bea.com...
          Hi,

          I am WLS 5.1 with sp8 and trying to connect to NDS LDAP Server 4.12. I
          checked the LDAP log file which says :

          conn=28 fd=704 slot=704 connection from 127.0.0.1 to 127.0.0.1
          conn=28 op=0 BIND
          dn="uid=admin,ou=Administrators,ou=TopologyManagement,o=NetscapeRoot"
          method=128 version=3
          conn=28 op=0 RESULT err=0 tag=97 nentries=0 etime=0
          conn=28 op=1 SRCH base="o=bozpivot.com" scope=0 filter="(objectclass=*)"
          conn=28 op=1 RESULT err=0 tag=101 nentries=1 etime=0
          conn=28 op=3 SRCH base="ou=Groups,o=bozpivot.com" scope=0
          filter="(objectclass=*)"
          conn=28 op=3 RESULT err=0 tag=101 nentries=1 etime=0
          conn=28 op=5 SRCH base="cn=system,ou=Groups,o=bozpivot.com" scope=0
          filter="(objectclass=*)"
          conn=28 op=5 RESULT err=0 tag=101 nentries=1 etime=0
          conn=28 op=-1 fd=704 closed - A1

          I am assuming that is correct. But the weblogic server does not like this
          reply. WLS says

          Unable to initialize server: java.lang.NullPointerException fatal
          initialization exception java.lang.NullPointerException at
          weblogic.security.ldaprealm.LDAPDelegate.magicBunny(LDAPDelegate.java:292)

          My ldaprealm.properties is as follows :
          weblogic.security.ldaprealm.url=ldap://127.0.0.1:389
          weblogic.security.ldaprealm.principal=uid=admin, ou=Administrators,
          ou=TopologyManagement, o=NetscapeRoot
          weblogic.security.ldaprealm.credential=mypassword
          weblogic.security.ldaprealm.ssl=false
          weblogic.security.ldaprealm.authentication=simple
          weblogic.security.ldaprealm.userAuthentication=local
          #
          # User Schema
          weblogic.security.ldaprealm.userDN=o=bizpivot.com,ou=People
          weblogic.security.ldaprealm.userNameAttribute=uid
          weblogic.security.ldaprealm.userPasswordAttribute=userpassword

          # Group Schema
          weblogic.security.ldaprealm.groupDN=o=bizpivot.com,ou=Groups
          weblogic.security.ldaprealm.groupNameAttribute=cn
          weblogic.security.ldaprealm.groupUsernameAttribute=uniquemember

          Can some one help me ?

          Thank you in advance.

          Ramesh