0 Replies Latest reply on Mar 11, 2004 6:46 PM by 3004

    Problems deploying WS .ear on WLW 8.1SP2

    3004

      Hi,

      I have a problem with deploying an .ear file containing a simple web services
      to my newly setup test domain.
      I have deployed the same.ear to two other BEA WLW servers without problem. The
      only difference between the servers I have deployed to before and this new one
      is that the others were installed with the complete Workshop and not just the
      runtime.
      The exception I get is included below and what seems so strange to me is that
      it is such a major component it fails on sp it seems to be some major classpath
      problems going on.
      I would appreciate any help or suggestions anyone can give regarding this.

      Thanks!
      /Marianne

      ####<Mar 11, 2004 7:13:21 PM MET> <Error> <Deployer> <xxxxx> <xxxxx> <ExecuteThread:
      '2' for q
      ueue: 'weblogic.kernel.System'> <<WLS Kernel>> <> <BEA-149201> <Failed to complete
      the deployment task
      with ID 3 for the application GWSTestServices.
      java.lang.NoClassDefFoundError: com/bea/wlw/runtime/core/bean/SLSBContainerBean
      at java.lang.ClassLoader.defineClass0(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:502)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
      at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:476)
      at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:181)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      at weblogic.utils.classloaders.GenericClassLoader.loadClass(GenericClassLoader.java:223)
      at weblogic.ejb20.deployer.EJBModule.setupEJBToImplClassDependencies(EJBModule.java:1010)
      at weblogic.ejb20.deployer.EJBModule.prepare(EJBModule.java:460)
      at weblogic.j2ee.J2EEApplicationContainer.prepareModule(J2EEApplicationContainer.java:2962)
      at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1534)
      at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1188)
      at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1031)
      at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.prepareContainer(SlaveD
      eployer.java:2602)
      at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.ja
      va:2552)
      at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2474)
      at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:798)
      at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:507)
      at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:465)
      at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25)
      at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197)
      at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170)
      --------------- nested within: ------------------
      weblogic.management.ManagementException: - with nested exception:
      [java.lang.NoClassDefFoundError: com/bea/wlw/runtime/core/bean/SLSBContainerBean]
      at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2491)
      at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:798)
      at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:507)
      at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:465)
      at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25)
      at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197)
      at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170)
      >