2 Replies Latest reply on Jul 19, 2002 5:00 PM by 3004

    Errors When start Workshop

    3004

      OS: Windows2000 Server(Chinese Big5 Edition) and Windows XP Professional
      Running Platform: Weblogic Platform 7.01 version.
      Problem : Workshop start exception.
      Desc:
      I can run workshop example server correctly. and can normaly admin the example
      server.
      But Whenever I open the workshop , the Example Server Console

      Show Error:

      View the Wl-Domain.log file, then show below:

      ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice> <Security>
      <kenming> <cgServer> <main> <kernel identity> <> <090093> <No configuration data
      was found on server cgServer for realm CompatibilityRealm.>
      ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice> <Security>
      <kenming> <cgServer> <main> <kernel identity> <> <090082> <Security initializing
      using realm CompatibilityRealm.>
      ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <main> <kernel identity> <> <000327> <Starting WebLogic Admin
      Server "cgServer" for domain "workshop">
      ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;19&#31186;> <Notice> <AI> <kenming>
      <cgServer> <main> <kernel identity> <> <000000> <Started WebLogic Integration
      - AI Server version 7.0>
      ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;49&#31186;> <Notice> <Management>
      <kenming> <cgServer> <main> <kernel identity> <> <141052> <Application Poller
      started for development server.>
      ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;52&#31186;> <Notice> <Security>
      <kenming> <cgServer> <main> <kernel identity> <> <090092> <SSL will load trusted
      CAs from the JDK cacerts KeyStore: C:\bea\jdk131_03\jre\lib\security\cacerts for
      realm CompatibilityRealm on server cgServer.>
      ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <SSLListenThread.Default> <kernel identity> <> <000354> <Thread
      "ListenThread.Default" listening on port 7001>
      ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <ListenThread.Default> <kernel identity> <> <000354> <Thread
      "ListenThread.Default" listening on port 7001>
      ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <main> <kernel identity> <> <000365> <Server state changed
      to RUNNING>
      ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <main> <kernel identity> <> <000360> <Server started in RUNNING
      mode>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;17&#31186;> <Notice> <Security>
      <kenming> <cgServer> <main> <kernel identity> <> <090093> <No configuration data
      was found on server cgServer for realm CompatibilityRealm.>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;17&#31186;> <Notice> <Security>
      <kenming> <cgServer> <main> <kernel identity> <> <090082> <Security initializing
      using realm CompatibilityRealm.>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;18&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <main> <kernel identity> <> <000327> <Starting WebLogic Admin
      Server "cgServer" for domain "workshop">
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;50&#31186;> <Notice> <AI> <kenming>
      <cgServer> <main> <kernel identity> <> <000000> <Started WebLogic Integration
      - AI Server version 7.0>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;52&#31186;> <Notice> <Management>
      <kenming> <cgServer> <main> <kernel identity> <> <141052> <Application Poller
      started for development server.>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;55&#31186;> <Notice> <Security>
      <kenming> <cgServer> <main> <kernel identity> <> <090092> <SSL will load trusted
      CAs from the JDK cacerts KeyStore: C:\bea\jdk131_03\jre\lib\security\cacerts for
      realm CompatibilityRealm on server cgServer.>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <SSLListenThread.Default> <kernel identity> <> <000354> <Thread
      "SSLListenThread.Default" listening on port 7002>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <ListenThread.Default> <kernel identity> <> <000354> <Thread
      "ListenThread.Default" listening on port 7001>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Error> <HTTP>
      <kenming> <cgServer> <ExecuteThread: '11' for queue: 'default'> <kernel identity>
      <> <101018> <[ServletContext(id=2181573,name=samples,context-path=/samples)] Servlet
      failed with ServletException>
      javax.servlet.UnavailableException: ServletContext(id=2181573,name=samples,context-path=/samples):
      The server cgServer is temporarilly suspended
      at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3034)
      at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2468)
      at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
      at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <main> <kernel identity> <> <000365> <Server state changed
      to RUNNING>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
      <kenming> <cgServer> <main> <kernel identity> <> <000360> <Server started in RUNNING
      mode>
      ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;57&#31186;> <Error> <HTTP>
      <kenming> <cgServer> <ExecuteThread: '14' for queue: 'default'> <kernel identity>
      <> <101083> <Connection failure>
      java.net.SocketException: ReadFile failed: &#25351;&#23450;&#30340;&#32178;&#36335;&#21517;&#31281;&#28961;&#27861;&#20351;&#29992;&#12290;
      (error 64, fd 2692)
      at weblogic.socket.NTSocketMuxer.initiateIO(Native Method)
      at weblogic.socket.NTSocketMuxer.read(NTSocketMuxer.java:461)
      at weblogic.servlet.internal.MuxableSocketHTTP.requeue(MuxableSocketHTTP.java:292)
      at weblogic.servlet.internal.ServletResponseImpl.send(ServletResponseImpl.java:1145)
      at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2473)
      at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
      at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)


      I had checked the /%USERPROFILE%/.Workshop and c:\bea\weblogic700\Workshop.properties,
      Them all are the right format!

      What's the error? How do I solve It?

      Regards.
      Kenming.

        • 1. Re: Errors When start Workshop
          3004
          This seems like a harmless error.

          Kenming Wang wrote:
          OS: Windows2000 Server(Chinese Big5 Edition) and Windows XP Professional
          Running Platform: Weblogic Platform 7.01 version.
          Problem : Workshop start exception.
          Desc:
          I can run workshop example server correctly. and can normaly admin the example
          server.
          But Whenever I open the workshop , the Example Server Console

          Show Error:

          View the Wl-Domain.log file, then show below:

          ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice> <Security>
          <kenming> <cgServer> <main> <kernel identity> <> <090093> <No configuration data
          was found on server cgServer for realm CompatibilityRealm.>
          ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice> <Security>
          <kenming> <cgServer> <main> <kernel identity> <> <090082> <Security initializing
          using realm CompatibilityRealm.>
          ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <main> <kernel identity> <> <000327> <Starting WebLogic Admin
          Server "cgServer" for domain "workshop">
          ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;19&#31186;> <Notice> <AI> <kenming>
          <cgServer> <main> <kernel identity> <> <000000> <Started WebLogic Integration
          - AI Server version 7.0>
          ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;49&#31186;> <Notice> <Management>
          <kenming> <cgServer> <main> <kernel identity> <> <141052> <Application Poller
          started for development server.>
          ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;52&#31186;> <Notice> <Security>
          <kenming> <cgServer> <main> <kernel identity> <> <090092> <SSL will load trusted
          CAs from the JDK cacerts KeyStore: C:\bea\jdk131_03\jre\lib\security\cacerts for
          realm CompatibilityRealm on server cgServer.>
          ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <SSLListenThread.Default> <kernel identity> <> <000354> <Thread
          "ListenThread.Default" listening on port 7001>
          ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <ListenThread.Default> <kernel identity> <> <000354> <Thread
          "ListenThread.Default" listening on port 7001>
          ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <main> <kernel identity> <> <000365> <Server state changed
          to RUNNING>
          ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <main> <kernel identity> <> <000360> <Server started in RUNNING
          mode>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;17&#31186;> <Notice> <Security>
          <kenming> <cgServer> <main> <kernel identity> <> <090093> <No configuration data
          was found on server cgServer for realm CompatibilityRealm.>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;17&#31186;> <Notice> <Security>
          <kenming> <cgServer> <main> <kernel identity> <> <090082> <Security initializing
          using realm CompatibilityRealm.>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;18&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <main> <kernel identity> <> <000327> <Starting WebLogic Admin
          Server "cgServer" for domain "workshop">
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;50&#31186;> <Notice> <AI> <kenming>
          <cgServer> <main> <kernel identity> <> <000000> <Started WebLogic Integration
          - AI Server version 7.0>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;52&#31186;> <Notice> <Management>
          <kenming> <cgServer> <main> <kernel identity> <> <141052> <Application Poller
          started for development server.>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;55&#31186;> <Notice> <Security>
          <kenming> <cgServer> <main> <kernel identity> <> <090092> <SSL will load trusted
          CAs from the JDK cacerts KeyStore: C:\bea\jdk131_03\jre\lib\security\cacerts for
          realm CompatibilityRealm on server cgServer.>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <SSLListenThread.Default> <kernel identity> <> <000354> <Thread
          "SSLListenThread.Default" listening on port 7002>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <ListenThread.Default> <kernel identity> <> <000354> <Thread
          "ListenThread.Default" listening on port 7001>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Error> <HTTP>
          <kenming> <cgServer> <ExecuteThread: '11' for queue: 'default'> <kernel identity>
          <> <101018> <[ServletContext(id=2181573,name=samples,context-path=/samples)] Servlet
          failed with ServletException>
          javax.servlet.UnavailableException: ServletContext(id=2181573,name=samples,context-path=/samples):
          The server cgServer is temporarilly suspended
          at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3034)
          at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2468)
          at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
          at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <main> <kernel identity> <> <000365> <Server state changed
          to RUNNING>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice> <WebLogicServer>
          <kenming> <cgServer> <main> <kernel identity> <> <000360> <Server started in RUNNING
          mode>
          ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;57&#31186;> <Error> <HTTP>
          <kenming> <cgServer> <ExecuteThread: '14' for queue: 'default'> <kernel identity>
          <> <101083> <Connection failure>
          java.net.SocketException: ReadFile failed: &#25351;&#23450;&#30340;&#32178;&#36335;&#21517;&#31281;&#28961;&#27861;&#20351;&#29992;&#12290;
          (error 64, fd 2692)
          at weblogic.socket.NTSocketMuxer.initiateIO(Native Method)
          at weblogic.socket.NTSocketMuxer.read(NTSocketMuxer.java:461)
          at weblogic.servlet.internal.MuxableSocketHTTP.requeue(MuxableSocketHTTP.java:292)
          at weblogic.servlet.internal.ServletResponseImpl.send(ServletResponseImpl.java:1145)
          at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2473)
          at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
          at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)


          I had checked the /%USERPROFILE%/.Workshop and c:\bea\weblogic700\Workshop.properties,
          Them all are the right format!

          What's the error? How do I solve It?

          Regards.
          Kenming.
          --
          Rajesh Mirchandani
          Developer Relations Engineer
          BEA Support


          • 2. Re: Errors When start Workshop
            3004
            Kenming,

            Can you start the server from the workshop IDE and let me know if you notice
            the same exceptions.

            Have you been seeing this exception everytime you start the server ? or have
            there been times when the exception was not generated ?

            Did you have any other version of Workshop installed prior to the GA version
            ?

            Thanks

            Raj Alagumalai
            WebLogic Workshop Support


            "Kenming Wang" <kenming@gcn.net.tw> wrote in message
            news:3d37b998@newsgroups.bea.com...
            >
            OS: Windows2000 Server(Chinese Big5 Edition) and Windows XP Professional
            Running Platform: Weblogic Platform 7.01 version.
            Problem : Workshop start exception.
            Desc:
            I can run workshop example server correctly. and can normaly admin the
            example
            server.
            But Whenever I open the workshop , the Example Server Console

            Show Error:

            View the Wl-Domain.log file, then show below:

            ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice>
            <Security>
            <kenming> <cgServer> <main> <kernel identity> <> <090093> <No
            configuration data
            was found on server cgServer for realm CompatibilityRealm.>
            ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice>
            <Security>
            <kenming> <cgServer> <main> <kernel identity> <> <090082> <Security
            initializing
            using realm CompatibilityRealm.>
            ####<2002/7/18 &#19979;&#21320;05&#26178;00&#20998;49&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <main> <kernel identity> <> <000327> <Starting
            WebLogic Admin
            Server "cgServer" for domain "workshop">
            ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;19&#31186;> <Notice>
            <AI> <kenming>
            <cgServer> <main> <kernel identity> <> <000000> <Started WebLogic
            Integration
            - AI Server version 7.0>
            ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;49&#31186;> <Notice>
            <Management>
            <kenming> <cgServer> <main> <kernel identity> <> <141052> <Application
            Poller
            started for development server.>
            ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;52&#31186;> <Notice>
            <Security>
            <kenming> <cgServer> <main> <kernel identity> <> <090092> <SSL will load
            trusted
            CAs from the JDK cacerts KeyStore:
            C:\bea\jdk131_03\jre\lib\security\cacerts for
            realm CompatibilityRealm on server cgServer.>
            ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <SSLListenThread.Default> <kernel identity> <>
            <000354> <Thread
            "ListenThread.Default" listening on port 7001>
            ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <ListenThread.Default> <kernel identity> <> <000354>
            <Thread
            "ListenThread.Default" listening on port 7001>
            ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <main> <kernel identity> <> <000365> <Server state
            changed
            to RUNNING>
            ####<2002/7/18 &#19979;&#21320;05&#26178;01&#20998;53&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <main> <kernel identity> <> <000360> <Server started
            in RUNNING
            mode>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;17&#31186;> <Notice>
            <Security>
            <kenming> <cgServer> <main> <kernel identity> <> <090093> <No
            configuration data
            was found on server cgServer for realm CompatibilityRealm.>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;17&#31186;> <Notice>
            <Security>
            <kenming> <cgServer> <main> <kernel identity> <> <090082> <Security
            initializing
            using realm CompatibilityRealm.>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;18&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <main> <kernel identity> <> <000327> <Starting
            WebLogic Admin
            Server "cgServer" for domain "workshop">
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;50&#31186;> <Notice>
            <AI> <kenming>
            <cgServer> <main> <kernel identity> <> <000000> <Started WebLogic
            Integration
            - AI Server version 7.0>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;52&#31186;> <Notice>
            <Management>
            <kenming> <cgServer> <main> <kernel identity> <> <141052> <Application
            Poller
            started for development server.>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;55&#31186;> <Notice>
            <Security>
            <kenming> <cgServer> <main> <kernel identity> <> <090092> <SSL will load
            trusted
            CAs from the JDK cacerts KeyStore:
            C:\bea\jdk131_03\jre\lib\security\cacerts for
            realm CompatibilityRealm on server cgServer.>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <SSLListenThread.Default> <kernel identity> <>
            <000354> <Thread
            "SSLListenThread.Default" listening on port 7002>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <ListenThread.Default> <kernel identity> <> <000354>
            <Thread
            "ListenThread.Default" listening on port 7001>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Error>
            <HTTP>
            <kenming> <cgServer> <ExecuteThread: '11' for queue: 'default'> <kernel
            identity>
            <> <101018>
            <[ServletContext(id=2181573,name=samples,context-path=/samples)] Servlet
            failed with ServletException>
            javax.servlet.UnavailableException:
            ServletContext(id=2181573,name=samples,context-path=/samples):
            The server cgServer is temporarilly suspended
            at
            weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletCo
            ntext.java:3034)
            at
            weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java
            :2468)
            at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
            at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <main> <kernel identity> <> <000365> <Server state
            changed
            to RUNNING>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;56&#31186;> <Notice>
            <WebLogicServer>
            <kenming> <cgServer> <main> <kernel identity> <> <000360> <Server started
            in RUNNING
            mode>
            ####<2002/7/18 &#19979;&#21320;06&#26178;01&#20998;57&#31186;> <Error>
            <HTTP>
            <kenming> <cgServer> <ExecuteThread: '14' for queue: 'default'> <kernel
            identity>
            <> <101083> <Connection failure>
            java.net.SocketException: ReadFile failed:
            &#25351;&#23450;&#30340;&#32178;&#36335;&#21517;&#31281;&#28961;&#27861;&#20
            351;&#29992;&#12290;
            (error 64, fd 2692)
            at weblogic.socket.NTSocketMuxer.initiateIO(Native Method)
            at weblogic.socket.NTSocketMuxer.read(NTSocketMuxer.java:461)
            at
            weblogic.servlet.internal.MuxableSocketHTTP.requeue(MuxableSocketHTTP.java:2
            92)
            at
            weblogic.servlet.internal.ServletResponseImpl.send(ServletResponseImpl.java:
            1145)
            at
            weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java
            :2473)
            at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
            at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)


            I had checked the /%USERPROFILE%/.Workshop and
            c:\bea\weblogic700\Workshop.properties,
            Them all are the right format!

            What's the error? How do I solve It?

            Regards.
            Kenming.