4 Replies Latest reply on Mar 22, 2005 5:18 AM by 3004

    Problem extracting FreeJSP 371

    3004
      When I attempt to install FullNitroXFreeInstall-371.exe, InstallAnywhere appears to "unstuff" the contents and then ask me to "Please select another location to extract the installer to". I do that (different hard drive), it extracts, and then gives me the same message, on and on like that. When I finally give up and cancel, nothing has been created.

      What's up? I hesitate to download another copy due to its size, but if this is corrupt behavior, I will.

      Regards,
      Mike
        • 1. Problem extracting FreeJSP 371
          3004
          Please check the Properties on downloaded file to compare with actual size

          FullNitroXFreeInstall-371.exe - 78.9 MB (82,747,392 bytes)

          If this is correct, then check the Task Manager for FullNitroXFreeInstall-371.exe - Kill the related process and retry.

          It might be that you double clicked the installer twice at a quick session and one of them did not launch and the other one is trying to extract using same temp folder.
          • 2. Used 372 but still had problems
            3004
            I decided to go ahead and get a fresh copy. This time it was version 372. This installed OK as part of Eclipse. However, upon launching Eclipse (3.0.1) I got a configuration error (see below). I then uninstalled 372 and afterwards continued to get configuration errors upon launching eclipse. I removed various files (one at a time) from /configuration/org.eclipse.update and finally got eclipse to run again without errors. I believe your uninstaller has some problems.


            Here is the text from the first error log file:
            ------start log file
            !SESSION Mar 19, 2005 09:27:29.828 ---------------------------------------------
            eclipse.buildId=I200406251208
            java.version=1.4.2_04
            java.vendor=Sun Microsystems Inc.
            BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

            !ENTRY org.eclipse.update.configurator Mar 19, 2005 09:27:29.828
            !MESSAGE Could not uninstall unused bundle update@/c:/eclipse/plugins/org.eclipse.gef_3.0.0/

            !ENTRY org.eclipse.core.runtime Mar 19, 2005 09:27:35.46
            !MESSAGE Product org.eclipse.platform.ide could not be found.

            !ENTRY org.eclipse.osgi Mar 19, 2005 09:27:35.62
            !MESSAGE Application error
            !STACK 1
            java.lang.RuntimeException: No application id has been found.
                 at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:313)
                 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:273)
                 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:129)
                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                 at java.lang.reflect.Method.invoke(Method.java:324)
                 at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
                 at org.eclipse.core.launcher.Main.run(Main.java:644)
                 at org.eclipse.core.launcher.Main.eclipse_main(Main.java:628)
                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                 at java.lang.reflect.Method.invoke(Method.java:324)
                 at com.m7.installer.util.NitroxMain$1.run(NitroxMain.java:28)
                 at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:171)
                 at java.awt.EventQueue.dispatchEvent(EventQueue.java:454)
                 at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
                 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
                 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
                 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
                 at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

            !ENTRY org.eclipse.osgi Mar 19, 2005 09:27:35.62
            !MESSAGE Bundle update@/c:/eclipse/plugins/org.eclipse.gef_3.0.0/ [47] was not resolved.

            !ENTRY org.eclipse.osgi Mar 19, 2005 09:27:35.62
            !MESSAGE Bundle update@/C:/NitroX_2.0_371/NitroX/eclipse/plugins/com.m7.nitrox.eclipse3.0_2.0.0/ [414] was not resolved.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.62
            !MESSAGE Missing required bundle org.eclipse.core.runtime.compatibility_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.62
            !MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.62
            !MESSAGE Missing required bundle org.eclipse.ui.views_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.62
            !MESSAGE Missing required bundle org.eclipse.jface.text_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.ui.editors_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.core.resources_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.jdt.ui_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.debug.core_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.debug.ui_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.search_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.jdt.debug_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.jdt.debug.ui_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.help_0.0.0.
            !SUBENTRY 1 org.eclipse.osgi Mar 19, 2005 09:27:35.78
            !MESSAGE Missing required bundle org.eclipse.ui.forms_0.0.0.
            • 3. Problem extracting FreeJSP 371
              3004
              Where did you get build 372? Guess you are confused our latest build is NitroX 2.0 final release 371.

              Try to install FullNitroXFreeInstall-371.exe selecting standalone eclipse and see whether you hit upon the same issue.
              • 4. 372
                3004
                When I downloaded a new version, it was named FullNitroXFreeInstall-372.exe. Perhaps the OS named it that way since FullNitroXFreeInstall-371.exe was already in the folder.

                I'll give your suggestion a shot and let you know.