6 Replies Latest reply on Apr 18, 2008 7:24 PM by 666705

    Active Directory Auth source job Failing

    666705
      Hi Team,

      We are trying to synch with Active directory, but running into following problem.

      But the Auth server is running fine and We changed the web.config to skip if problems with Getgroups option.

      Any thing we are missing?

      Sync Agent is processing groups.
      Dec 14, 2006 12:55:07 PM- PTAuthSourceAgent::ProcessGroups: Call to retrieve the groups on this auth source failed. Please check that the authentication source server is online.
      *** Exception: com.plumtree.server.impl.soap.OpenSoapException: Error in function AWSProvider.GetGroups (): Error in function SOAPEnvelope.Restore (arrayText == [B@159780d): SOAP fault: faultcode='soap:Server' faultstring='Server was unable to process request. --> A referral was returned from the server error performing search: GetGroupsInternal Error in GetGroups'
      at com.plumtree.openfoundation.util.XPException.GetInstance(XPException.java:371)
      at com.plumtree.server.impl.users.providers.AWSProvider.GetGroups(AWSProvider.java:554)
      at com.plumtree.automationserver.agents.PTAuthSourceAgent.ProcessGroups(PTAuthSourceAgent.java:857)
      at com.plumtree.automationserver.agents.PTAuthSourceAgent.PerformOperation(PTAuthSourceAgent.java:266)
      at com.plumtree.automationserver.shell.PTJobShell.perform(PTJobShell.java:599)
      at com.plumtree.automationserver.shell.PTJobShell.runJob(PTJobShell.java:199)
      at com.plumtree.automationserver.shell.PTJobShell.run(PTJobShell.java:89)
      Caused by: com.plumtree.server.impl.soap.OpenSoapException: Error in function SOAPEnvelope.Restore (arrayText == [B@159780d): SOAP fault: faultcode='soap:Server' faultstr

      Thanks,

      Ram                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
        • 1. Re: Active Directory Auth source job Failing
          666705
          Hi ,
          I'm having the same issue, did you solve it? any solution?

          Bharat
          • 2. Re: Active Directory Auth source job Failing
            666705
            Same here, anyone get this fixed?
            • 3. Re: Active Directory Auth source job Failing
              666705
              I've got the same problem, any help?
              • 4. Re: Active Directory Auth source job Failing
                666705
                Open PTSpy and look a few lines up when the error actually hits, here's what mine said:<br><br>
                <i>There is no such object on the server error performing search: GetGroupsInternal Error in GetGroups</i><br><br>
                Hmmm...here's the whole PTSpy line:<br><br>
                SOAP call failed, an internal error occured on the remote server. Attempting to parse the SOAP fault for detailed error info. Web Service='Active Directory', SOAP Action='urn:plumtree-com:AWService.GetGroups', URL='http://EWPAD01/adaws/SyncProviderSoapBinding.asmx' : <?xml version="1.0" encoding="utf-8"?>
                <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
                <soap:Body>
                <soap:Fault>
                <faultcode>soap:Server</faultcode>
                <faultstring>System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Plumtree.Remote.ServiceException: There is no such object on the server error performing search: GetGroupsInternal Error in GetGroups
                at com.plumtree.remote.auth.xp.XPSyncProvider.LogAndRethrow(IOKLogger logger, String functionName, Exception e) in e:\latestbuild\Release\devkit\6.0.x\auth\src\xpj2c\impl\com\plumtree\remote\auth\xp\XPSyncProvider.cs:line 786
                at com.plumtree.remote.auth.xp.XPSyncProvider.GetGroups() in e:\latestbuild\Release\devkit\6.0.x\auth\src\xpj2c\impl\com\plumtree\remote\auth\xp\XPSyncProvider.cs:line 192
                at Plumtree.Remote.Auth.Soap.SyncProviderSoapBinding.GetGroups() in e:\latestbuild\Release\devkit\6.0.x\auth\src\dotnet\soap\SyncProviderSoapBinding.asmx.cs:line 168
                --- End of inner exception stack trace ---</faultstring>
                <detail />
                </soap:Fault>
                </soap:Body>
                </soap:Envelope>
                <br><br>
                No answer for you guys yet, will investigate further.
                • 5. Re: Active Directory Auth source job Failing
                  666705
                  Got it. On your remote authentication source object, go into step 3 (left nav link called 'Synchronization'), now look at the very bottom of the right pane, check the box labeled:<br>
                  <i>Import user and group memberships from other authentication sources.</i><br>
                  By default, it is not.<br>
                  Do this at least on the first job run, whether to continue is up to your needs.<br>
                  I watched the spy as it worked and then of course viewed the job log when complete. Worked fine.
                  • 6. Re: Active Directory Auth source job Failing
                    666705
                    Nevermind that post - not exactly right.<br>
                    Just get your query's right on step 2 of the wizard.<br>
                    Leave the default User (and Group) Query Filter values, those work fine. But make sure you have the User Query Base and Group Query Base values exactly right and that they'll return something.<br><br>
                    If you're new to AD queries and how to construct this line, download the freeware LDAP utility at the bottom of this page:<br>http://www.ldapadministrator.com/download.htm<br>It's like query analyzer for Active Directory. Don't know how I even got this far w/o it.