5 Replies Latest reply on Feb 2, 2004 7:05 PM by 3004

    email generator Not working..?

    3004
      I downloaded the Email Generator zip file from your website. However it does not seem to be working, I am getting an error that says server was not able to retrieve the contents of this gadget due to an error with gadget content server. Any ideas???

        • 1. re: email generator Not working..?
          3004
          what happens when you hit the URL directly (not through the portal)?

          • 2. re: email generator Not working..?
            3004
            Here is the error:
            Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.Source Error:
            Line 71:           "Passport" and "None"
            Line 72:         -->
            Line 73:         <authentication mode="Windows" />
            Line 74:         <!--  APPLICATION-LEVEL TRACE LOGGING
            Line 75:           Application-level tracing enables trace log output for every page within an application.
            • 3. re: email generator Not working..?
              3004
              You have not configured this as a web application in IIS. You must go to IIS administration, find the virtual directory you have set up, right-click & choose properties, then click 'Create' to create a new web application; just using a virtual directory is not sufficient for .NET applications.

              • 4. re: email generator Not working..?
                3004
                Here is the error that i get after making this an Application in IIS
                Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.IO.FileNotFoundException: File or assembly name System, or one of its dependencies, was not found.Source Error:
                Line 30:         private static bool __intialized = false;
                Line 31:
                Line 32:         public Global_asax() {
                Line 33:             if ((ASP.Global_asax.__intialized == false)) {
                Line 34:                 ASP.Global_asax.__intialized = true;
                Source File: C:\WINNT\Microsoft.NET\Framework\v1.0.3705\Temporary ASP.NET Files\gsdev_portlets_src\0d73b11c\a8a117a7\rgtqy0qb.0.cs[b] Line: 32 Assembly Load Trace:The following information can be helpful to determine why the assembly 'System' could not be loaded.
                === Pre-bind state information ===
                LOG: DisplayName = System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
                (Fully-specified)
                LOG: Appbase = file:///C:/GSDEV/Portlets/src
                LOG: Initial PrivatePath = bin
                Calling assembly : LetterGenerator, Version=1.0.1418.21666, Culture=neutral, PublicKeyToken=null.
                ===

                LOG: Publisher policy file is not found.
                LOG: No redirect found in host configuration file (C:\WINNT\Microsoft.NET\Framework\v1.0.3705\aspnet.config).
                LOG: Using machine configuration file from C:\WINNT\Microsoft.NET\Framework\v1.0.3705\config\machine.config.
                LOG: Post-policy reference: System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
                LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.0.3705/Temporary ASP.NET Files/gsdev_portlets_src/0d73b11c/a8a117a7/System.DLL.
                LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.0.3705/Temporary ASP.NET Files/gsdev_portlets_src/0d73b11c/a8a117a7/System/System.DLL.
                LOG: Attempting download of new URL file:///C:/GSDEV/Portlets/src/bin/System.DLL.
                LOG: Attempting download of new URL file:///C:/GSDEV/Portlets/src/bin/System/System.DLL.
                LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.0.3705/Temporary ASP.NET Files/gsdev_portlets_src/0d73b11c/a8a117a7/System.EXE.
                LOG: Attempting download of new URL file:///C:/WINNT/Microsoft.NET/Framework/v1.0.3705/Temporary ASP.NET Files/gsdev_portlets_src/0d73b11c/a8a117a7/System/System.EXE.
                LOG: Attempting download of new URL file:///C:/GSDEV/Portlets/src/bin/System.EXE.
                LOG: Attempting download of new URL file:///C:/GSDEV/Portlets/src/bin/System/System.EXE.
                Stack Trace:
                [FileNotFoundException: File or assembly name System, or one of its dependencies, was not found.]
                   LetterGenerator.Global.InitializeComponent() +0
                   LetterGenerator.Global..ctor()
                   ASP.Global_asax..ctor() in C:\WINNT\Microsoft.NET\Framework\v1.0.3705\Temporary ASP.NET Files\gsdev_portlets_src\0d73b11c\a8a117a7\rgtqy0qb.0.cs:32

                [TargetInvocationException: Exception has been thrown by the target of an invocation.]
                   System.RuntimeType.CreateInstanceImpl(Boolean publicOnly) +0
                   System.Activator.CreateInstance(Type type, Boolean nonPublic) +66
                   System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +277
                   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +109
                   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance() +160
                   System.Web.HttpApplicationFactory.FireApplicationOnStart(HttpContext context) +20
                   System.Web.HttpApplicationFactory.Init(HttpContext context) +481
                   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +155
                   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +407
                • 5. re: email generator Not working..?
                  3004
                  The code you are trying to run is trying to find a .NET 1.1 assembly. It looks as though you only have 1.0 installed, so it is failing to find the assembly. I'd advise you install the .NET Framework 1.1.