1 Reply Latest reply on Nov 17, 2008 3:08 PM by alwu-Oracle

    Nothing Return via Jena Program???

    670644
      Hi Folks,

      I have followed the below procedures to retrieve the information via Jena. But nothing is returned. Would you please help me to solve it? The first three steps are successful, but nothing is returned when I execute any Jena's SPARQL functions to retrieve the data.

      Oracle Spatial Server
      1. CREATE TABLE wine_table (id NUMBER, triple SDO_RDF_TRIPLE_S);
      2. EXECUTE SEM_APIS.CREATE_SEM_MODEL('*wine*', *'wine_table*', 'triple');

      My Labtop
      3. java example.Examples ‐testModel jdbcUrl username password model_name wine.owl RDF/XML
      4. java example.Examples -testOrderBy jdbcUrl usename password wine

      Please help! It is highly appreciated!

      Kit
        • 1. Re: Nothing Return via Jena Program???
          alwu-Oracle
          Actually, step 1 and 2 you did are not relevant to step 3 because in step 3 you chose
          the name of the rdf (owl) model to be "model_name"

          You can skip step 1 and 2 because Jena Adaptor will create them on your behalf.
          The application table name will be automatically determined by Jena Adaptor if you are using
          the simple constructor.

          So I would suggest:
          1) drop the wine model and application table from SQLPLUS
          SQLPLUS> exec sem_apis.drop_sem_model('wine');
          SQLPLUS> drop table wine_table;

          2) java example.Examples ‐testModel jdbcUrl username password wine_graph wine.owl RDF/XML

          3) java example.Examples -testOrderBy jdbcUrl usename password wine_graph

          Cheers,

          Zhe Wu (aka Alan Wu)