3 Replies Latest reply on Dec 3, 2008 1:41 AM by 672682

    new to Oracle..need help

    672682
      hi..i very new to oracle..i just started yesterday...

      anyway..before this ive been storing triples with AllegroGraph Database and now i need to try out the Oracle 11g.

      first ive been search for what to install for me to use the semantic of it and im very very confuse. can someone advice me on any tutorial and what is the requirement / oracle software that i need to start saving the triple using the 11g.

      what is JENA for and also the spatial for..im very confuse what to install actually. ive only install the 11g database.

      from this link.. " http://www.oracle.com/technology/obe/11gr1_db/datamgmt/nci_semantic_network/nci_semantics_les01.htm#p"... im stuck at the 2nd step of "Prerequisites"... i cant register as i didn't subscribe to the " support Identifier" stuff..is there any other way i can do or any other tutorial that can help me to start with the semantic 11g.

      the bottom line is im very very new to oracle. before this i just know by the name when im in Uni.

      one more thing...any tutorial link on how to create table so on so forth...i really dont know where 2 start. im totally lost...

      really hope someone able to give me guidance..

      thanks in advance

      regards
      norazanita@yahoo.com
        • 1. Re: new to Oracle..need help
          alwu-Oracle
          Jena is a set of JAVA APIs and implementations from HP Lab. See the following links for details.
          http://jena.sourceforge.net/

          Jena Adaptor is from Oracle and this adaptor implements some of Jena's basic and important APIs
          including Graph, Model, BulkUpdateHandler, etc. Basically, Jena Adaptor allows users to use Oracle's
          semantic store (semantic data management provided inside RDBMS) through Jena's Java APIs.


          Assume you don't have a Metalink account, you can find the server side patch to 11.1.0.6 using
          the following link.
          http://www.oracle.com/technology/software/tech/semantic_technologies/files/jenadrv_patch111rdf.zip

          To install the above patch, please follow Section 2 of the following document.
          http://www.oracle.com/technology/tech/semantic_technologies/documentation/jenadrv_patch_ig.txt

          If you are not familiar with Oracle Database, please read the last section (Example: Step-by-step instructions (new Oracle Database 11g installation) in the above document.

          Hope it helps,

          Zhe Wu (a.k.a Alan Wu)
          • 2. Re: new to Oracle..need help
            JorgeB-Oracle
            Hi,

            I recommend to install 11.1.0.7.0 to have the latest patchset and to avoid the installation of the Jena patch which is included in 11.1.0.7.0

            The prerequisite note just indicates that you need to run this script:

            $ORACLE_HOME/md/admin/catsem11i.sql

            connected as sys as sysdba

            Oracle spatial has to be installed as Semantics uses some code from Oracle Spatial but the Spatial option is a separate feature of the Oracle Database.

            I will contact you via email to follow up.

            Regards!
            Jorge
            • 3. Re: new to Oracle..need help
              672682
              hi thanks for the link. i'll try out...

              thanks once again for the HELP!

              Go Oracle!