This discussion is archived
4 Replies Latest reply: Aug 6, 2013 2:41 AM by user7389810 RSS

WebLogic Portal (10.3.0) requires feature "com.m7.nitrox (1.0.20)" (?)

674574 Newbie
Currently Being Moderated
I just installed WebLogic Portal 10.3 and I'm trying to install a couple of plug ins to Workshop/Eclipse, but whenever I select any item to install I get this error:

WebLogic Portal (10.3.0) requires feature "com.m7.nitrox (1.0.20)", or compatible.

Everything else seems to be working fine, so I'm not sure why my installation is giving me this issue. I've done a bit of digging already and haven't found what may be causing this issue, and I'm hoping someone here may be able to point me in the right direction.

Thanks!

Above description is cloned from user10371842's post. I encountered the same issue. Does anyone have solutions? Thanks
  • 1. Re: WebLogic Portal (10.3.0) requires feature "com.m7.nitrox (1.0.20)" (?)
    648832 Explorer
    Currently Being Moderated
    This is a bug, CR379999. that will be fixed WLP 10.4. In the meantime, here's the workaround from the bug report:

    Download the plugin manually, and either 1) create an extension location on the file system from it and add that via Help|Software Updates|Manage Configuration, or 2) extract it to one of the workshop eclipse folders (i.e. tools/eclipse_pkgs/2.0/eclipse_3.3.2, tools/eclipse_pkgs/2.0/pkgs/eclipse, workshop_10.3/workshop4WP/eclipse, wlportal_10.3/eclipse).

    Additionally, you can comment out the com.* import lines in your %BEA_HOME%\wlportal_10.3\eclipse\features\com.bea.wlp_10.3.0\feature.xml, like this:

    <requires>
    <import plugin="org.eclipse.core.runtime" version="3.3" match="compatible"/>
    <import plugin="org.eclipse.ui" version="3.3" match="compatible"/>
    <!--
    <import feature="com.m7.nitrox" version="1.0.20" match="compatible"/>
    <import feature="com.bea.workshop.cmdline.feature" version="1.0.30" match="compatible"/>
    <import feature="com.bea.workshop.common.feature" version="1.1.40" match="compatible"/>
    <import feature="com.bea.workshop.upgrade81.feature" version="1.0.30" match="compatible"/>
    <import feature="com.bea.workshop.web.feature" version="1.0.20" match="compatible"/>
    <import feature="com.bea.workshop.wls.feature" version="1.1.30" match="compatible"/>
    <import feature="com.bea.workshop.xmlbeans.feature" version="1.0.30" match="compatible"/>
    -->
    </requires>

    Then restart Workshop. Sorry for the trouble.

    George
  • 2. Re: WebLogic Portal (10.3.0) requires feature "com.m7.nitrox (1.0.20)" (?)
    716576 Newbie
    Currently Being Moderated
    I cannot apply this workaround on Workshop10.3 without portal.
    Any other solution
    i am using Oracle Workshop from Enterpise Pack.

    thanks
    salman
  • 3. Re: WebLogic Portal (10.3.0) requires feature "com.m7.nitrox (1.0.20)" (?)
    734405 Newbie
    Currently Being Moderated
    Hi all,

    I have not found the plugin for manual installing, but I have commented the feature.xml like George saids, and then I tried to update again from workshop. Now works pretty fine!

    Thanks

    Fabián.
  • 4. Re: WebLogic Portal (10.3.0) requires feature "com.m7.nitrox (1.0.20)" (?)
    user7389810 Newbie
    Currently Being Moderated

    Yes, Fabian is right, its worked gr8. Thanks George. I don't know ABC of it . Your solution helped me. Thanks for all

     

    Regards

    Sathish Jaganathan

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points