11 Replies Latest reply: Sep 7, 2009 9:08 PM by Todd Little-Oracle RSS

    Can't access TSAM data server URL

      I deploy the TSAM program according "BEA TSAM Deployment Guide" document(http://edocs.bea.com/tsam/docs11/deployment/deploy.html#wp1058966), then start the TSAM manager, I can access the TSAM Console use URL "http://myhost:9090/tsam ". When I access the URL "http://myhost:9090/tsam/dataserver", the error page says "Sorry, requested resource is forbidden [HTTP Status 403]. "
        • 1. Re: Can't access TSAM data server URL
          Todd Little-Oracle
          The TSAM dataserver doesn't provide a user interface. It's sole purpose is to provide a service for the LMS processes on the monitored Tuxedo systems to send their data to TSAM Manager. The only user interface to TSAM is the TSAM console.

          Todd Little
          Oracle Tuxedo Chief Architect
          • 2. Re: Can't access TSAM data server URL
            Thanks, Todd!
            My question is related LMS actually, the LMS process starts failed when I boot tuxedo application system.

            Here is the error message when tuxedo booting:
            asirxing@intrepid:~/Projects/tuxedo$ tmboot -y
            exec simpserv -A :
                 on SITE2 -> process id=2951 ... Started.
            exec LMS -A -- -l :
                 on SITE1 -> CMDTUX_CAT:1685: ERROR: Application initialization failure
            29 processes started.

            Here is the ULOG message:
            131346.intrepid!LMS.2584.3081565872.0: 12-11-2008: Tuxedo Version 10.0, 32-bit
            131346.intrepid!LMS.2584.3081565872.0: LIBTUX_CAT:262: INFO: Standard main starting
            131346.intrepid!LMS.2584.3081565872.0: LIBTUX_CAT:6826: INFO: TSAM License Serial #: 454493271161-2664300133141, Expiration None
            131346.intrepid!LMS.2584.3081565872.0: LIBTUX_CAT:6827: INFO: TSAM Licensed to : Customer
            131346.intrepid!LMS.2584.3081565872.0: CMDTUX_CAT:6994: ERROR: The console address is not specified or invalid
            131346.intrepid!LMS.2584.3081565872.0: LIBTUX_CAT:250: ERROR: tpsvrinit() failed
            51,1 Bot
            Here is my ubb configuration:
            ### Add by AsirXing for TSAM ###
            ### Add by AsirXing for TSAM ###

            Here is the tsam.log:
            <2008-12-11 11:53:50,607> <INFO> <org.apache.myfaces.webapp.StartupServletContextListener> <ServletContext '/home/tuxedo/bea/tsam1.1/apache-tomcat-5.5.17/webapps/tsam/' initialized.>
            <2008-12-11 11:53:50,633> <INFO> <com.bea.tsam.server.RequestServer> <TSAM-0129: JDBC Driver: oracle.jdbc.driver.OracleDriver>
            <2008-12-11 11:53:50,633> <INFO> <com.bea.tsam.server.RequestServer> <TSAM-0130: JDBC URL: jdbc:oracle:thin:@>
            <2008-12-11 11:53:50,633> <INFO> <com.bea.tsam.server.RequestServer> <TSAM-0131: JDBC Username: tuxedo>
            <2008-12-11 11:53:51,192> <INFO> <com.bea.tsam.server.DataServer> <TSAM-0127: TSAM Data Server started>
            <2008-12-11 11:53:51,198> <INFO> <com.bea.tsam.chart.DataProviderServlet> <TSAM-0509: Cleanup BIRT temporary image files periodically>
            <2008-12-11 11:53:51,203> <INFO> <org.apache.myfaces.webapp.MyFacesServlet> <MyFacesServlet for context '/home/tuxedo/bea/tsam1.1/apache-tomcat-5.5.17/webapps/tsam/' initialized.>

            Any comments about it, Todd?
            Thanks again!
            • 3. Re: Can't access TSAM data server URL
              Hi AsirXing,

              You will need to remove the "http://" from the TSAM Data Server address (-l CLOPT option). I have been using the following server entry for LMS (on a Windows system) and have had no problems.

                        CLOPT="-A -- -l localhost:8080/tsam/dataserver"

              Hope this helps,

              Kind regards,
              • 4. Re: Can't access TSAM data server URL
                Hi Kind:

                Get it! It works fine now! Thanks!
                • 5. Re: Can't access TSAM data server URL
                  I have configured and deployd TSAM and also configured LMS on my Tuxedo server/app. i have been able to login to the TSAM console and have been able to verify all the servers/services/hostname/Machine/Groups were listed properly in the "service monitoring"/"server monitoring" menus etc. But however, when i choose/select a particular service for monitoring from the drop down Menu and click submit, i am getting the following message "No Monitoring Data". I am sure there were several calla made to the service and there should be some data available. I must be able to see the live monitoring chart. Its the same message 'No Monitoring Data" i get for all the other services i chose. Do you have any idea why the information is not being shown or collected?

                  Domain: tuxdom2:itejclstux02:112870, Service: ComplexOrder

                  TSAM-0510: INFO: No monitoring data
                  • 6. Re: Can't access TSAM data server URL
                    Todd Little-Oracle

                    A couple of possibilities:

                    1) You haven't enabled any monitoring policies. You can check if in fact Tuxedo is collecting data by checking the LMS server in tmadmin and see if it has processed any requests. If it has, go to the next note. If it hasn't, then you need to enable some monitoring policies by using the TSAM console.

                    2) Depending upon what you are trying to look at, it is possible that the monitoring timeframe chosen in the console is outside the range of when the requests took place.

                    Todd Little
                    Oracle Tuxedo Chief Architect
                    • 7. Re: Can't access TSAM data server URL
                      Thanks Todd, for the suggestions.
                      But however, I have tried both the suggestions. but no use. Is there anything in the configuration, that you think could be causing this. TSAM is able to display all the Tux Domain Configuration properly including master/slave machines, Groups, Servers with server IDs, and also services, which means it is able to talk to LMS, but is not able to collect monitoring Data for any of the same services shown in the configuration. Has any one come across a similar issue?
                      • 8. Re: Can't access TSAM data server URL
                        Todd Little-Oracle

                        Does the LMS show any work done? If yes, then the problem is reporting the data to the TSAM data server. If not, then the problem is in the monitoring configuration. If you use the environment variable route, do you see anything in the ULOG indicating that monitoring is occurring or that the environment variable couldn't be parsed?

                        Todd Little
                        Oracle Tuxedo Chief Architect
                        • 9. Re: Can't access TSAM data server URL

                          By default the monitoring will not happen until you set the correct monitoring policy. You can enable monitoring policy by,
                          1. environment variable TMMONITOR, such as
                          export TMMONITOR=app,svc:: (UNIX style), then restart your Tuxedo application

                          2. You can also use chmo command in tmadmin to enable a particular monitoring process, such as,
                          tmadmin>chmo -g APPGRP svc:: (Enable service monitoring for group APPGRP)

                          3. You can also use console monitoring policy

                          If tuxedo restarted, only 1# can keep the same monitoring settings 2# and 3# will not turn on automatically.

                          You will see "TMMONITOR parsed ..." message in ULOG if it take effect.

                          • 10. Re: Can't access TSAM data server URL
                            Thank you very much the above trick worked. An i am able to see the required Data. However when i do "Historical Data Query" for a particular service, i see the chart and the number of transaction detail etc, but the "Average Execution Time" and "Average Wait Time" shows 0. Any reason why? It should show the actual time taken isnt it. Please advise.

                            Time Interval Succeed Fail Average Execution Time Average Wait Time
                            ... 0 0 0.000 0.000
                            14:00 - 14:59 5 0 *0.000 0.000*

                            Total 5.0 0.0
                            • 11. Re: Can't access TSAM data server URL
                              Todd Little-Oracle

                              Just a guess, but could the services be completing in less than a millisecond? If you are certain this is not the case, then I would suggest opening up a support ticket with Oracle Customer Support.

                              Todd Little
                              Oracle Tuxedo Chief Architect