3 Replies Latest reply on Feb 19, 2009 8:16 PM by 667092

    Error configuring the OAS4OS Server with SSL mode


      I have OID and RedHat 4 UP5 in the server, and I'm trying to configure the server with
      SSL mode.

      I started the script to configure the server with SSL mode:

      [INFRA:~/infra/ldap/bin]$ ./sslConfig_OIDserver.sh

      OAS4OS: Release - Production
      Copyright (c) 2008 Oracle. All rights reserved.

      Configuring Linux Authentication on OID server side ...
      Please make sure that your OID server is currently up and running. Please also make sure that your OID server processes are brought up by opmnctl.

      Please specify the realm
      E.g. dc=us,dc=oracle,dc=com: dc=vm,dc=oracle,dc=com
      Please specify OID non-SSL port: 389
      Please enter OID cn=orcladmin password:
      Please enter the Password for your new Oracle wallet:
      opmnctl: restarting opmn managed processes...


      Note that the script asks for the non-SSL port, instead of the SSL port.
      Then, the script for SSL mode configure the script for the client with the non-SSL port:

      [INFRA:~/infra/ldap/bin]$ grep -i oidServerPort= sslConfig_OIDclient.sh

      After that, I copied the files again (the fresh files), and I run the script for SSL again,
      and when the script asked to me by the non-SSL portl I entered the SSL-port 636, but the
      script didn't finished to execute anymore.

      Then, appears to be a problem with this.

      Luis Vivero.
        • 1. Re: Error configuring the OAS4OS Server with SSL mode
          As the configuration for SSL uses TSL, I mean, the ldap operation uses TLS from the client side, then the ldap connection uses the non-SSL port under TLS.
          Then, when the configuration with SSL ask you by the non-SSL port, this is good.

          The configuration script for SSL can takes some seconds before release the command line, I just wait for some more seconds, and the configuration was executed without problems.
          • 2. Re: Error configuring the OAS4OS Server with SSL mode

            I am also working on the OAS4OS
            I ran into some issues similar to what you have described.
            Could you please let me know if you are successful in doing the OAS4OS?

            I am some what confused to which version of OID to be used as the OAS4OS package installabled downloaded file(ReadME.txt) says it needs OID version where as its Admin Guide says that it needs to be upgraded to OID

            But I have upgraded to and I have no idea whether this version does not require any config tools to migrate the users, to add the users etc., to OID.

            I would appreciate any help on this.

            Thanks in advance,
            • 3. Re: Error configuring the OAS4OS Server with SSL mode
              Hi Mahendra,

              I configured OAS4OS with OID sucessfully.
              And yes, you need OID

              As far as I know, the OAS4OS guide that we have until this moment is for OAS4OS, then, for that reason you saw that.
              But the fact, is that you have to upgrade OID to before install/reinstall OAS4OS

              Luis Vivero.