0 Replies Latest reply: Mar 19, 2009 5:56 PM by 675521 RSS

    backspace not working problem and a tip, Why?

    675521
      Hello there, I'm newbie this SQL Developer
      I have a problem situation in using backspace and found some trick to solve it.


      1. First Problem, download it and installed on JDK6 Up10. Then I knew that can't use backspace key on sql files.
      I read a lot of solving tips and also below two article are same answer of it. but It's not work on my situation.
      <ol><li>[Keypad issue - Backspace, delete, forward, back, up down keys not working|http://forums.oracle.com/click.jspa?searchID=-1&messageID=2834808]
           Posted on: 2008. 10. 23 오후 12:07, by user: user10409501
           --
           Relevance:
           100%
           --
      [Show all results within this thread|http://forums.oracle.com/search.jspa?q=backspace&objID=f260&dateRange=last90days&forumID=260&rankBy=10001&threadID=721838]

      </li>
      <li>[Re: [1.1.2.25.79] Backspace key still doesn't work in SQL Worksheet|http://forums.oracle.com/click.jspa?searchID=-1&messageID=2807403]
           Posted on: 2008. 10. 9 오전 7:48, by user: user824041
           --
           Relevance:
           90%
           --
      [Show all results within this thread|http://forums.oracle.com/search.jspa?q=backspace&objID=f260&dateRange=last90days&forumID=260&rankBy=10001&threadID=482496]</li>
      </ol>

      1) My sqldeveloper encironment were
      - jdk1.6.0_10 - sqldeveloper 1.5.1
      - OS is Win XP sp3, korean.
      2) I used upper two solving issue and it was not working on me.

      2. second, I used another jdk and backspace not working problem is disapeared.
      1) sqldeveloper environments are only changed by jdk.
      - jdk1.6.0_6
      - sqldeveloper 1.5.1
      2) It's working and happy on sqldeveloper.

      I don't know what have different between jdk6_up6 and jdk6_up10
      but it show not same result sqldeveloper's editing environments.

      3. finally, wnen success on jdk1.6.0_6, i changed sqldeveloper.conf and jdk to jdk 1.6.0_10 and then backspace type is work.

      It's my issue and want knowing what are differents...
      Thanks for reading,