8 Replies Latest reply on Jan 9, 2009 12:07 PM by Saurabh T

    Trying http://localhost:7778 gives error

    Saurabh T
      I am using a server with Oracle 9i release 9.2.0.1.0 whre Oracle HTTP server is configured on Apache 1.3

      Trying URL http://localhost:7778 keeps waiting and then gives 'The Page can not be displayed' error.

      I checked httpd.conf where port is mentioned as 7778.

      somebody help me please in getting this resolved.

      Thanks in advanve.

      Regards,
      Saurabh
        • 1. Re: Trying http://localhost:7778 gives error
          Manikya -Oracle
          Hi Saurabh,

          Can you check the following:


          1> Is it a new install ? Reason of asking is that Port can be changed later on, after install, whereas portlist.ini is created at the time of install.
          In this case check httpd.conf for correct Port.

          2> If new Install(and also if no port change after install), you can get the Correct URL Detail in $ORACLE_HOME/install/setupinfo.txt
          3> If you are sure that the URL:Port you are using is correct then check if HTTP Server is running :
               $opmnctl status
          4> If still unresolved, try troubleshooting with Apache logs: $ORACLE_HOME/Apache/Apache/logs/error.log (Please post it in thread for getting help)
          5> Check the Loopback entry is there for the localhost in etc/hosts file.

          Regards,
          MA
          1 person found this helpful
          • 2. Re: Trying http://localhost:7778 gives error
            Saurabh T
            Hi MA,

            Thanks for your response.

            It is not a new install. This install was there for quite a time(3-4 yrs) but it seems no one was using this server.

            I checked httpd.conf and the prot no mentioned is *7778*.

            I could find a file setupinfo.txt in location $ORACLE_HOME\Apache\Apache. The URLs mentioned in this file are
            *[http://serverName:7778|http://servername:7778/]* and *[https://serverName:4443|https://servername:4443/]*. I tried these URLs also but same result.

            I checked HTTP server is running.

            I am trying URL *[http://localhost:7778|http://localhost:7778/]* by loging in to the Server itself.

            Below is the part of error log *$ORACLE_HOME/Apache/Apache/logs/error.log* when I start HTTP server and
            try the URL [http://localhost:7778|http://localhost:7778/]

            [Mon Dec 22 12:52:24 2008|http://forums.oracle.com/forums/] crit (13)Permission denied: Unable to read Gateway configuration in wdbsvr.app
            [Mon Dec 22 12:52:24 2008|http://forums.oracle.com/forums/] error (13)Permission denied: Please check your enviroment.
            ORACLE_HOME is
            PATH is I:\orant920\bin;I:\orant920\Apache\Perl\5.00503\bin\mswin32-x86;I:\orant920\Apache\fastcgi;F:\VERITAS\NetBackup\bin\;I:\orant920\bin;I:\orant920\jre\1.4.2\bin\client;I:\orant920\jre\1.4.2\bin;I:\orant920\bin;C:\Program Files\Oracle\jre\1.3.1\bin;C:\Program Files\Oracle\jre\1.1.8\bin;E:\UCPS\rpmtools\bin\;E:\UCPS\rpmtools\lib\;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;E:\NetIQ\AppManager\bin;E:\NetIQ\Common\bin;C:\Program Files\Symantec\pcAnywhere\;I:\OraAdmin\PSTools;I:\Orant920
            WV_GATEWAY_CFG is [I:]
            NLS_LANG is [http://AMERICAN_AMERICA.UTF8|http://american_america.utf8/]

            Thanks in advance.

            Regards,
            Saurabh

            Edited by: user10423090 on Dec 22, 2008 7:00 AM
            • 3. Re: Trying http://localhost:7778 gives error
              paul the Architect
              Has any new software been installed?

              Did it just stop working or have you rebooted the server?

              Can you check the length of the path on the server to make sure it is not to long as you have Oracle at both ends. Oracle As could only read a certain length of path so may be its not finding 'dir' it requires.

              I assume you do not have a full server backup you could restore!

              Does that application server manager console work?
              • 4. Re: Trying http://localhost:7778 gives error
                Manikya -Oracle
                Hi Saurabh,

                As per the Error mentioned in error Logs, please check the following points:

                1> You should start the apache service as (local) administrator account, The account which has installed the Binaries.

                2) wdbsrv.app file should exixst at I:\orant920\Apache\modplsql\cfg directory ,and check if it is not corrupt(0 Byte, or non-readable)

                3) The environment variable, WV_GATEWAY_CFG, should point to the complete file pathname of the wdbsvr.app and not to the directory only.

                Hope it helps you,

                Also, does this ever worked before..?

                Regards,
                MA
                1 person found this helpful
                • 5. Re: Trying http://localhost:7778 gives error
                  Saurabh T
                  Thanks for the responses.

                  To user4591883_

                  This server was not being used for a long time and also was not managed by us.

                  I checked Paths of Oracle folders. They look proper in length.

                  Yes, I don't have full server backup to restore.

                  Application server manager console is working (I am able to connect to server from Start-> Run -> mstsc /v:server_ip /console).

                  To ORA-4030_

                  1) HTTp server is running in Services(Local), if that meens from your 1st point.

                  2) wdbsvr.app file exists in proper path and is Not currupt.

                  3) I have reseet the environment variable WV_GATEWAY_CFG.
                  Previously it was I:\orant920\Apache\modplsql\cfg.
                  I changed it to I:\orant920\Apache\modplsql\cfg\wdbsvr.app.

                  but still the problem is as it is.

                  I am not sure if it ever worked before. I got this server now and also there is no contact point to ask for details of the server/installation.

                  Please help in resolving the issue. let me know if you want some other information.

                  Thanks in advance.

                  Regards,
                  Saurabh
                  • 6. Re: Trying http://localhost:7778 gives error
                    paul the Architect
                    Sorry its not looking very good for you.

                    I have had very similar problems in the past when the server has crashed or just been switched off at the wall.

                    It not very easy to get them going again but try the following :

                    1 shutdown the Apps server from server management console. Then close the server abd reboot this can some times resolve the problems.

                    2 check the log files to see if the server has been accessed in the past.

                    3 truncate the end of the log files as they can get corupted and stop the server from starting.

                    What type of server is it?
                    What is it runing?
                    1 person found this helpful
                    • 7. Re: Trying http://localhost:7778 gives error
                      70824
                      Look at the Listen directive, not Port. Also, try with FireFox - some MS IE implementations have issues with redirects (if you have Portal here, this might be an issue)

                      And patch, patch, patch!!! You have an unpatched, desupported version at your hands.

                      What do you want to use it for? Would it not be easier to install a fresh, and more recent version of software?
                      • 8. Re: Trying http://localhost:7778 gives error
                        Saurabh T
                        Thanks a lot to you all for your help.

                        Setting up the environment variable WV_GATEWAY_CFG correctly, shutting down the server and then restarting apache.exe did the trick.

                        Though, I'm still not sure what the actual problem was, because I had tried it earlier also. ;)

                        Edited by: user10423090 on Jan 9, 2009 4:06 AM