1 2 Previous Next 22 Replies Latest reply on Apr 10, 2009 3:34 PM by 78510 Go to original post
      • 15. Re: Form 10.1.2.0.2(10g) lib path
        621803
        That is pretty much exactly how I have it set up currently, except that all forms, reports, libraries, etc., are in a single directory on the network.

        Note that there is no issue with any other files. Only libraries.

        I had thought it was an issue with Forms 6i libraries, but I also can't open those that came with the Developer Suite 10g installation, which I copied to the directory on the network.

        So I copied the directory to my computer (off the network).

        I created a shortcut that points to the library and the new directory, and ran it. I got an error (not the same error) -"PDE-PER001 Internal error (scaba 10)"

        From within Forms Builder, I navigated to the local copy of the library and was able to open it (i.e., not using the shortcut), but I cannot compile it. I get "FRM-91507: Internal Error: Unable to generate library"

        Note that it is not a viable option to work from a local copy of the directory.
        • 16. Re: Form 10.1.2.0.2(10g) lib path
          Joe Farah
          when you create a shortcut that points to the directory:

          1st: open the forms buidlder from this shortcut
          2nd: open your library.
          3rd: compile your library.
          4th: open your form
          5th: remove any previous attachment of the lib
          6th: attach the library again
          7th: when asked, remove the path of the lib? answer by yes.
          8th: compile the form
          9th: run it

          make sure that the FORMS_PATH and default.env statisfy what we talked about in this conversation.

          hope the above will help..
          • 17. Re: Form 10.1.2.0.2(10g) lib path
            621803
            I'm sorry, but as I explained previously, those are the steps (through #3) that I have tried over and over with no success.

            I don't need to worry about attaching a library to a form (the steps after #3). That is not the issue, and I know how to do that.

            This is an existing, mature 6i application that we are trying to upgrade to 10g. I am able to open and edit form and menu modules. But if I can't upgrade the libraries, then the rest of it doesn't matter.

            10g Forms Builder won't even let me create a new library.
            • 18. Re: Form 10.1.2.0.2(10g) lib path
              Joe Farah
              Ok dear I got you.

              1 - Oracle DS 10g, which windows you are running on ?
              2- Does you user have administrative privileges ?
              • 19. Re: Form 10.1.2.0.2(10g) lib path
                user434854
                After installing the Developer Suite did you installed the Oracle BI Tools Software ?

                I faced the same issues and it came out to be a (what else ???) Windows located problem.

                If you installed the Oracle BI Tools Software after installing the Developer Suite then check your Path environment variable.

                When installing Developer Suite and Oracle BI Software adopt changes to your Path environment
                in this way, that the Developer Suite pathes are first in sequence ....
                • 20. Re: Form 10.1.2.0.2(10g) lib path
                  621803
                  I didn't install the BI suite.

                  I added to Forms_Path and Reports_Path in the registry, to point to the development folder where the libraries, forms and reports are located.

                  Should the Path environment variable also point there? Is this new to 10g Forms?
                  • 21. Re: Form 10.1.2.0.2(10g) lib path
                    621803
                    In my case, the problem is not with attaching libraries to forms. The problem is with being able to open the library (the .pll file) itself, to edit and re-compile.

                    However I was able to get around this by creating a folder on my hard (local) drive containing the PLL files.

                    I am able to edit and re-compile most of my libraries now. There are still two libraries that I can't open. I get error message "PDE-PER001 Internal Error (scaba 10)." I'm trying to work with folks at MetaLink on this.
                    • 22. Re: Form 10.1.2.0.2(10g) lib path
                      78510
                      It is a bug for Form 10.1.2. If you have admin privilege, it is fine. Otherwise you get this error. Please look at metlink for more detail.
                      1 2 Previous Next