5 Replies Latest reply on Feb 11, 2009 7:47 PM by 420940

    RMAN Duplicate DB Error

    684500
      Hi,

      Below is the error I received when duplicating my dev db to test db. I wish I could post the entire RMAN messages but the db is very large....

      RMAN-00571: ===========================================================
      RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
      RMAN-00571: ===========================================================
      RMAN-03002: failure of Duplicate Db command at 02/10/2009 16:23:31
      RMAN-03015: error occurred in stored script Memory Script
      RMAN-11003: failure during parse/execution of SQL statement: alter database recover logfile '+ASMDG/testdb/archivelog/2009_02_10/thread_2_seq_49114.319.678471419'
      ORA-01041: internal error. hostdef extension doesn't exist

      I copied all the RMAN backups of dev db to test server (both on diff hosts) and connected target to dev, auxiliary to test and issued duplicate db using set until time 23:30:00......but the above messages indicate that it recovered till 22:15:00 and was having error recovering from 22:25:00. It successfuly recovered from 20:00:00 (full backup time) thru 22:15:00....Why does it give an error at 22:25:00..when all the files are SCP'd from same location to another one..what shall I do now to complete the recovery and open the db...Since, it is a test, i dont even need to do a recovery...i need to run some queries...so all i need is to open the db..i tried using resetlogs option...but i get the following errror....

      SQL> alter database open resetlogs;
      alter database open resetlogs
      *
      ERROR at line 1:
      ORA-38856: cannot mark instance UNNAMED_INSTANCE_2 (redo thread 2) as enabled

      Plz help me....
        • 1. Re: RMAN Duplicate DB Error
          420940
          I beleive database is in mount state. Just issue the command "recover database using backup controlfile"
          it will ask you for the archive logs. if you have that archive log at default location, then just press enter, otherwise type the full name. if you don't have that archive log, then type CANCEL.
          then try to open the database in resetlogs.
          1 person found this helpful
          • 2. Re: RMAN Duplicate DB Error
            684500
            Yes the db is in mount state and I tried as u said....

            i gave the file name as it is located on host server and the db files, control, redo, archive log's are located on ASM.......

            SQL> recover database using backup controlfile;
            ORA-00279: change 8185578805690 generated at 02/09/2009 22:25:30 needed for thread 1
            ORA-00289: suggestion : +ASMDG
            ORA-00280: change 8185578805690 for thread 1 is in sequence #57212


            Specify log: {<RET>=suggested | filename | AUTO | CANCEL}
            /ora_backup/tgdev/rman/tgdev_58073_1_1_2009-02-09T22:25:01.arch.bak
            ORA-00317: file type 0 in header is not log file
            ORA-00334: archived log: '/ora_backup/tgdev/rman/tgdev_58073_1_1_2009-02-09T22:25:01.arch.bak'

            any idea?

            Edited by: user8371767 on Feb 11, 2009 10:18 AM
            • 3. Re: RMAN Duplicate DB Error
              420940
              the archive log you have given is not the archive log. it is the backup set name. in this case, you have to first extract the archive logs from this backup set and then do the recovery.
              go to RMAN and type below command
              "restore archivelog all;"

              and then again do the step "recover database using backup controlfile;"

              check first where your archive logs will be restored? by default it will go to $ORACLE_HOME/dbs folder or the log_archive_dest_? specified in database

              --------------
              or set the destination in RMAN as

              RUN
              {
              SET ARCHIVELOG DESTINATION TO '/oracle/temp_restore';
              RESTORE ARCHIVELOG ALL;

              --------------

              Edited by: Appoo on Feb 11, 2009 10:30 PM
              • 4. Re: RMAN Duplicate DB Error
                684500
                hey, i still couldn't get thru this one....

                RMAN> restore archivelog all;

                Starting restore at 02/11/2009 13:36:29
                using target database control file instead of recovery catalog
                allocated channel: ORA_DISK_1
                channel ORA_DISK_1: sid=151 instance=dev2 devtype=DISK
                allocated channel: ORA_DISK_2
                channel ORA_DISK_2: sid=297 instance=dev1 devtype=DISK

                RMAN-00571: ===========================================================
                RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
                RMAN-00571: ===========================================================
                RMAN-03002: failure of restore command at 02/11/2009 13:36:40
                RMAN-06026: some targets not found - aborting restore

                And the rest of it is
                No backup of log thread 2 seq.......
                ....
                ...
                ...

                my init.ora file has the folowing settings:

                *.log_archive_dest_1='LOCATION=+ASMDG MANDATORY REOPEN'
                *.log_archive_format='%t_%s_%r.arch'

                as i told u earlier, my archive backup set files are located on host server and i think it is looking in the ASM. but, i created the following files when i first ran the duplicated db command....

                thread_1_seq_57210.334.678471419
                thread_1_seq_57211.318.678471419
                thread_2_seq_49114.319.678471419

                Is it not able to read these files? My set until time has been set to 23:30:00 but it has an error at 22:25:00 backup set.....but all those backup sets are valid RMAN HOT backups....plz help me....
                • 5. Re: RMAN Duplicate DB Error
                  420940
                  in RMAN try this and update us

                  catalog start with '/ora_backup/tgdev/rman/';
                  list archivelog all;
                  restore archive log all;