5 Replies Latest reply on Feb 23, 2009 6:46 PM by 621027

    VM vanishes after reboot

    621027
      Hi,
      I have 3 systems:
      1- System # 1 is my Server Pool Master, Utility Server, and Virtual Machine Server
      2- System # 2 is my another Virtual Machine Server
      3- System # 3 is my control machine running Oracle Linux.

      I installed Oracle VM server 2.1.2 on systems 1 and 2 with no problem.
      I also installed Oracle Ent. Linux R5U3 (x86_64) on system #3. After that I also installed Oracle VM Manager 2.1.2 on server # 3.
      PROBLEM:
      After creating the pools and importing ISO images, I created a new VM. Everything went well untill o the point VM system had to be restarted. As you know XP wants to reboot the system during the installation and RedHat needs to be rebooted after installation in done.
      After VM system goes down for rebooting, I cannot bring them back again. This is the error message:

      {color:#ff0000}failed:<Exception: failed:<Exception: vm config file ('/OVS/running_pool/10_vmp93h03/vm.cfg') does not exist.> StackTrace: File "/opt/ovs-agent-2.2/OVSXXenVMConfig.py", line 508, in xen_get_memory cfg = xen_unmarshall_cfg(vm_cfg_file) File "/opt/ovs-agent-2.2/OVSXXenVMConfig.py", line 97, in xen_unmarshall_cfg raise Exception("vm config file ('%s') does not exist." % cfg_file) > StackTrace: File "/opt/ovs-agent-2.2/OVSSiteVM.py", line 84, in start_vm raise e {color}

      I also connected to the pool master and ran xm list command but didn't see nothing.
      root@vmp93h01 ~# xm list
      Name ID Mem VCPUs State Time(s)
      Domain-0 0 543 2 r----- 543.3
      {color:#000000}
      The file, {color}{color:#000000}/OVS/running_pool/10_vmp93h03/vm.cfg does exist and I could {color}ssh to the server machine and see the vm.cfg file. Here is my vm.cfg file:

      {color:#0000ff}# cat /OVS/running_pool/10_vmp93h03/vm.cfg
      acpi = 1
      apic = 1
      builder = 'hvm'
      device_model = '/usr/lib/xen/bin/qemu-dm'
      disk = ['file:/OVS/running_pool/10_vmp93h03/System.img,hda,w',
      'file:/OVS/iso_pool/Windows/windows_xp_32bit.iso,hdc:cdrom,r',
      ]
      kernel = '/usr/lib/xen/boot/hvmloader'
      keymap = 'en-us'
      memory = '512'
      name = '10_vmp93h03'
      on_crash = 'restart'
      on_reboot = 'restart'
      pae = 1
      serial = 'pty'
      timer_mode = 0
      vcpus = 1
      vif =
      vnc = 1
      vncconsole = 1
      vnclisten = '0.0.0.0'
      vncpasswd = 'pass'
      vncunused = 1{color}

      I also have to say that I'm not using SAN. These are all x86-64 machines.

      I need your help here. I had tried the previous versions of Oracle VM products but did not have this problem.

      Regards,
      Habib

      Edited by: user618024 on Feb 11, 2009 3:16 PM
        • 1. Re: VM vanishes after reboot
          676147
          Hi there


          Run the command ln -s /OVS/running_pool/10_vmp93h03/vm.cfg /etc/xen/10_vmp93h03

          That should work...if 10_vmp93h03 is what your VM is called...........other wise replace the /etc/xen/10_vmp93h03 with /xet/xen/<vmID>
          E.G /etc/xen/vm03



          Let me know how that works..



          Or try run the VM from the console

          xm create <vmname>


          let me know if that works
          • 2. Re: VM vanishes after reboot
            621027
            Hi,
            Thanks for your response. I tried your suggestion and made a symbolic link but did not work:
            ln -s /OVS/running_pool/10_vmp93h03/vm.cfg /etc/xen/10_vmp93h03

            I got the same error message again. I can create the vm machine and I also can see the cfg file, but when I reboot the system after OS installation, ORACLE VM manager can not see it.
            I used the same machines with Enterprise-R4-U7-i386 and version 2.1.1 and had no problem.
            I'll replace the server pool machine to see what happens.

            Best Regards
            • 3. Re: VM vanishes after reboot
              676147
              Hi There


              thats unfortuanate that it didnt work.


              Did you try a xm create < vmname> in the VM server console window?


              If you did can you tell me the error message that you got from it?


              Thanks.
              • 4. Re: VM vanishes after reboot
                621027
                Hi,

                Thanks for your replay. Is the relation between Oracle VM manager and Oracle server 2 ways? In other words, if I create a new vm using VM server console (xm create), will I be able to see it in VM manager web application? Is there any mechanism for Oracle VM Manager to pickup xen commands ran on VM server console by users?
                If I remember correctly, there was no such a mechanism in previous versions.

                I've replaced the vm pool server machine. I've also removed the VM manager package from Oracle Linux. I'll try again after reinstalling the VM manager package and will let you know.

                Best Regards,
                Habib
                • 5. Re: VM vanishes after reboot
                  621027
                  Problem was solved (for now) after replacing the old hardware with a more powerful one. However, the same hardware setup used to work with previous version of Oracle VM.

                  Thank you everybody for your help.

                  Regards