3 Replies Latest reply: Feb 9, 2011 9:49 AM by paone RSS

    Unable to load performance pack (Solaris 10)

    682360
      Hi all,

      I had started a BEA wlss 3.1 on Solaris SPARC10 (Solaris 10 5/08 s10s_u5wos_10 SPARC). Although the wlss managed to start successfully, there was an error:

      <26.mar.2009 kl 18.35 CET> <Error> <Socket> <BEA-000438> <Unable to load performance pack. Using Java I/O instead. Please ensure that a native performance library is in: '/opt/bea/sipserver31/server/native/solaris/sparc'
      >

      However, all the performance libraries are already there in the folder '/opt/bea/sipserver31/server/native/solaris/sparc'.

      total 1496
      drwxr-xr-x 2 root root 512 mars 12 15:04 .
      drwxr-xr-x 3 root root 512 mars 12 15:04 ..
      -rw-r--r-- 1 root root 360304 mars 12 15:04 libjmsc.so
      -rw-r--r-- 1 root root 43736 mars 12 15:04 libmuxer.so
      -rw-r--r-- 1 root root 16720 mars 12 15:04 libnodemanager.so
      -rw-r--r-- 1 root root 5232 mars 12 15:04 libterminalio.so
      -rw-r--r-- 1 root root 16800 mars 12 15:04 libweblogicunix1.so
      -rw-r--r-- 1 root root 7176 mars 12 15:04 libwlenv.so
      -rw-r--r-- 1 root root 23000 mars 12 15:04 libwlfileio2.so
      -rwxr-xr-x 1 root root 270336 mars 12 15:04 wlauth

      Did anyone have the same problem before ?

      Thanks for your help.

      Best Regards,
      kirati
        • 1. Re: Unable to load performance pack (Solaris 10)
          user753546
          I sit happening with sunjdk?

          If you install the 64-bit version of Oracle Communications Converged Application Server installer package on Solaris, you must add the -d64 option with the Sun JDK in order to specify 64-bit mode. If you omit the -d64 option, the Sun JDK automatically defaults to 32-bit mode and the installer fails to install required 64-bit native libraries.

          Hope it helps.

          Anurag Bahl
          • 2. Re: Unable to load performance pack (Solaris 10)
            682360
            I added the -d64 options and it works !
            thank you very much for your help.
            • 3. Re: Unable to load performance pack (Solaris 10)
              paone
              Hi all,

              I got similar Error when I tried to installed Generic version of WebLogic 10.3.4.0 on Solaris 5.10.

              Best option as told above

              java -d64 -jar wls1034_generic.jar -mode=console

              Other alternative is that tell the WebLogic use 64bit JDK to say that
              I have changed commEnv.sh script 2 lines

              #JAVA_USE_64BIT, true if JVM uses 64 bit operations
              JAVA_USE_64BIT=true

              and

              Update> SUN_ARCH_DATA_MODEL="64"


              Hope this sharing will help to resolve much more of yours.... :)

              Edited by: PavanBhavanishekhar on Feb 9, 2011 7:37 AM