6 Replies Latest reply: Sep 8, 2009 3:22 AM by 688959 RSS

    PS 8.49 Integration Gateway - IBResponse

      Hi All

      We are using Peoplesoft tools 8.49 .while doing credit card test using ProcessBrokerTransaction it throws the below error

      IntegrationGateway: No response received from Gateway (158,10829)

      The Gateway didnot send back a IBResponse.

      Kindly help me out..."
        • 1. Re: PS 8.49 Integration Gateway - IBResponse

          Can you tell me the name of the following:
          OS name & version
          Webserver name & version
          PeopleTools version (like 8.49.05)

          Have you tried pinging the node?

          Is the node internal or external?

          • 2. Re: PS 8.49 Integration Gateway - IBResponse
            Hi S ,

            Please find the environment details below ..

            Tools : 8.49.15
            Application: 9.0
            Java : 1.5
            Webserver : BEA Weblogic
            OS name -Sun solaris or Unix (Error occur at client place so am confused between either two OS)

            Also find the logs below ...(I have modified the application server path with # symbol for security purpose)

            ####<Mar 16, 2009 8:27:43 PM GMT> <Error> <HTTP> <######> <PIA> <[ACTIVE] ExecuteThread: '17' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1237235263114> <BEA-101020> <[weblogic.servlet.internal.WebAppServletContext@993730 - appName: 'peoplesoft', name: '/PSIGW', context-path: '/PSIGW'] Servlet failed with Exception
            java.lang.UnsupportedOperationException: Method not implemented.
            at java.net.URLStreamHandler.openConnection(URLStreamHandler.java:80)
            at java.net.URL.openConnection(URL.java:990)

            Please help me out...
            • 3. Re: PS 8.49 Integration Gateway - IBResponse
              Hi S,

              Sorry forgot to answer all ur questions

              Yes the node is External
              We were able to ping the node and it is successful..Able to load Gateway connectors and the Peoplesoft Listening connector is Active..

              Let me know if any other questions..
              • 4. Re: PS 8.49 Integration Gateway - IBResponse

                Its a problem with your PIA install..
                Have a look at https://metalink3.oracle.com/od/faces/secure/km/DocumentDisplay.jspx?id=661851.1&h=Y

                If you are unable to access the link, the solution says

                Gateway did not receive back IBResponse
                The directory structure for the webserver was missing some files. Re-installing PIA resolved this issue.

                • 5. Re: PS 8.49 Integration Gateway - IBResponse
                  Thanks a lot...Issue cleared
                  • 6. Re: PS 8.49 Integration Gateway - IBResponse
                    Hi Today I faced the same issue...Check wheter Intergrationbroker.properties file is present in the webserver/Domain/Applications/Peoplesoft/../Web-inf/...
                    See if any thing is written in this file..if not copy this file from other webserver directory and change URL accordingly.....Now you should be able to load connectors