This discussion is archived
14 Replies Latest reply: May 3, 2009 1:01 AM by gerardnico RSS

Setting Up Mail Server to Send Alerts Using ibots

695807 Newbie
Currently Being Moderated
Hi

I'm new to this tool.

I was following the tutorial on the oracle website to setup the mail server. I did exactly the same but I'm not getting any mails. Currently I'm getting the alerts but its not sending the email. I have few questions on this

The Steps that were followed by me are:
1)Downloaded Argosoft mail server
2) Created users (wiprkk) and password also
3)Entered user@<yourmachine> in the Return Address text box, where <yourmachine> is the name of your machine domain configuration. For this I gave as wiprkk@geeks.
4)*Question Here is what is my machine name? Is it my computer name?* which is *"geeks"*
5) What Should I type in for *"Return Address"?* The screenshot says *"user@yourmachine.us.oracle.com"*. In my case will it be wiprkk@geeks.us.oracle.com???
6) What will be my Local Host and Local Domain?????? Currently the screenshot says *"Local host" & "Local Domain" - "yourmachine.us.oracle.com"*. So for my case will it be *"geeks.us.oracle.com"*
7) What would be the email address in outlook express ??? will it be wipkk@geeks
8) What would be the email server name for both Incoming and outgoing mail ??? will it be (machinename==geeks?? or machinename.us.oracle.com == geeks.us.oracle.com????

can you please help me resolve this issue. It would be helpful if anyone can give step by step instructions with the below data.

Your reply at the earliest would be helpful.

Just to summarize

username: wiprkk
computername = machine name =="geeks"
What should be the "Local Host" in my case
What should be the "Local Domain" in my case
What is this ".us.oracle.com"?? Do i need to append this with my machine name??? can I use .us.oracle.com????

Do i need to start any services in my machines other than OBIEE Scheduler servers etc.. (I mean like smtp services etc..)
  • 1. Re: Setting Up Mail Server to Send Alerts Using ibots
    Turribeach Guru
    Currently Being Moderated
    The guide you followed assumes you are running your PC within a Windows Domain and that you have some sort of basic mail knowledge to do the configuration. I would recommend that you post the question in Argosoft mail server forums since this is a forum for OBIEE products, not Argosoft's. In any case I you don't need to setup any mail servers to have OBIEE Delivers sending emails as it works with any SMTP mail server. If you are at work there will be certainly one available otherwise your work email couldn't be routed, ask your network administrator. If you are at home you could use your ISP's SMTP server. You certainly have an internet connection since you posted this message. :-)
  • 2. Re: Setting Up Mail Server to Send Alerts Using ibots
    695807 Newbie
    Currently Being Moderated
    Hi

    I'm trying to setup this on my laptop. Can you give me step by step instructions on how could use ISP's SMTP server to get the mail server configured and see the emails in my oulook express.

    Thanks
    WIPRKK
  • 3. Re: Setting Up Mail Server to Send Alerts Using ibots
    Turribeach Guru
    Currently Being Moderated
    http://oraclebizint.wordpress.com/2007/09/13/oracle-bi-ee-10133-configuring-delivers-ibots/
  • 4. Re: Setting Up Mail Server to Send Alerts Using ibots
    695807 Newbie
    Currently Being Moderated
    Hi

    I have done all those steps the only part I have probelm is setting up a mail server on my machine. I need guidance on that

    Thanks
    wiprkk
  • 5. Re: Setting Up Mail Server to Send Alerts Using ibots
    628531 Expert
    Currently Being Moderated
    Have a look here:
    http://obiee101.blogspot.com/2008/09/setting-up-mailserver-in-vmware.html

    regards

    John
    http://obiee101.blogspot.com
  • 6. Re: Setting Up Mail Server to Send Alerts Using ibots
    695807 Newbie
    Currently Being Moderated
    Hi John

    Thanks for the reply. I followed the instructions posted in the link it worked fine but the problem I having is when I edit my account in delivers and try to setup an email account. Its not taking it. It is abc@yahoo.com. but my email setup is wiprkk@geeks. where geeks is my machine name. I don't have a .com. How can i make the email account work in presentation services (ibots)
    Thanks
    Wiprkk

    Edited by: WIPRKK on Apr 25, 2009 10:15 PM
  • 7. Re: Setting Up Mail Server to Send Alerts Using ibots
    gerardnico Expert
    Currently Being Moderated
    Hy,

    You don't need to install a mail server on your machine. Use simply the smtp server of your provider (the best is to use a SSL smtp to be able to use it anywhere if you configure a laptop).
    I have made an example for you.
    http://gerardnico.com/weblog/2009/04/26/obiee-how-to-configure-the-mail-server-of-oracle-bi-schedulerdelivers/

    Success
    Nico
  • 8. Re: Setting Up Mail Server to Send Alerts Using ibots
    695807 Newbie
    Currently Being Moderated
    Hi

    Your example was helpful but I still couldn't get it right. I don't have an email account with my isp. I use gmail a lot. How can i configure gmail in the scheduler configration (job manager). I gave sender address as wiprkk@gmail.com
    smtp address as smtp.gmail.com and smtp port as 465

    username as wiprkk@gmail.com
    password:email password.

    and in ibots i create the email as wiprkk@gmail.com.

    I can see the alerts in presentation services but it is not sending the emails.

    Please try to help in how I can resolve this

    Can u match this for gmail
    ■smtp server : smtp.xs4all.nl === smtp.gmail.com????
    ■port TLS : 587===465????
    ■Login : login===wiprkk@gmail.com
    ■Password : password=== email password
    ■Sender : nicolas.gerard@newfrontiers.com ==== wiprkk@gmail.com????

    ERROR MESSAGE:

    Eventually succeeded, but encountered and resolved errors...
    Number of skipped recipients: 1 of 2

    +++ ThreadID: b84 : 2009-04-26 14:42:59.781
    iBotID: /users/administrator/_ibots/Test Email
    [nQSError: 75003] Failed to open connection to SMTP Server.

    +++ ThreadID: b84 : 2009-04-26 14:42:59.812
    iBotID: /users/administrator/_ibots/Test Email
    ...Trying SMTP Delivery loop again

    +++ ThreadID: b84 : 2009-04-26 14:42:59.812
    ... Sleeping for 5 seconds.

    +++ ThreadID: b84 : 2009-04-26 14:48:05.015
    iBotID: /users/administrator/_ibots/Test Email
    [nQSError: 75003] Failed to open connection to SMTP Server.

    +++ ThreadID: b84 : 2009-04-26 14:48:05.031
    iBotID: /users/administrator/_ibots/Test Email
    ...Trying SMTP Delivery loop again

    +++ ThreadID: b84 : 2009-04-26 14:48:05.078
    ... Sleeping for 8 seconds.

    +++ ThreadID: b84 : 2009-04-26 14:53:13.250
    iBotID: /users/administrator/_ibots/Test Email
    [nQSError: 75003] Failed to open connection to SMTP Server.

    +++ ThreadID: b84 : 2009-04-26 14:53:13.296
    iBotID: /users/administrator/_ibots/Test Email
    ...Trying SMTP Delivery loop again

    +++ ThreadID: b84 : 2009-04-26 14:53:13.328
    ... Sleeping for 6 seconds.

    +++ ThreadID: b84 : 2009-04-26 14:58:19.531
    iBotID: /users/administrator/_ibots/Test Email
    [nQSError: 75003] Failed to open connection to SMTP Server.

    +++ ThreadID: b84 : 2009-04-26 14:58:19.562
    iBotID: /users/administrator/_ibots/Test Email
    Exceeded number of delivery retries.

    Thanks
    wiprkk
  • 9. Re: Setting Up Mail Server to Send Alerts Using ibots
    gerardnico Expert
    Currently Being Moderated
    For gmail :
    * smtp : smtp.gmail.com
    * port : 465
    * user : user@gmail.com
    * password : email password
    * Sender : user@gmail.com

    Detail here :
    http://www.emailaddressmanager.com/tips/outlook-gmail.html

    You must verify that you can reach the Smtp Gmail :
    http://gerardnico.com/wiki/smtp_telnet


    Success
    Nico
  • 10. Re: Setting Up Mail Server to Send Alerts Using ibots
    Turribeach Guru
    Currently Being Moderated
    My guess is that Delivers is not going to work with Gmail's SMTP server. Gmail's SMTP server uses authentication and an SMTP extension called STARTTLS to encrypt the SMTP connection as SMTP is a clear text protocol. Delivers has the option to enable SMTP authentication but I don't see any options to enable encryption (usually shown as SSL, TLS or STARTTLS on email clients) so I don't think it will work. As I said before I don't understand why you can't use your ISP's SMTP server. I don't know any ISPs that don't provide an SMTP server to its customerss, even if they don't give you an email account with your internet connection. If yours doesn't provide one then I would recommend you switch to one that does. You could also use Linux which comes with it's own SMTP server. In any case setting up an SMTP server is not really a subject for this forum and you would probably get more help looking in SMTP specific web forums.
  • 11. Re: Setting Up Mail Server to Send Alerts Using ibots
    gerardnico Expert
    Currently Being Moderated
    Hy Turribeach,

    It works for me and my providers use the same extension STARTTLS.
    May be the port is 587 and not 465.

    All detail are here :
    http://mail.google.com/support/bin/answer.py?hl=en&answer=13287

    Success
    Nico
  • 12. Re: Setting Up Mail Server to Send Alerts Using ibots
    gerardnico Expert
    Currently Being Moderated
    Hy Turribeach,

    Just to say that I was wrong. You're right. I just try it today and my provider can use STARTTLS but it does not require to use it as Gmail does.
    I apologize.

    Good week-end
    Nico
    C:\Documents and Settings\Nicolas>telnet smtp.gmail.com 587
    220 mx.google.com ESMTP 10sm8014744eyd.42
    ehlo nico
    250-mx.google.com at your service, [83.83.223.119]
    250-SIZE 35651584
    250-8BITMIME
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250 PIPELINING
    AUTH LOGIN
    530 5.7.0 Must issue a STARTTLS command first. 10sm8014744eyd.42
    .....
    And you can see that you get in the log after Mail Configuration :
    +++ ThreadID: 1044 : 2009-05-02 21:13:29.594
        iBotID: /users/administrator/_iBots/lag
    [nQSError: 75005] Failed to send AUTH command. No supported authentication mechanism found
  • 13. Re: Setting Up Mail Server to Send Alerts Using ibots
    695807 Newbie
    Currently Being Moderated
    Hi

    I did the same but got the same error. So what am i supposed to do? my isp's smtp server is "smtp-server.socal.rr.com" and will my email address be abc@gmail.com.

    Thanks
    Wiprkk
  • 14. Re: Setting Up Mail Server to Send Alerts Using ibots
    gerardnico Expert
    Currently Being Moderated
    I can't find a ssl smtp on your ISP : http://www.rr.com/ because the help is restricted to its network and I don't know your town and your type of connection : http://help.rr.com/

    I suppose that you are on it therefore you can try this one :
    * smtp server : smtp-server.socal.rr.com
    * port : 25
    * Login : No login
    * Password : No Password
    * Sender : your account on the rr network

    Try your parameters before sending :
    http://gerardnico.com/wiki/smtp_telnet

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points