4 Replies Latest reply: Apr 27, 2009 10:57 AM by 668906 RSS

    managed server state UNKNOWN after server reboot

    488475
      Using beasvc scripts I have registered Nodemanager, AdminServer, and managed server Apps as windows services. I setup AdminServer service to depend on Nodemanager and Apps to depend on AdminServer service. All services startup fine on reboot, however, in console the Apps state is showing UNKNOWN. If I go into windows services and manually restart this service, it then shows as RUNNING. I've tried to delay the Apps service statup up to 5 minutes after AdminServer but get the same results. Any ideas where the disconnect is happening?

      This is happening with WL 10.3, Windows Server 2003 & 2008. Let me know if I need to paste any scripts or settings. Thanks!
        • 1. Re: managed server state UNKNOWN after server reboot
          668906
          What does the logs suggest?
          • 2. Re: managed server state UNKNOWN after server reboot
            488475
            AdminServer Log:
            ####<Apr 27, 2009 10:43:24 AM CDT> <Info> <ServletContext-/bea_wls_internal> <0279its-jdev01> <AdminServer> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <> <1240847004384> <BEA-000000> <HTTPClntLogin: Login rejected with code: 'Failed', reason: java.net.ProtocolException: HTTP tunneling is disabled
                 at weblogic.rjvm.http.HTTPServerJVMConnection.acceptJVMConnection(HTTPServerJVMConnection.java:89)
                 at weblogic.rjvm.http.TunnelLoginServlet.service(TunnelLoginServlet.java:80)
                 at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
                 at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
                 at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
                 at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:292)
                 at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:175)
                 at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3498)
                 at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
                 at weblogic.security.service.SecurityManager.runAs(Unknown Source)
                 at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2180)
                 at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2086)
                 at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1406)
                 at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
                 at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)


            Apps server log:
            ####<Apr 27, 2009 10:43:55 AM CDT> <Warning> <JMX> <0279its-jdev01> <Apps> <[ACTIVE] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1240847035317> <BEA-149510> <Unable to establish JMX Connectivity with the Adminstration Server AdminServer at <JMXServiceURL:null>.>

            Edited by: jstretch on Apr 27, 2009 8:49 AM
            • 3. Re: managed server state UNKNOWN after server reboot
              668906
              For 1. Enable http tunneling. This is a workaround.
              For 2. Check if you have ip address specified for admin serve. If its not then specify one.
              • 4. Re: managed server state UNKNOWN after server reboot
                488475
                Enabling Tunneling worked. I was unaware that it supported http as well as t3.

                Did not specify an IP address as its all on the same machine so localhost is assumed.

                Thanks