4 Replies Latest reply on May 1, 2009 11:58 AM by 698737

    Issues with starting weblogic server for my domain

    698737
      This is part of the adminserver log file:

      ####<Apr 29, 2009 3:47:18 PM EDT> <Critical> <WebLogicServer> <mycomputername> <AdminServer> <main> <<WLS Kernel>> <> <> <1241034438142> <BEA-000386> <Server subsystem failed. Reason: java.lang.AssertionError: java.lang.reflect.InvocationTargetException
      java.lang.AssertionError: java.lang.reflect.InvocationTargetException
           at weblogic.descriptor.internal.AbstractDescriptorBean$SecurityService._invokeServiceMethod(AbstractDescriptorBean.java:1011)
           at weblogic.descriptor.internal.AbstractDescriptorBean$SecurityService.decrypt(AbstractDescriptorBean.java:1039)
           at weblogic.descriptor.internal.AbstractDescriptorBean$SecurityService.access$200(AbstractDescriptorBean.java:963)
           at weblogic.descriptor.internal.AbstractDescriptorBean._decrypt(AbstractDescriptorBean.java:960)

      What could the issue be?
        • 1. Re: Issues with starting weblogic server for my domain
          togotutor
          Please give us more info on this.

          Also , please check if you are running anything else on same port. Also check if you are not missing any configuration files. Check if the classpath has been set correctly. boot.properties file in place.
          • 2. Re: Issues with starting weblogic server for my domain
            698737
            I have a boot.properties file under mydomain>servers>AdminServer>Security
            Is this correct and where it should be?

            I've a config.xml file under mydomain>config
            Is this the only config file I need to be concerned about?

            I checked the ports that are listening and 7001 is not one of them. I am pretty sure I set up they system to use 7001, where can I check to verify and how can I 'make' it listen to this port? Actually, pointbase port is set up to listen to 9093 but I don't see that port on my list when I do netstat -o

            I didn't change anything about classpaths. I created everything out of the box and left that untouched. Where should I check to verify if something got out of sync?

            Thanks for the help.

            Edited by: user11113120 on Apr 30, 2009 5:33 AM
            • 3. Re: Issues with starting weblogic server for my domain
              togotutor
              Looks like the file setup is correct. Can you please give complete log output?
              • 4. Re: Issues with starting weblogic server for my domain
                698737
                I finally got so frustrated that I uninstall and reinstalled it. I did not import any projects at this time, but created a simple, out-of-the-box domain. Then tried to start the server under that domain, and now I get:

                Invalid table name "USERS" specified at position

                Please find part of log output below (I don't see a place in this forum to attach a file). I've copied the portions out of the log that reference exceptions. I appreciate the help!

                ava.sql.SQLException: Invalid table name "USERS" specified at position 23.
                     at com.pointbase.net.netJDBCPrimitives.handleResponse(DashoA13*..:335)
                     at com.pointbase.net.netJDBCPrimitives.handleJDBCObjectResponse(DashoA13*..:383)
                     at com.pointbase.net.netJDBCConnection.prepareStatement(DashoA13*..:545)
                     at weblogic.security.providers.authentication.DBMSSQLReadOnlyDatabaseConnectionImpl.getPreparedStatement(DBMSSQLReadOnlyDatabaseConnectionImpl.java:37)
                     at weblogic.security.providers.authentication.shared.DBMSSQLRuntimeQueryImpl.passwordStringQuery(DBMSSQLRuntimeQueryImpl.java:78)
                     at weblogic.security.providers.authentication.shared.DBMSSQLRuntimeQueryImpl.executeUserPassword(DBMSSQLRuntimeQueryImpl.java:71)
                     at weblogic.security.providers.authentication.shared.DBMSAtnLoginModuleImpl.authenticateDBMS(DBMSAtnLoginModuleImpl.java:666)
                     at weblogic.security.providers.authentication.shared.DBMSAtnLoginModuleImpl.login(DBMSAtnLoginModuleImpl.java:270)
                     at com.bea.common.security.internal.service.LoginModuleWrapper$1.run(LoginModuleWrapper.java:110)
                     at java.security.AccessController.doPrivileged(Native Method)
                     at com.bea.common.security.internal.service.LoginModuleWrapper.login(LoginModuleWrapper.java:106)
                     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                     at java.lang.reflect.Method.invoke(Method.java:585)
                     at javax.security.auth.login.LoginContext.invoke(LoginContext.java:769)
                     at javax.security.auth.login.LoginContext.access$000(LoginContext.java:186)
                     at javax.security.auth.login.LoginContext$4.run(LoginContext.java:683)
                     at java.security.AccessController.doPrivileged(Native Method)
                     at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:680)
                     at javax.security.auth.login.LoginContext.login(LoginContext.java:579)
                     at com.bea.common.security.internal.service.JAASLoginServiceImpl.login(JAASLoginServiceImpl.java:91)
                     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                     at java.lang.reflect.Method.invoke(Method.java:585)
                     at com.bea.common.security.internal.utils.Delegator$ProxyInvocationHandler.invoke(Delegator.java:61)
                     at $Proxy17.login(Unknown Source)
                     at weblogic.security.service.internal.WLSJAASLoginServiceImpl$ServiceImpl.login(WLSJAASLoginServiceImpl.java:89)
                     at com.bea.common.security.internal.service.JAASAuthenticationServiceImpl.authenticate(JAASAuthenticationServiceImpl.java:80)
                     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                     at java.lang.reflect.Method.invoke(Method.java:585)
                     at com.bea.common.security.internal.utils.Delegator$ProxyInvocationHandler.invoke(Delegator.java:61)
                     at $Proxy19.authenticate(Unknown Source)
                     at weblogic.security.service.PrincipalAuthenticator.authenticate(PrincipalAuthenticator.java:366)
                     at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(CommonSecurityServiceManagerDelegateImpl.java:911)
                     at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(CommonSecurityServiceManagerDelegateImpl.java:1029)
                     at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager.java:854)
                     at weblogic.security.SecurityService.start(SecurityService.java:141)
                     at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
                     at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
                     at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)
                >
                ####<May 1, 2009 7:50:55 AM EDT> <Critical> <Security> <lmv25-ite89695> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1241178655172> <BEA-090403> <Authentication for user weblogic denied>
                ####<May 1, 2009 7:50:55 AM EDT> <Critical> <WebLogicServer> <mycomputername> <AdminServer> <main> <<WLS Kernel>> <> <> <1241178655172> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
                weblogic.security.SecurityInitializationException: Authentication for user weblogic denied
                     at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthorization(CommonSecurityServiceManagerDelegateImpl.java:947)
                     at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(CommonSecurityServiceManagerDelegateImpl.java:1029)
                     at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager.java:854)
                     at weblogic.security.SecurityService.start(SecurityService.java:141)
                     at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
                     at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
                     at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)