This discussion is archived
3 Replies Latest reply: Jun 11, 2012 2:54 PM by 942977 RSS

Server Setup Error with Oracle Business Process Architect - Express Edition

696918 Newbie
Currently Being Moderated
I am trying to setup a server with Oracle Business Process Analysis Suite including Business Process Architect and Repository. When I tried to install the Product, it only let me install the "Express Edition" on the server.

I tried to setup a new database with the installation for Repository Server, and then selected the option to "Connect to existing configured database" when installing Business Process Architect. But now when I open up Business Process Architect on the server machine, it cannot open the "Local Server", and gives an error "Unable to Connect to Local Business Server". I am not sure if I am doing anything incorrect with the setup. Could someone please share thoughts on how to fix this issue?

Thanks in advance,
  • 1. Re: Server Setup Error with Oracle Business Process Architect - Express Edition
    452670 Newbie
    Currently Being Moderated
    Hi Sowmya,

    what you have in in-coherent deployment.
    Google the word "ARIS_Platform_SWP_en_2006-04.pdf" this is a good white paper from ARIS guys which will help you understand the deployment options of Oracle BPA.
    Once you are armed with this info, you will find that the Oracle documention sort-of makes sense.


  • 2. Re: Server Setup Error with Oracle Business Process Architect - Express Edition
    695893 Newbie
    Currently Being Moderated
    Hi Sowmya,

    What i get from your post is, You are trying to install
    1. Repository Server with External Database System.
    2. Business Architect
    and all this three ( Repository server, Database System and Business Architect) are on the same machine.

    I would suggest the following steps.

    1. Install your external Database system (Oracle 10g..) without creating any Database Instance.
    2. Install Repository server Select the third option in datbase which say create a new instance and configure it.
    When you choose the third option Repository server creates a Database instance and configures it for itself.

    3. Install Business Architect with standard database.
    you will get LOCAL server, click on Add server and add our repository server (please dont forget to Start the Repository server before connecting :) ).

    You can do this all on same machine or all on different machines but there may be some firewall issue depending upon your netwrok configuration. so i suggest try n test all this on as same machine first.

    I will be happy to answer any more queries on this topic...


    Gaurav Sharma :)
  • 3. Re: Server Setup Error with Oracle Business Process Architect - Express Edition
    942977 Newbie
    Currently Being Moderated
    Hi GauravSharma
    I have a problem with my BPA Suite installation
    i followed this steps

    1. Install Oracle Database 11g XE (server)
    2. Install Oracle Business Publisher (server)
    2.1 I choose Oracle Database
    2.2 I choose 2nd option Configure and connect already database instance
    2.3 I created two tablespaces BPA_DATA and BPA_IDX
    3. Install BPA Architect (on my computer)

    I get local server but when i try to add a new repository server i specify the server ip address but it doesnt work

    i able to connect to XE database by sql developer
    there's something wrong?




  • Correct Answers - 10 points
  • Helpful Answers - 5 points