10 Replies Latest reply on May 11, 2009 2:08 PM by Mohammed Taj

    Package installation fail on linux

    Mohammed Taj
      hello all,

      binutils-2.14.90.0.4-26 (i386)
      control-center-2.2.0.1-10 (i386)
      glibc-2.3.2-95.3 (i686)
      glibc-common-2.3.2-95.3 (i386)
      libstdc++-3.2.3-20 (i386)
      make-3.79.1-17 (i386)
      package compat-db is not installed
      package gcc-c++ is not installed
      package gcc is not installed
      package gnome-libs is not installed
      package libstdc++-devel is not installed
      package openmotif21 is not installedpdksh-5.2.14-21 (i386)
      setarch-1.3-1 (i386)
      sysstat-5.0.5-1 (i386)
      xscreensaver-4.10-4 (i386)

      i am trying to install above "NOt installed" package
      i can able to download the all require package but whenever trying to install each package given me conflict error, when i try to upgrade then given "needed by some other package" error...

      kindly suggest what to do?

      root@erptest data1# rpm -ivch libstdc++-devel-3.4.6-8.i386.rpm
      warning: libstdc++-devel-3.4.6-8.i386.rpm: V3 DSA signature: NOKEY, key ID 73307de6
      error: Failed dependencies:
      libstdc++ = 3.4.6-8 is needed by libstdc++-devel-3.4.6-8
      root@erptest data1# rpm -Uh libstdc++-devel-3.4.6-8.i386.rpm
      warning: libstdc++-devel-3.4.6-8.i386.rpm: V3 DSA signature: NOKEY, key ID 73307de6
      error: Failed dependencies:
      libstdc++ = 3.4.6-8 is needed by libstdc++-devel-3.4.6-8
      root@erptest data1#
      root@erptest data1#

      trying to install SOA suite
      linux version: Linux erptest.xxxxxxx.local 2.4.21-4.EL #1 Fri Oct 3 18:13:58 EDT 2003 i686 i686 i386 GNU/Linux