10 Replies Latest reply: Jul 4, 2011 7:25 PM by 873187 RSS

    invalid username/password

    621707
      Oracle 11g

      When i tried to connect to database with test user from SQL prompt then i can connect to it.

      SQL> conn test/test
      connected.

      But when i tried to connect with toad with test/test it shows me invalid username/password.
      Why is it so?

      This is strange for me.
        • 1. Re: invalid username/password
          Mohammed Mehraj Hussain
          in oracle 11g , the passwords are case sensitive , so check once again in toad and try to connect with the smaller case as you used in cmd prompt
          • 2. Re: invalid username/password
            138180
            It seems to me you may have an old TOAD version. TOAD prior to 9.5 is capitalizing password strings before sending them to the database and therefore is unable to connect to Oracle 11g unless passwords in your database are capitalized as well or Oracle 11g context sensitive password feature is turned off.

            Dusan
            • 3. Re: invalid username/password
              621707
              I am aware about the case sensitivity in oracle 11g.

              So i used to copy same password which i use on SQL prompt.

              And regarding toad version i can login with other user only i face error for test user.
              • 4. Re: invalid username/password
                584650
                Don't type your password in TOAD when you try to connect and let it popup a dialog box for your password. Type the password in there and it will work. Not sure what they've done in TOAD with passwords but that is a workaround. It has to do with case sensitive passwords in 11g. I think if you change the password to all upper case it will work with TOAD.

                The parameter for this is SEC_CASE_SENSITIVE_LOGON http://download.oracle.com/docs/cd/B28359_01/server.111/b28320/initparams.htm#insertedID211

                The next problem you'll probably have in 11g is accounts expiring, because they've set a default password expiry time of accounts to 180 days:
                DEFAULT                PASSWORD_LIFE_TIME      PASSWORD 180
                DEFAULT                PASSWORD_GRACE_TIME     PASSWORD 7
                It's bound to make some applications stop working out there and catch people out.
                • 5. Re: invalid username/password
                  720731
                  This was perfect! I cannot belive my first hit when i googled this issue was your post. I had 4 dba members stumped on why toad was not working right
                  • 6. Re: invalid username/password
                    CKPT
                    hi,

                    the toad is in server machine, or different?

                    in case if different machine, make sure of tns entry.

                    can you post error message

                    Thanks.
                    • 7. Re: invalid username/password
                      mseberg
                      alter system set sec_case_sensitive_logon=False scope=spfile;

                      Bounce.

                      We have user still using Toad 8 with oracle 11
                      • 8. Re: invalid username/password
                        811024
                        Thank you, Thank you, Thank you!

                        I've been wrestling with this bit of rubbish off and on for over a MONTH! I flipped over to SQL Developer when I really needed a GUI into the database, but the experience was, uh, "not the same."
                        • 9. Re: invalid username/password
                          866510
                          This was awesome, I never post anything on any of the forums. Doing it for the first time for this brilliant answer/solution. This really works....!!!!
                          • 10. Re: invalid username/password
                            873187
                            This workaround works. TOAD 9 version is converting passwords into uppercase and with 11g, it gives username/password invalid error.