This discussion is archived
6 Replies Latest reply: Jun 27, 2013 12:57 PM by harikiran RSS

BRM Installation Failed

704977 Newbie
Currently Being Moderated
Hi...

I'm trying to install Oracle BRM 7.3 on Solaris and Unix, and everything is well until I try to run the pin_setup. I always receive the same error:
pcmdd: bad connect for orion, errno 146
Re-reading the pin.conf file "./pin.conf" since it has changed. Previous file mod time was 1244049508, now it is 1244050447
errno=<PIN_ERR_DM_CONNECT_FAILED:26> location=<Unknown pin location:0> class=<UNKNOWN:0> f
ield num=<0:0,0> recid=<0> reserved=<146>
pcmdd: bad connect for orion, errno 146

Also I have tried to start the dm_oracle and all the components running the scripts in 7.3/bin and the result is always the same:
Executing start_dm_oracle
DMm: shmbase = 0xfc800000
DMm: shm_id = 21
DMm: shmsize = 33554432 bytes
dm_malloc(25422): ...force_release...(): strange magic (0)
DM(25422) got SIGV...
Stack Trace (25422) :
/opt/portal/7.3/bin/dm_oracle:print_traceback+0x0(0xb, 0x0, 0x0, 0x0, 0x0, 0xffbfe560)
/opt/portal/7.3/bin/dm_oracle:sigsegv_handler+0x50(0xfef30034, 0xff3dafb6, 0xffbfe6bc, 0xf
fbfe694, 0xff3ee7c4, 0xff3bb7e8)
/usr/lib/libthread.so.1:_sema_post+0x4f4(0xb, 0x0, 0xffbfe6c0, 0xffbfe6a4, 0xff2b1e18, 0x0
)
/usr/lib/libthread.so.1:_sema_post+0x6a4(0x0, 0x0, 0x0, 0x40000000, 0xff2b1d98, 0x0)
/opt/portal/7.3/bin/dm_oracle:dm_back_die+0x94(0xc00, 0xffbfea60, 0x0, 0x0, 0x0, 0x0)
/opt/portal/7.3/bin/dm_oracle:dm_die+0x8c(0x0, 0x0, 0x451f0, 0xff3ef828, 0x28284, 0xc00)
/opt/portal/7.3/bin/dm_oracle:dm_back_init+0xec(0x0, 0x0, 0xffbfec4c, 0xffbfec50, 0xffbfec
48, 0xffbfebc8)
/opt/portal/7.3/bin/dm_oracle:dm_back+0xbc(0xffbfeefc, 0x44e10, 0xc00, 0x3e9e4, 0x3f3b8, 0
xffbfed30)
/opt/portal/7.3/bin/dm_oracle:make_a_child+0x35c(0x6, 0x0, 0x2000000, 0x800, 0x44e70, 0xbb
c)
DM(25420) sigchld: back end 0, pid 25422, stat 0xb00


Could you help me, please...

thanks in advance :D
  • 1. Re: BRM Installation Failed
    206307 Pro
    Currently Being Moderated
    Your question is a bit off-topic, but any way. It look like you BRM instance is not able to connect to the database and/or server. Is the database/server reachable via host and port number?

    Marc
    http://orasoa.blogspot.com
  • 2. Re: BRM Installation Failed
    704977 Newbie
    Currently Being Moderated
    Yes, It is. The database woks correctly and it is modified by the pin_setup script, but the dm_oracle does not work.
  • 3. Re: BRM Installation Failed
    206307 Pro
    Currently Being Moderated
    Create a ticket at Oracle SUpport for assistence :-(

    Marc
  • 4. Re: BRM Installation Failed
    user10494894 Newbie
    Currently Being Moderated
    Hi everyone,

    It looks like a memory crash by missing a dynamic link.

    Try to do this...

    1. Find out the dm_sm_obj

    1.1. cd $PIN_HOME/sys/dm_oracle
    1.2. grep dm_sm_obj pin.conf

    this action returns:

    - dm dm_sm_obj /opt/portal/7.3.1/sys/dm_oracle/<obj_name>.so

    (obj_name: could be dm_oracle10g.so or dm_oracle9i.so; it is based of your environment)

    2. Now, get all libraries and objects linked to dm_sm_obj

    2.1. ldd dm_oracle10g.so

    ldd command : list dynamic dependencies of executable files or shared objects.

    this action returns:

    libdmpin.so => /opt/portal/7.3.1/lib/libdmpin.so
    libBAS.so => /opt/portal/7.3.1/lib/libBAS.so
    libclntsh.so.10.1 => (file not found) << this is an example >>
    libm.so.1 => /usr/lib/libm.so.1
    .. and many more references ..

    look over "(file not found)" message;

    2.2. find out the missing dynamic dependencies

    find $ORACLE_HOME -name libclntsh.so.10.1

    this action returns:

    /opt/app/oracle/product/10.2.0/Db_1/lib32/libclntsh.so.10.1
    /opt/app/oracle/product/10.2.0/Db_1/instantclient32/libclntsh.so.10.1
    /opt/app/oracle/product/10.2.0/Db_1/lib/libclntsh.so.10.1


    if you have many <obj_name> in your system, use one by one directory; do not add all the libraries.

    2.3. adding the missing library to LD_LIBRARY_PATH

    export LD_LIBRARY_PATH=$ORACLE_HOME/lib32:$LD_LIBRARY_PATH

    2.4 Restart the Setup execution

    cd $PIN_HOME/setuo
    ./pin_setup

    if the error message is displaying againg, go back to 2.3. step and use the next library

    Do not hesitate to send a message.

    Victor.
  • 5. Re: BRM Installation Failed
    samiullah.khaan Newbie
    Currently Being Moderated

    I tried this Victor but it didnt work. The problem is still there. same DM_CONNECT_FAILED error. Please advise.

  • 6. Re: BRM Installation Failed
    harikiran Newbie
    Currently Being Moderated

    Just to verify:

     

    1) If you were using the db on the same machine, set the db env using oraenv and then the brm env using source.me.sh. then try pin_setup. Due to improper env variables, the .so files may not find the libraries properly.

    You can check the .so file's validity using ldd command.

    2) If the pin_setup failed, some of the processes will still be runnning in the background. So ensure to restart os or kill all relevant processes before retrying the same.

     

    Regards,

    Harikiran

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points