11 Replies Latest reply: Aug 17, 2010 5:00 PM by 765173 RSS

    Forms and Reports services release 3

    428468
      We currently have release 10.1.2.0.2 for our forms and reports.

      We have been advised to upgrade to release 3 to fix a vista JRE issue we were having.

      But upon reviewing this, i cant see any Forms & Reports Services on release 10.1.2.3?
        • 1. Re: Forms and Reports services release 3
          385818
          I am not sure I understand your question but maybe they meant to upgrade to R3, 10.1.3.
          • 2. Re: Forms and Reports services release 3
            Shail Goel
            FYI, 10gR3 v10.1.3.x doesn't contain Forms and Reports.
            • 3. Re: Forms and Reports services release 3
              Shail Goel
              What you probably are looking for is Oracle AS 10g Patchset 3 (10.1.2.3). You can find it on MetaLink. It is Patch #5983622. Here is the direct link to download it:

              http://updates.oracle.com/ARULink/PatchDetails/process_form?patch_num=5983622

              Thanks
              Shail
              • 4. Re: Forms and Reports services release 3
                428468
                Thanks for the responses

                We were advised to upgrade to 10.3.x due to the certification with Vista PCs and JRE 1.6.x

                Can you advise if the patchset is certified also with this JRE?

                I am unsure why they told me to upgrade if forms and reports is not possible on app server 10.3.x but that was my fear when readin some documentation.
                • 5. Re: Forms and Reports services release 3
                  Shail Goel
                  OK. Yes, Oracle Application Server 10gR3 v10.1.3 does not have Forms and Reports components/services. The latest current production version for Forms and Reports is 10gR2 v10.1.2.3.

                  Yes, 10.1.2.3 is certified to run on Vista and yes JRE 1.6 can be used on client side. Refer following certification matrix for complete details and requirements:
                  http://www.oracle.com/technology/software/products/ias/files/as_certification_r2_101202.html

                  Thanks
                  Shail
                  • 6. Re: Forms and Reports services release 3
                    428468
                    ok thanks everyone,

                    We have one last concern, basically we provide systems for many different customers, who all have their own application server setup. As you can imagine we cant do the patchset on every customers site, so we plan on staggering the upgrades as and when they are needed. Only installing the latest patchset on new installs.

                    Would there be any issues if we install this in our development environment and develop forms/reports on 10.1.2.3 for some cusotomers who are on app server 10.1.2.0.2?
                    or will this cause issues?
                    • 7. Re: Forms and Reports services release 3
                      428468
                      Following on from the thread i upgraded a test environment to see what happened. I patched fine and amended forsmweb.cfg to
                      baseHTMLjinitiator=webutiljpi.htm
                      
                      baseHTMLjpi=webutiljpi.htm
                      
                      jpi_download_page=http://java.sun.com
                      
                      jpi_classid=clsid:CAFEEFAC-0016-0000-0004-ABCDEFFEDCBA
                      
                      jpi_codebase=http://server:7777/forms/webutil/jre-6u4-windows-i586-p.exe
                      
                      jpi_mimetype=application/x-java-applet;jpi-version=1.6
                      
                      #jpi_download_page=http://server:7777/forms/webutil/jre-6u4-windows-i586-p.exe
                      
                      pageTitle=Redthorn Aventa
                      
                      separateFrame=yes
                      
                      lookAndFeel=Oracle
                      
                      colorScheme=blaf
                      
                      width=100%
                      
                      height=100%
                      
                      HTMLbodyAttrs=scroll="no" leftmargin="0" topmargin="0" marginheight="0" marginwidth="0" onload="top.moveTo(0,0);top.resizeTo(screen.availWidth,screen.availHeight);"
                      
                      imageBase=codebase
                      
                      archive_jini=frmall_jinit.jar
                      
                      WebUtilArchive=frmwebutil.jar,jacob.jar,/forms/aventa/public/aventa.jar
                      
                      WebUtilLogging=off
                      
                      WebUtilLoggingDetail=normal
                      
                      WebUtilErrorMode=Alert
                      
                      WebUtilDispatchMonitorInterval=5
                      
                      WebUtilTrustInternal=true
                      
                      WebUtilMaxTransferSize=16384
                      
                      splashScreen=startup.gif
                      
                      background=background.gif
                      
                      envFile=c:\redthorn\aventa\public\default.env
                      
                      serverApp=/forms/aventa/public/registry
                      
                      form=main.fmx
                      But when i open a system now i get the following Java error:
                      RegisterWebUtil - Loading WebUtil Version 10.1.2.0
                      
                      Loaded image: jar:http://172.16.1.118:7778/forms/aventa/public/aventa.jar!/startup.gif
                      
                      Loaded image: jar:http://172.16.1.118:7778/forms/java/frmall.jar!/oracle/forms/icons/oracle_logo_light.gif
                      
                      Loaded image: jar:http://172.16.1.118:7778/forms/aventa/public/aventa.jar!/background.gif
                      
                      proxyHost=null
                      
                      proxyPort=0
                      
                      connectMode=HTTP, native.
                      
                      Forms Applet version is : 10.1.2.3
                      
                      Loaded image: jar:http://172.16.1.118:7778/forms/java/frmall.jar!/oracle/forms/icons/ellipsis.gif
                      
                      Loaded image: jar:http://172.16.1.118:7778/forms/java/frmall.jar!/oracle/forms/icons/frame.gif
                      
                      Loaded image: jar:http://172.16.1.118:7778/forms/aventa/public/aventa.jar!/tlb_nav.gif
                      
                      Exception in thread "thread applet-oracle.forms.engine.Main-2" java.lang.NoSuchMethodError: oracle.forms.handler.IHandler.getApplet()Ljava/applet/Applet;
                      
                                      at oracle.forms.webutil.common.VBeanCommon.init(Unknown Source)
                      
                                      at oracle.forms.handler.UICommon.instantiate(Unknown Source)
                      
                                      at oracle.forms.handler.UICommon.onCreate(Unknown Source)
                      
                                      at oracle.forms.handler.JavaContainer.onCreate(Unknown Source)
                      
                                      at oracle.forms.engine.Runform.onCreateHandler(Unknown Source)
                      
                                      at oracle.forms.engine.Runform.processMessage(Unknown Source)
                      
                                      at oracle.forms.engine.Runform.processSet(Unknown Source)
                      
                                      at oracle.forms.engine.Runform.onMessageReal(Unknown Source)
                      
                                      at oracle.forms.engine.Runform.onMessage(Unknown Source)
                      
                                      at oracle.forms.engine.Runform.sendInitialMessage(Unknown Source)
                      
                                      at oracle.forms.engine.Runform.startRunform(Unknown Source)
                      
                                      at oracle.forms.engine.Main.createRunform(Unknown Source)
                      
                                      at oracle.forms.engine.Main.start(Unknown Source)
                      
                                      at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
                      
                                      at java.lang.Thread.run(Unknown Source)
                      So I dont know if this is a seperate forum question to my previous one, but it is a problem for me, anyone any ideas?

                      Main.fmx is my standard start page for my system, which works fine in previous app server/java version
                      • 8. Re: Forms and Reports services release 3
                        385818
                        I think this can be resolved by refering to metalink note 559213.1 - Referencing getApplet Causes The Error "java.lang.NoSuchMethodError" After Upgrade To 10.1.2.3.

                        You will need the make some changes in the classpath.
                        • 9. Re: Forms and Reports services release 3
                          428468
                          I reviewed this document and there it tells me to recompile my java code. No .Java files exist in our JAR only .class files.

                          We use the demos and webutil but do not use java at all other than this.

                          any other thoughts?
                          • 10. Re: Forms and Reports services release 3
                            385818
                            Since you are trying to use webutil, how about trying metalink note 561273.1 - Webutil Fails After The Installation Of Forms 10.1.2.3 ...

                            You would have to check if you have the correct frmwebutil.jar file.... or better, clearing the cache on the client so that the new .jar file is loaded.

                            Hey, I see from the log that the version of webutil that is trying to load is "RegisterWebUtil - Loading WebUtil Version 10.1.2.0", it must be loading the frmwebutil.jar file from the cache on the client, it is not loading the new one from the server, clear the cache and see what happens..

                            Edited by: Rodolfo Ferrari on Jun 11, 2009 4:15 AM
                            • 11. Re: Forms and Reports services release 3
                              765173
                              Hi All,

                              We are on 10.1.2.3 forms and reports services OAS 10.1.2.3 (patchset 3).

                              Can someone tell which version is the latest version (other than the fusion upgrade) that supports reports services.. Does 11g have it?

                              Thanks...