5 Replies Latest reply: Jun 25, 2009 11:00 AM by 708560 RSS

    ODP.NET connection not visible in VB.NET

      I'm using WinXp and VB.NET 2008. I also installed Oracle 11g Client, and ODP .NET provider (I wasn't doing any configurations later - tnsnames etc.). The problem is that i can't find the ODP connection in my VB.NET data sources, there are only .net providers for Oracle. I don't know if it has something to do with error i encountered during oracle 11g installation. The error occured because of DHCP assigned IP adress. I'll try to fix that by installing microsoft loopback driver but i don't know if that would do the trick. Or maybe it has something to do with not configuring tsnames or something else.
      I tried to connect to oracle using odbc driver and it recognized database, but it is kind a slow, and i realy need some features from ODP (object-relational features).
      Thanks in advance!
        • 1. Re: ODP.NET connection not visible in VB.NET
          gdarling - oracle
          What version of ODP did you install? If you installed off the 11106 client cd, you wont see the Oracle Data Provider for .NET show in in VS. You need to install the [ Oracle Developer Tools for Visual Studio|http://www.oracle.com/technology/software/tech/windows/odpnet/index.html]. If you already have an 11g client home, you can just add that right over the top of it.

          You should still be able to code to code ODP.net code manually and add a reference to oracle.dataaccess as well, but you need to be at least for UDT functionality anyway.

          Hope it helps,
          • 2. Re: ODP.NET connection not visible in VB.NET
            Thanks Greg! I downloaded Oracle 11g from Oracle website, and ODP - ODTwithODAC1110621 as well (latest non beta version). I think i managed to fix that problem with dhcp assigned Ip adress by installing and configuring microsoft loopback driver. But that didn't solve the problem. I still can't see ODP connection in my data source list. I don't know, maybe I missed some trivial thing. I installed the loopback driver (did some ip configuring), then installed oracle 11g client, and after that ODP. I can work with database through SQL Plus normally, and managed to manualy import oracle.data access reference. Is it possible that i missed some configuration like tnsnames or ezzconnect?
            • 3. Re: ODP.NET connection not visible in VB.NET
              gdarling - oracle

              The presense or not of ODP.NET in a data source wizard would have nothing to do with tcp, loopback, tnsnames, etc.

              What version of Visual Studio are you using?

              Where are you looking exactly that you dont see it? See, for example, the "creating a connection" section in this [Getting Started article|http://www.oracle.com/technology/obe/hol08/dotnet/buildnet/buildnet_otn.htm#t1]

              • 4. Re: ODP.NET connection not visible in VB.NET
                Yes i thought so myself, but since i didn't find any other reason for ODP's lack of presence i thought i should try that. I have Visual studio 2008 professional, and also running win XP sp2. I also read the Getting started article, but I think I did everything right, and there is still no ODP in Oracle providers, only .Net Framework provider and OLEDB provider.
                • 5. Re: ODP.NET connection not visible in VB.NET
                  Hello again! I tried to solve my problem by reinstalling oracle 11g and ODP.NET but that didn't help me. I even downloaded and installed the newest ODP.NET beta version but it still won't show in my data connections. I should say that i can access and manipulate database through sql plus without any problems. I also tried to access database in VB.NET through vb code (OracleConnection object) and it works for me. VB.NET recognizes oracle developer tools as installed product in VS about form (and VS splash screen as well). Also in the Tools menu i can see options like "Run SQL*plus script", "Oracle application debugging" and "Start Oracle External Debugger", so i guess that means VB recognized it. But I can't seem to find it in my data connections.