2 Replies Latest reply: Jun 24, 2009 2:43 PM by 19426 RSS

    orion test returned :storax_aiowait: IO returned an error 27061

    620991
      I'm using orion version 11.1.0.7.0 on Linux Centos 5.2 distribution with 2.6.24.1 kernel. Get same error when writing to multiple raw or mounted devices. Thought the problem was due to different size luns but same error occurs using multiple luns of identical size but problem also occurs when testing a single device. Insights / solutions are appreciated.

      Single device output:

      # ./orion_linux_x86-64 -testname test -run advanced -type rand -matrix row -num_large 16 -verbose -duration 15
      ORION: ORacle IO Numbers -- Version 11.1.0.7.0
      test_20090624_1336
      Test will take approximately 2 minutes
      Larger caches may take longer

      Name: /dev/sdf1 Size: 134211861504
      1 FILEs found.


      TEST START

      ----------------------------------------------

      Running point: Small=0, Large=16
      Point 1 out of 6
      Valid

      Running point: Small=1, Large=16
      Point 2 out of 6
      Valid

      Running point: Small=2, Large=16
      Point 3 out of 6
      Valid

      Running point: Small=3, Large=16
      Point 4 out of 6
      Valid

      Running point: Small=4, Large=16
      Point 5 out of 6

      storax_aiowait: IO returned an error 27061
      OER 27061: waiting for async I/Os failed
      Linux-x86_64 Error: 14: Bad address
      Additional information: -1
      Additional information: 8192
      lun_aiowait: storax_aiowait failed.
      rwbase_run_test: rwbase_reap_req failed
      rwbase_run_process: rwbase_run_test failed
      rwbase_rwluns: rwbase_run_process failed
      orion_thread_main: rw_luns failed
      Test error occurred
      Orion exiting

      fdisk -l output
      Disk /dev/sdf: 134.2 GB, 134217728000 bytes
      255 heads, 63 sectors/track, 16317 cylinders
      Units = cylinders of 16065 * 512 = 8225280 bytes

      Device Boot Start End Blocks Id System
      /dev/sdf1 1 16317 131066271 83 Linux