1 2 Previous Next 22 Replies Latest reply: Jul 24, 2009 10:29 AM by 273930 RSS

    11g forms and reports install issues

    273930
      hi all

      im installing 11g an a virtual machine (not sure if this is relevent)

      the machine has a static is is part of a domain

      ive installed weblogic, no problem but when installing 11g forms and reports it always fails at the creating ASInstance stage.

      ive tried on Windows Server 2008 32bit and 64bit, Vista 32bit and 64bit but to no avail.

      BUT

      intrestingly enough ive tried on my home laptop (vista home 32bit) and it all worked fine.

      is the hyper-v machine that the problem? surely not?

      thanks
        • 1. Re: 11g forms and reports install issues
          273930
          note, all systems report "adrci.exe not working, send to microsoft" errors when at the configuration stage.

          This happend about 10 times, but the configs all finish as "Success" until it reaches the "Creating ASInstance" stage.

          at this point if fails it thinks about it for a while, the adrci.exe error appears and if fails, saying refer to log, below is the log.

          [2009-07-14T11:38:12.764+01:00] [as] [ERROR] [] [oracle.as.provisioning] [tid: 18] [ecid: 0000I9sh3scF4EG6yzaeMG1AN5B5000009,0] [[
          oracle.as.management.opmn.optic.OpticException: Error in starting opmn server
          Unknown opmnctl exit code
               at oracle.as.management.opmn.optic.OpmnAdmin.executeCommand(OpmnAdmin.java:255)
               at oracle.as.management.opmn.optic.OpmnAdmin.startOpmnServer(OpmnAdmin.java:87)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv._createInstance(ASInstanceProv.java:251)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv.createInstance(ASInstanceProv.java:163)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv.createInstanceAndComponents(ASInstanceProv.java:114)
               at oracle.as.provisioning.engine.WorkFlowExecutor._createASInstancesAndComponents(WorkFlowExecutor.java:521)
               at oracle.as.provisioning.engine.WorkFlowExecutor.executeWLSWorkFlow(WorkFlowExecutor.java:437)
               at oracle.as.provisioning.engine.Config.executeConfigWorkflow_WLS(Config.java:870)
               at oracle.as.install.classic.ca.standard.InstanceProvisioningTask.doExecute(InstanceProvisioningTask.java:214)
               at oracle.as.install.classic.ca.standard.StandaloneTool.execute(StandaloneTool.java:50)
               at oracle.as.install.classic.ca.standard.StandardProvisionTaskList.execute(StandardProvisionTaskList.java:61)
               at oracle.as.install.classic.ca.ClassicConfigMain.doExecute(ClassicConfigMain.java:126)
               at oracle.as.install.engine.modules.configuration.client.ConfigAction.execute(ConfigAction.java:335)
               at oracle.as.install.engine.modules.configuration.action.TaskPerformer.run(TaskPerformer.java:87)
               at oracle.as.install.engine.modules.configuration.action.TaskPerformer.startConfigAction(TaskPerformer.java:104)
               at oracle.as.install.engine.modules.configuration.action.ActionRequest.perform(ActionRequest.java:15)
               at oracle.as.install.engine.modules.configuration.action.RequestQueue.perform(RequestQueue.java:63)
               at oracle.as.install.engine.modules.configuration.standard.StandardConfigActionManager.start(StandardConfigActionManager.java:158)
               at oracle.as.install.engine.modules.configuration.boot.ConfigurationExtension.kickstart(ConfigurationExtension.java:81)
               at oracle.as.install.engine.modules.configuration.ConfigurationModule.run(ConfigurationModule.java:82)
               at java.lang.Thread.run(Thread.java:619)

          ]]
          [2009-07-14T11:38:12.780+01:00] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 18] [ecid: 0000I9sh3scF4EG6yzaeMG1AN5B5000009,0] Exit code from OPMNAdmin : 255
          [2009-07-14T11:38:12.780+01:00] [as] [ERROR] [] [oracle.as.provisioning] [tid: 18] [ecid: 0000I9sh3scF4EG6yzaeMG1AN5B5000009,0] [[
          oracle.as.provisioning.engine.CfgWorkflowException
               at oracle.as.provisioning.engine.Engine.processEventResponse(Engine.java:596)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv.createInstance(ASInstanceProv.java:175)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv.createInstanceAndComponents(ASInstanceProv.java:114)
               at oracle.as.provisioning.engine.WorkFlowExecutor._createASInstancesAndComponents(WorkFlowExecutor.java:521)
               at oracle.as.provisioning.engine.WorkFlowExecutor.executeWLSWorkFlow(WorkFlowExecutor.java:437)
               at oracle.as.provisioning.engine.Config.executeConfigWorkflow_WLS(Config.java:870)
               at oracle.as.install.classic.ca.standard.InstanceProvisioningTask.doExecute(InstanceProvisioningTask.java:214)
               at oracle.as.install.classic.ca.standard.StandaloneTool.execute(StandaloneTool.java:50)
               at oracle.as.install.classic.ca.standard.StandardProvisionTaskList.execute(StandardProvisionTaskList.java:61)
               at oracle.as.install.classic.ca.ClassicConfigMain.doExecute(ClassicConfigMain.java:126)
               at oracle.as.install.engine.modules.configuration.client.ConfigAction.execute(ConfigAction.java:335)
               at oracle.as.install.engine.modules.configuration.action.TaskPerformer.run(TaskPerformer.java:87)
               at oracle.as.install.engine.modules.configuration.action.TaskPerformer.startConfigAction(TaskPerformer.java:104)
               at oracle.as.install.engine.modules.configuration.action.ActionRequest.perform(ActionRequest.java:15)
               at oracle.as.install.engine.modules.configuration.action.RequestQueue.perform(RequestQueue.java:63)
               at oracle.as.install.engine.modules.configuration.standard.StandardConfigActionManager.start(StandardConfigActionManager.java:158)
               at oracle.as.install.engine.modules.configuration.boot.ConfigurationExtension.kickstart(ConfigurationExtension.java:81)
               at oracle.as.install.engine.modules.configuration.ConfigurationModule.run(ConfigurationModule.java:82)
               at java.lang.Thread.run(Thread.java:619)
          Caused by: oracle.as.provisioning.util.ConfigException:
          Error creating ASInstance asinst_1.
          Cause:
          An internal operation has failed: Error in starting opmn server
          Unknown opmnctl exit code
          Action:
          See logs for more details.
               at oracle.as.provisioning.util.ConfigException.createConfigException(ConfigException.java:123)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv._createInstance(ASInstanceProv.java:306)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv.createInstance(ASInstanceProv.java:163)
               ... 17 more
          Caused by: oracle.as.management.opmn.optic.OpticException: Error in starting opmn server
          Unknown opmnctl exit code
               at oracle.as.management.opmn.optic.OpmnAdmin.executeCommand(OpmnAdmin.java:255)
               at oracle.as.management.opmn.optic.OpmnAdmin.startOpmnServer(OpmnAdmin.java:87)
               at oracle.as.provisioning.fmwadmin.ASInstanceProv._createInstance(ASInstanceProv.java:251)
               ... 18 more

          ]]

          Edited by: mickbarlow on Jul 14, 2009 3:44 AM
          • 2. Re: 11g forms and reports install issues
            Shail Goel
            Can you tell me what do you see in your $ORACLE_INSTANCE\diagnostics\logs\OPMN\opmn\opmn.log file?

            Also, after you get this error, try to start OPMN manually - "opmnctl start" (by launching opmnctl.bat from $ORACLE_INSTANCE\bin directory) and let me know what error does it report.

            Thanks
            Shail
            • 3. Re: 11g forms and reports install issues
              273930
              hi shail

              C:\Oracle\Middleware\asinst_1\diagnostics\logs\OPMN\opmn is empty

              and when opmnctl start, i get a windows error - This application failed to start because MSVCR71.dll was not found. Re-installing the application may fix this problem

              is this any help?

              thanks

              Edited by: mickbarlow on Jul 15, 2009 12:38 AM
              • 4. Re: 11g forms and reports install issues
                BabakSaraie
                Hi

                I had a same problem, you have to search this DLL and If you install Win2003 SP2, Microsoft .NET Frame work has been installed under your Windows folder, so you can find out this DLL under Frame work so copy msvcr71.dll to system and system32 folder, you can pass this problem.

                Best regards
                BAbak Saraie
                • 5. Re: 11g forms and reports install issues
                  273930
                  i even thought to myself, do i need DOT NET framework installed but thought dont be silly!

                  i'll give that a go.

                  thanks


                  edit: just realised im on Windows 2008, not 2003...

                  Edited by: mickbarlow on Jul 15, 2009 7:20 AM
                  • 6. Re: 11g forms and reports install issues
                    273930
                    i have put MSVCR71.dll in the system and system32 folder and this appears to have solved the problem

                    thankyou.
                    • 7. Re: 11g forms and reports install issues
                      273930
                      nearly...

                      when 'executing: opmnctl restartproc ias_component=ohs' it fails.

                      --------
                      09/07/15 16:51:13 Start process
                      --------
                      Apache.exe: Syntax error on line 1032 of C:\\Oracle\\Middleware\\asinst_1\\config\\OHS\\ohs1/httpd.conf: Syntax error on line 3 of C:/Oracle/Middleware/asinst_1/config/OHS/ohs1/mod_wl_ohs.conf: Cannot load C:/Oracle/Middleware/as_1/ohs/modules/mod_wl_ohs.so into server: The specified module could not be found.
                      • 8. Re: 11g forms and reports install issues
                        Shail Goel
                        Hum! Did you make any changes in mod_wl_ohs.conf file?

                        Can you try to comment out the following Include directive in $ORACLE_INSTANCE\config\OHS\ohs1\httpd.conf file:

                        include "${ORACLE_INSTANCE}/config/${COMPONENT_TYPE}/${COMPONENT_NAME}/mod_wl_ohs.conf"

                        And try to restart OHS.

                        Thanks
                        Shail
                        • 9. Re: 11g forms and reports install issues
                          273930
                          shail

                          i did not make any changes in mod_wl_ohs.conf , should i have done?

                          ive commented out "include "${ORACLE_INSTANCE}/config/${COMPONENT_TYPE}/${COMPONENT_NAME}/mod_wl_ohs.conf" and restarted, but still no luck.


                          C:\Oracle\Middleware\asinst_1\bin>opmnctl startproc ias-component=ohs1
                          opmnctl startproc: starting opmn managed processes...
                          ==============================================================================

                          opmn id=VISTA3211GDEV:6701
                          0 of 1 processes started.

                          ias-instance id=asinst_1
                          ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

                          ------------------------------------------------------------------------------

                          ias-component/process-type/process-set:
                          ohs1/OHS/OHS/

                          Error
                          --> Process (index=1,uid=1985679173,pid=5264)
                          failed to start a managed process after the maximum retry limit
                          Log:
                          C:\Oracle\Middleware\asinst_1\diagnostics\logs\OHS\ohs1\console~OHS~1.log


                          C:\Oracle\Middleware\asinst_1\bin>
                          • 10. Re: 11g forms and reports install issues
                            273930
                            any other ideas please?
                            • 11. Re: 11g forms and reports install issues
                              Shail Goel
                              Sorry had been busy with my day job for last few days :-)

                              Did you check what's now in console~OHS~1.log file? Does it still complain about syntax?
                              • 12. Re: 11g forms and reports install issues
                                273930
                                hi shail

                                the log file now states the following

                                --------
                                09/07/16 08:48:16 Start process
                                --------
                                Syntax error on line 18 of C:/Oracle/Middleware/asinst_1/config/OHS/ohs1/moduleconf/forms.conf:
                                Invalid command 'WebLogicCluster', perhaps misspelled or defined by a module not included in the server configuration


                                here my forms.conf


                                # Name
                                # forms.conf - Forms component Apache directives configuration file.
                                #
                                # Purpose
                                # It should include the weblogic managed server (routing) directives for
                                # the servers where Forms applications are deployed and other miscellaneous
                                # Forms component OHS directives.
                                #
                                #
                                # Remarks
                                # This file is included with the OHS configuration under
                                # $OI/config/OHS/<OHS Node Name>/moduleconf sub-directory.
                                #
                                #
                                <Location /forms>
                                SetHandler weblogic-handler
                                WebLogicCluster VISTA3211GDEV.redthorn.local:9001
                                DynamicServerList OFF
                                </Location>



                                thanks, your help is MUCH appreciated... :D
                                • 13. Re: 11g forms and reports install issues
                                  Shail Goel
                                  OK so it is a Forms installation. Your forms.conf file looks ok. But for this to work, you have to have mod_wl_ohs included/loaded. Un-comment the include directive in httpd.conf.

                                  Can you check if C:/Oracle/Middleware/as_1/ohs/modules/mod_wl_ohs.so is present in your environment?

                                  Thanks
                                  Shail
                                  • 14. Re: 11g forms and reports install issues
                                    7024
                                    Hi All,
                                    I also faced these issues.

                                    I am using a virtual machine. My host machine is Windows 7 64 bit and I created Virtual Machine using the Windows 7 virtual machine feature. I had faced the same issue with VMware VM also so it is not the problem with VM i think.


                                    for the opmn not starting problem i did the following
                                    After the setup step i copied the msvcr7.dll to the as_1/bin folder. I had this file in my host machine (Win 7 64 bit) I copied this and then opmn started working.

                                    Now for the mod_wl_ohs problem
                                    I copied the mod_wl_22.so from the C:\Oracle\Middleware\wlserver_10.3\server\plugin\win\32 into the C:\Oracle\Middleware\as_1\ohs\modules folder and renamed it to mod_wl_ohs.so and restarted the ohs process by using the command

                                    opmnctl startproc process-type=OHS

                                    and everything started

                                    After this i started the WLS_FORMS managed server using the Start menu

                                    and I was able to open the test form using the ohs

                                    http://192.168.0.183:8888/forms/frmservlet?form=test.fmx

                                    I hope this helps.

                                    Regards
                                    Regee

                                    Edited by: regeechacko on Jul 21, 2009 12:40 PM
                                    1 2 Previous Next